flatpak-tests_1.4.3-1_i386.deb


Advertisement

Description

flatpak-tests - Application deployment framework for desktop apps (tests)

Property Value
Distribution Ubuntu 19.10 (Eoan Ermine)
Repository Ubuntu Universe i386
Package filename flatpak-tests_1.4.3-1_i386.deb
Package name flatpak-tests
Package version 1.4.3
Package release 1
Package architecture i386
Package type deb
Category universe/misc
Homepage http://flatpak.org/
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 413.86 KB
Installed size 1.97 MB
Flatpak installs, manages and runs sandboxed desktop application bundles.
See the flatpak package for a more comprehensive description.
This package contains automated tests.

Alternatives

Package Version Architecture Repository
flatpak-tests_1.4.3-1_amd64.deb 1.4.3 amd64 Ubuntu Universe
flatpak-tests - - -

Requires

Name Value
attr -
ca-certificates -
desktop-file-utils -
flatpak = 1.4.3-1
gnupg -
gtk-update-icon-cache -
hicolor-icon-theme -
libappstream-glib8 >= 0.5.13
libarchive13 >= 3.0.4
libc6 >= 2.28
libdconf1 >= 0.26.0
libflatpak0 >= 1.3.4
libglib2.0-0 >= 2.55.1
libgpgme11 >= 1.1.6
libjson-glib-1.0-0 >= 1.2.0
libostree-1-1 >= 2019.2
libseccomp2 >= 1.0.1
libsoup2.4-1 >= 2.41.90
libsystemd0 -
libxau6 -
libxml2 >= 2.7.4
ostree >= 2019.2
shared-mime-info -

Download

Type URL
Mirror archive.ubuntu.com
Binary Package flatpak-tests_1.4.3-1_i386.deb
Source Package flatpak

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install flatpak-tests deb package:
    # sudo apt-get install flatpak-tests

Changelog

2019-09-19 - Simon McVittie <smcv@debian.org>
flatpak (1.4.3-1) unstable; urgency=medium
* New upstream stable release
- d/p/Don-t-register-polkit-agent-if-we-cannot-connect-to-syste.patch,
d/p/tests-Skip-tests-that-use-system-helper-if-uid-or-gid-is-.patch:
drop patches, applied upstream
* Remove redundant --libexecdir, no longer needed with compat level 12
2019-07-09 - Simon McVittie <smcv@debian.org>
flatpak (1.4.2-2) unstable; urgency=medium
* Upload to unstable
* d/gbp.conf: Return to debian/master branch
* Use debhelper-compat 12
* Standards-Version: 4.4.0 (no changes required)
2019-07-02 - Simon McVittie <smcv@debian.org>
flatpak (1.4.2-1) experimental; urgency=medium
* New upstream release
* d/p/Don-t-register-polkit-agent-if-we-cannot-connect-to-syste.patch:
Add proposed patch to avoid crashing if the system bus is unavailable,
working around policykit-1 bug #923046
* d/salsa-ci.yml: Request standard CI on salsa.debian.org
* d/p/tests-Skip-tests-that-use-system-helper-if-uid-or-gid-is-.patch:
Avoid testing the system helper if uid or gid is zero.
The system helper refuses to run in test mode if it has privileges,
but some CI systems (currently including salsa-ci) run as uid or
gid 0 in a disposable container.
* d/test.sh: Don't run tests under linux32, even if reprotest did the
build under linux32
* d/test.sh: Don't output non-test logs (notably
debian/output/reprotest.log on salsa-ci) after running tests
2019-06-13 - Simon McVittie <smcv@debian.org>
flatpak (1.4.1-1) experimental; urgency=high
* New upstream stable release
- This reverts an unintended ABI break in 1.4.0.
2019-05-28 - Simon McVittie <smcv@debian.org>
flatpak (1.4.0-1) experimental; urgency=medium
* New upstream stable release
2019-05-10 - Simon McVittie <smcv@debian.org>
flatpak (1.3.4-1) experimental; urgency=medium
* New upstream development release
- Incompatible change: /etc/flatpak/remotes.d/*.conf are no longer
read, and are superseded by /etc/flatpak/remotes.d/*.flatpakrepo
* Require libostree 2019.2, for OSTREE_REPO_PULL_FLAGS_MIRROR
* Install flatpak-docker-seccomp.json to /u/s/d/flatpak/examples.
This seccomp profile can be used to configure a Docker container to
allow bubblewrap and Flatpak to be run, with some caveats:
- The host kernel must allow unprivileged user namespace creation
(for example Debian with sysctl kernel.unprivileged_userns_clone=1,
or recent Ubuntu in its default configuration)
- Use the seccomp profile
(docker run --security-opt seccomp=flatpak-docker-seccomp.json)
- Make the host system /proc visible in the container
(docker run -v=/proc:/host/proc)
- Run flatpak as an ordinary user in the container, not as root
* d/copyright: Update
* d/libflatpak0.symbols: Update
2019-04-27 - Simon McVittie <smcv@debian.org>
flatpak (1.3.3-1) experimental; urgency=medium
* New upstream development release
- Drop patches that were applied upstream
- d/libflatpak0.symbols: Update

See Also

Package Description
flatpak-xdg-utils-tests_1.0.0-1_i386.deb as-installed tests for flatpak-xdg-utils
flatpak-xdg-utils_1.0.0-1_i386.deb xdg-open and xdg-email reimplementation for containerized apps
flatpak_1.4.3-1_i386.deb Application deployment framework for desktop apps
flatzinc_6.1.0-2_i386.deb constraint problem modelling language
flawfinder_1.31-1_all.deb examines source code and looks for security weaknesses
fldiff_1.1+0-6_i386.deb graphical diff program
fldigi_4.1.06-2_i386.deb digital modem program for hamradio operators
flent_1.3.0-1_all.deb FLExible Network Tester for bufferbloat testing and more
flex-old-doc_2.5.4a-10ubuntu2_all.deb Documentation for an old flex (a fast lexical analyzer generator)
flex-old_2.5.4a-10ubuntu2_i386.deb Old version of the fast lexical analyzer generator
flexbackup_1.2.1-6.4_all.deb Flexible backup tool for small to medium sized installations
flexbar_3.5.0-2_i386.deb flexible barcode and adapter removal for sequencing platforms
flexc++_2.07.06-1_i386.deb Flex-style scanner generator for C++
flexloader_0.03-3build1_i386.deb utility to configure SRAM based ALTERA devices
flexml_1.9.6-5_i386.deb Fast validating XML processors and applications generator
Advertisement
Advertisement