python3-paramiko_2.6.0-1_all.deb


Advertisement

Description

python3-paramiko - Make ssh v2 connections (Python 3)

Property Value
Distribution Ubuntu 19.10 (Eoan Ermine)
Repository Ubuntu Main i386
Package filename python3-paramiko_2.6.0-1_all.deb
Package name python3-paramiko
Package version 2.6.0
Package release 1
Package architecture all
Package type deb
Category python
Homepage https://github.com/paramiko/paramiko/
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 119.01 KB
Installed size 703.00 KB
"Paramiko" is a combination of the Esperanto words for "paranoid" and "friend".
It's a module for Python 2.7/3.4+ that implements the SSH2 protocol for secure
(encrypted and authenticated) connections to remote machines. Unlike SSL (aka
TLS), SSH2 protocol does not require hierarchical certificates signed by a
powerful central authority. You may know SSH2 as the protocol that replaced
Telnet and rsh for secure access to remote shells, but the protocol also
includes the ability to open arbitrary channels to remote services across the
encrypted tunnel (this is how SFTP works, for example).
This is the Python 3 version of the package.

Alternatives

Package Version Architecture Repository
python3-paramiko_2.6.0-1_all.deb 2.6.0 all Ubuntu Main
python3-paramiko - - -

Requires

Name Value
python3-bcrypt >= 3.1.3
python3-cryptography >= 2.5
python3-nacl >= 1.0.1
python3:any -

Download

Type URL
Mirror archive.ubuntu.com
Binary Package python3-paramiko_2.6.0-1_all.deb
Source Package paramiko

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install python3-paramiko deb package:
    # sudo apt-get install python3-paramiko

Changelog

2019-08-17 - Sandro Tosi <morph@debian.org>
paramiko (2.6.0-1) unstable; urgency=medium
* New upstream release; Closes: #924178, #851474, #892860
* Acknowledge NMU: Closes: #892859, #904635
* debian/control
- move under DPMT umbrella (with current maintainers blessing)
- bump b-d on cryptograpy to >= 2.5
- drop obsolete X-Python*-Version fields
- bump Standards-Version to 4.4.0 (no changes needed)
- update Vcs-* fields to point to DPMT repo
- update long description; Closes: #766893
* debian/copyright
- convert to machine-parsable format
- add myself to copyright (previous contributions were not mentioned)
- update to new upstream release
* debian/patches/remove_pytest_relaxed.patch
- refresh patch
* debian/source/lintian-overrides
- update for new jquery.js
2018-12-01 - Gaudenz Steinlin <gaudenz@debian.org>
paramiko (2.4.2-0.1) unstable; urgency=medium
* New upstream version 2.4.2 (Closes: #892859)
* Fix autopkgtests (switch to pytest) (Closes: #904635)
2018-03-07 - Jeremy T. Bouse <jbouse@debian.org>
paramiko (2.4.0-1) unstable; urgency=medium
* Imported Upstream version 2.4.0
* Update build for 2.4.0 (Closes: #871249, #882322, #698075)
2016-06-08 - Jeremy T. Bouse <jbouse@debian.org>
paramiko (2.0.0-1) unstable; urgency=medium
* Imported Upstream version 2.0.0 (Closes: #826737)
* Correct email address for patch
* Update Standards-Version to 3.9.8, no changes needed
* Update doc file names to match upstream changes
* Update crypto dependencies
* Clean up debian/control, debian/rules and lintian issues
* Upstream bug tracking check (Closes: #783313, #754851)
2016-04-11 - Jeremy T. Bouse <jbouse@debian.org>
paramiko (1.16.0-1) unstable; urgency=medium
* Imported Upstream version 1.16.0 (Closes: #816618)
* Update debian/patches
* Add Python pyasn1 and gssapi build depends (Closes: #804582)
* Use upstream test script
* Update debian/watch to use pypi.debian.net
* Fix dh_auto_test override
* Update Standards-Version to 3.9.7, no changes needed
* Remove unneeded option
2015-10-25 - Jeremy T. Bouse <jbouse@debian.org>
paramiko (1.15.3-1) unstable; urgency=medium
* Imported Upstream version 1.15.3
2015-07-08 - Jeremy T. Bouse <jbouse@debian.org>
paramiko (1.15.2-1) unstable; urgency=medium
* Imported Upstream version 1.15.2
* Update Standards-Version (no changes needed)
2014-09-23 - Jeremy T. Bouse <jbouse@debian.org>
paramiko (1.15.1-1) unstable; urgency=medium
* Imported Upstream version 1.15.1
* Update gbp.conf section headers for newer version
* Move from epydoc to sphinx for doc build
* Add patch to localize generated documentation
* Implement pybuild buildsystem
* debian/gbp.conf: Update postbuild for git-buildpackage
* Imported Upstream version 1.15.0
* Specify minimum required version of ecdsa
2014-08-28 - Jeremy T. Bouse <jbouse@debian.org>
paramiko (1.14.1-1) unstable; urgency=medium
[ Thomas Kluyver ]
* Add autopkgtest information
[ Jeremy T. Bouse ]
* Include upstream GitHub Pull Request #352 to fix RC bug.
Thanks to Jelmer Vernooij <jelmer> (Closes: #750517, #755910)
* Imported Upstream version 1.14.1
* Revert "Include upstream GitHub Pull Request #352 to fix RC bug"
as it was included in upstream bug fix release 1.14.1 to remove
the regression introduced into 1.14.0.
2014-05-27 - Jeremy T. Bouse <jbouse@debian.org>
paramiko (1.14.0-2) unstable; urgency=low
* Add extend-diff-ignore to debian/source/options.
Thanks to Thomas Goirand <zigo>
* Add python-ecdsa to Build-Depends (Closes: #702571)
* Add Python 3 support to build.
Thanks to Thomas Goirand <zigo> (Closes: #697600, #749512)
* Clean up build environment

See Also

Package Description
python3-parted_3.11.2-11_i386.deb Python 3 interface for libparted
python3-passlib_1.7.1-1_all.deb comprehensive password hashing framework
python3-paste_3.1.0+dfsg1-1_all.deb tools for using a Web Server Gateway Interface stack - Python 3.x
python3-pastedeploy_2.0.1-1_all.deb load, configure, and compose WSGI applications and servers - Python 3.x
python3-pastescript_2.0.2-2_all.deb create file layouts for Python3 packages and serve webapps
python3-pbr_5.1.1-0ubuntu3_all.deb inject useful and sensible default behaviors into setuptools - Python 3.x
python3-pecan_1.3.3-0ubuntu2_all.deb WSGI object-dispatching web framework - Python 3.x
python3-pep8_1.7.1-3_all.deb Python PEP 8 code style checker - Python 3
python3-petname_2.6-0ubuntu1_all.deb python3 library for generating pronouncable, memorable, pet names
python3-pexpect_4.6.0-1_all.deb Python 3 module for automating interactive applications
python3-pil.imagetk_6.1.0-1_i386.deb Python Imaging Library - ImageTk Module (Python3)
python3-pil_6.1.0-1_i386.deb Python Imaging Library (Python3)
python3-pint_0.9-1_all.deb define, operate and manipulate physical quantities - Python 3.x
python3-pkg-resources_41.1.0-1_all.deb Package Discovery and Resource Access using pkg_resources
python3-ply_3.11-3_all.deb Lex and Yacc implementation for Python3
Advertisement
Advertisement