zsh_5.7.1-1ubuntu2_amd64.deb


Advertisement

Description

zsh - shell with lots of features

Property Value
Distribution Ubuntu 19.10 (Eoan Ermine)
Repository Ubuntu Main amd64
Package filename zsh_5.7.1-1ubuntu2_amd64.deb
Package name zsh
Package version 5.7.1
Package release 1ubuntu2
Package architecture amd64
Package type deb
Category shells
Homepage https://www.zsh.org/
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 682.69 KB
Installed size 2.25 MB
Zsh is a UNIX command interpreter (shell) usable as an
interactive login shell and as a shell script command
processor. Of the standard shells, zsh most closely resembles
ksh but includes many enhancements. Zsh has command-line editing,
built-in spelling correction, programmable command completion,
shell functions (with autoloading), a history mechanism, and a
host of other features.

Alternatives

Package Version Architecture Repository
zsh_5.7.1-1ubuntu2_i386.deb 5.7.1 i386 Ubuntu Main
zsh - - -

Requires

Name Value
libc6 >= 2.29
libcap2 >= 1:2.10
libtinfo6 >= 6
zsh-common = 5.7.1-1ubuntu2

Download

Type URL
Mirror archive.ubuntu.com
Binary Package zsh_5.7.1-1ubuntu2_amd64.deb
Source Package zsh

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install zsh deb package:
    # sudo apt-get install zsh

Changelog

2019-09-05 - Matthias Klose <doko@ubuntu.com>
zsh (5.7.1-1ubuntu2) eoan; urgency=medium
* No-change upload with strops.h and sys/strops.h removed in glibc.
2019-04-29 - Steve Langasek <steve.langasek@ubuntu.com>
zsh (5.7.1-1ubuntu1) eoan; urgency=low
* Merge from Debian unstable.  Remaining changes:
- debian/zshrc: Enable completions by default, unless skip_global_compinit
is set.
- Support cross-compiling:
- Adjust upstream autoconf cross-compile default fallbacks.
- Skip zcompile when cross-compiling.
- Add libelf-dev dependency.
* Dropped changes, included upstream:
- debian/patches/CVE-2018-0502-and-CVE-2018-13259.patch:
fix in Src/exec.c and add test Test/A05execution.ztst.
- Cherrypick upstream patch to fix A05execution.ztst test case. Resolves
autopkgtest failure.
2019-02-05 - Axel Beckert <abe@debian.org>
zsh (5.7.1-1) unstable; urgency=medium
* [8b89d0d5,ea17cf89] New upstream bugfix release
+ [205859e6] Drop fix-vcs-info-p4.patch, fixed upstream
[ Daniel Shahaf ]
* [14d26260] d/upstream/signing-key.asc: Add the 5.7 RM's signing key.
2019-01-27 - Michael Prokop <mika@debian.org>
zsh (5.7-2) unstable; urgency=low
[ Frank Terbeck ]
* [cb6fba8] Fix perforce detection in vcs-info
2019-01-25 - Axel Beckert <abe@debian.org>
zsh (5.7-1) unstable; urgency=low
* [9799d0f9,7b75d97c] New upstream release
+ Upload to unstable again.
2019-01-05 - Axel Beckert <abe@debian.org>
zsh (5.6.2-test-3-1) experimental; urgency=low
* [325fceab,7e6a3d734] New upstream release candidate
+ [f64cd71d] Fixes FTBFS on 32-bits architectures
* [2c01967c] debian/pkg-zsh-workflow-new-upstream-release.md fine-tuning
* [30825099] Bump debhelper compatibility level to 12.
+ Use b-d on "debhelper-compat (= 12)" instead of debian/compat.
* [087d6045] Change shebang path in example script to Debian's zsh path.
* [6cbe67e6] Make autopkgtest pass by including config.modules in
zsh-dev. (Test/V07pcre.ztst now tries to access ../config.modules to
check if the PCRE module was enabled and needs to be tested. The test
emits a warning on STDERR if ../config.modules is not found.)
2018-12-24 - Axel Beckert <abe@debian.org>
zsh (5.6.2-test-2-1) experimental; urgency=low
* [9dbde9e,bf8b7f7] New upstream release candidate
+ [dc2bfeee] Have V07pcre fail if PCRE was enabled by configure
(config.modules) but failed to load for any reason. (Closes: #909114)
+ [44b0a973] Remove all cherry-picked patches.
+ [01c3153e] debian/rules: Build zshbuiltins.1 out-of-tree like the
rest.
[ Daniel Shahaf ]
* [19fed9e6] debian/upstream/signing-key.asc: Add the upstream signing
key used since 5.5.1-test-1.
[ Ondřej Nový ]
* [b402fc2e] debian/tests: Use AUTOPKGTEST_TMP instead of ADTTMP.
[ Axel Beckert ]
* [24256bb7] Add zsh-autosuggestions to list of zsh-related packages in
bug-script.
* [1239bb28] Declare compliance with Debian Policy 4.3.0. (No other
changes were necessary.)
* [06946d43] debian/TODO.md: Mention that switching zsh-dev to arch:all
is non-trivial.
* [e0798c2f] Declare debian/pkg-zsh-workflow.md as outdated.  Add
debian/pkg-zsh-workflow-new-upstream-release.md as massively reduced
replacement.
2018-09-19 - Axel Beckert <abe@debian.org>
zsh (5.6.2-3) unstable; urgency=medium
* [92175749] Revert "Switch from the deprecated libpcre3 to the newer
(!) libpcre2." libpcre2 is not a drop-in replacement and not detected
by zsh's configure script. (Closes: #909084, reopens LP#1792544)
2018-09-18 - Axel Beckert <abe@debian.org>
zsh (5.6.2-2) unstable; urgency=medium
[ Axel Beckert ]
* [a5db2473] Switch from the deprecated libpcre3 to the newer (!)
libpcre2. (LP: #1792544)
[ Daniel Shahaf ]
* [3d8f4eee] Cherry-pick 551ff842 from upstream: Another attachtty()
fix. (Closes: #908818)

See Also

Package Description
zvmcloudconnector-common_2.0.0~b1~git2019062011.4fc9142.really.1.4.1-0ubuntu2_all.deb z/VM Development SDK for managing z/VM - Common Files
Advertisement
Advertisement