libkf5config-dev_5.56.0-0ubuntu1.1_i386.deb


Advertisement

Description

libkf5config-dev - configuration settings framework for Qt

Property Value
Distribution Ubuntu 19.04 (Disco Dingo)
Repository Ubuntu Updates Universe i386
Package filename libkf5config-dev_5.56.0-0ubuntu1.1_i386.deb
Package name libkf5config-dev
Package version 5.56.0
Package release 0ubuntu1.1
Package architecture i386
Package type deb
Category universe/libdevel
Homepage https://projects.kde.org/projects/frameworks/kconfig
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 35.48 KB
Installed size 254.00 KB
KConfig provides an advanced configuration system. It is made of two
parts: KConfigCore and KConfigGui.
KConfigCore provides access to the configuration files themselves. It
features:
- centralized definition: define your configuration in an XML file
and use `kconfig_compiler` to generate classes to read and write
configuration entries.
- lock-down (kiosk) support.
KConfigGui provides a way to hook widgets to the configuration so
that they are automatically initialized from the configuration and
automatically propagate their changes to their respective
configuration files.
This package is part of KDE Frameworks 5.
This package contains the development files.,

Alternatives

Package Version Architecture Repository
libkf5config-dev_5.62.0-0ubuntu1~ubuntu19.04~ppa1_amd64.deb 5.62.0 amd64 Kubuntu Backports
libkf5config-dev_5.62.0-0ubuntu1~ubuntu19.04~ppa1_i386.deb 5.62.0 i386 Kubuntu Backports
libkf5config-dev_5.56.0-0ubuntu1.1_amd64.deb 5.56.0 amd64 Ubuntu Updates Universe
libkf5config-dev_5.56.0-0ubuntu1_i386.deb 5.56.0 i386 Ubuntu Universe
libkf5config-dev_5.56.0-0ubuntu1_amd64.deb 5.56.0 amd64 Ubuntu Universe
libkf5config-dev - - -

Requires

Name Value
libkf5config-bin = 5.56.0-0ubuntu1.1
libkf5config-dev-bin = 5.56.0-0ubuntu1.1
libkf5configcore5 = 5.56.0-0ubuntu1.1
libkf5configgui5 = 5.56.0-0ubuntu1.1
qtbase5-dev >= 5.8.0~

Replaces

Name Value
libkf5config-bin-dev << 5.47.0~

Download

Type URL
Mirror archive.ubuntu.com
Binary Package libkf5config-dev_5.56.0-0ubuntu1.1_i386.deb
Source Package kconfig

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libkf5config-dev deb package:
    # sudo apt-get install libkf5config-dev

Changelog

2019-08-09 - Rik Mills <rikmills@kubuntu.org>
kconfig (5.56.0-0ubuntu1.1) disco-security; urgency=medium
* SECURITY UPDATE: malicious .desktop files (and others) would execute
code (LP: #1839432).
- debian/patches/CVE-2019-14744.diff: removes the affected feature as
currently 'unused'.
- CVE-2019-14744
2019-03-09 - José Manuel Santamaría Lema <panfaust@gmail.com>
kconfig (5.56.0-0ubuntu1) disco; urgency=medium
* New upstream release (5.56.0)
2019-02-13 - Rik Mills <rikmills@kubuntu.org>
kconfig (5.55.0-0ubuntu1) disco; urgency=medium
* New upstream release (5.55.0)
2019-01-13 - Rik Mills <rikmills@kubuntu.org>
kconfig (5.54.0-0ubuntu1) disco; urgency=medium
* New upstream release (5.54.0)
2018-12-09 - José Manuel Santamaría Lema <panfaust@gmail.com>
kconfig (5.53.0-0ubuntu1) disco; urgency=medium
* New upstream release (5.53.0)
2018-11-22 - José Manuel Santamaría Lema <panfaust@gmail.com>
kconfig (5.52.0-0ubuntu1) disco; urgency=medium
[ Rik Mills ]
* New upstream release (5.51.0)
[ José Manuel Santamaría Lema ]
* New upstream release (5.52.0)
* Update symbols files
2018-09-10 - Rik Mills <rikmills@kubuntu.org>
kconfig (5.50.0-0ubuntu1) cosmic; urgency=medium
* New upstream release (5.50.0)
2018-08-21 - Rik Mills <rikmills@kubuntu.org>
kconfig (5.49.0-0ubuntu1) cosmic; urgency=medium
[ Rik Mills ]
* New upstream release (5.48.0)
* New upstream release (5.49.0)
[ José Manuel Santamaría Lema ]
* Update symbols files for GCC 8
* Move away from dhmk and set compat level to 11 in order to reduce
delta with Debian
2018-06-26 - Rik Mills <rikmills@kubuntu.org>
kconfig (5.47.0-0ubuntu2) cosmic; urgency=medium
* Restore debian breaks/replaces for libkf5config-dev against
libkf5config-bin-dev, which did not get carried accross in previous
merge
2018-06-14 - Rik Mills <rikmills@kubuntu.org>
kconfig (5.47.0-0ubuntu1) cosmic; urgency=medium
* New upstream release (5.47.0)
[ José Manuel Santamaría Lema ]
* Merge with debian, notes:
- keep using dhmk and debhelper compat level = 9, see:
https://phabricator.kde.org/w/kubuntu/black-operations/pyramid/
- remove KConfigCompiler_Test-Update-test_signal.h.ref-to-follow-t.patch
and kubuntu_disable-broken-tests.patch since the problem is already fixed
in upstream code

See Also

Package Description
libkf5config-doc_5.56.0-0ubuntu1.1_all.deb configuration settings framework for Qt (documentation)
libkf5configcore5_5.56.0-0ubuntu1.1_i386.deb configuration settings framework for Qt
libkf5configgui5_5.56.0-0ubuntu1.1_i386.deb configuration settings framework for Qt
libkfile4_4.14.38-0ubuntu6.1_i386.deb File Selection Dialog Library for KDE Platform
libkhtml5_4.14.38-0ubuntu6.1_i386.deb KHTML Web Content Rendering Engine
libkidletime4_4.14.38-0ubuntu6.1_i386.deb library to provide information about idle time
libkimproxy4_4.14.38-0ubuntu6.1_i386.deb Instant Messaging Interface Library for the KDE Platform
libkio5_4.14.38-0ubuntu6.1_i386.deb Network-enabled File Management Library for the KDE Platform
libkjsapi4_4.14.38-0ubuntu6.1_i386.deb KJS API Library for the KDE Development Platform
libkjsembed4_4.14.38-0ubuntu6.1_i386.deb library for binding JavaScript objects to QObjects
libkmediaplayer4_4.14.38-0ubuntu6.1_i386.deb KMediaPlayer Interface for the KDE Platform
libknewstuff2-4_4.14.38-0ubuntu6.1_i386.deb "Get Hot New Stuff" v2 Library for the KDE Platform
libknewstuff3-4_4.14.38-0ubuntu6.1_i386.deb "Get Hot New Stuff" v3 Library for the KDE Platform
libknotifyconfig4_4.14.38-0ubuntu6.1_i386.deb library for configuring KDE Notifications
libkntlm4_4.14.38-0ubuntu6.1_i386.deb NTLM Authentication Library for the KDE Platform
Advertisement
Advertisement