librte-pmd-axgbe18.11_18.11.2-1ubuntu0.19.04.1_amd64.deb


Advertisement

Description

librte-pmd-axgbe18.11 - Data Plane Development Kit (librte-pmd-axgbe runtime library)

Property Value
Distribution Ubuntu 19.04 (Disco Dingo)
Repository Ubuntu Updates Universe amd64
Package filename librte-pmd-axgbe18.11_18.11.2-1ubuntu0.19.04.1_amd64.deb
Package name librte-pmd-axgbe18.11
Package version 18.11.2
Package release 1ubuntu0.19.04.1
Package architecture amd64
Package type deb
Category universe/libs
Homepage https://dpdk.org/doc/guides/nics/axgbe.html
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 26.46 KB
Installed size 105.00 KB
DPDK is a set of libraries for fast packet processing. Applications run
in user-space and communicate directly with dedicated network interfaces.
This package contains the runtime libraries for librte-pmd-axgbe.

Alternatives

Package Version Architecture Repository
librte-pmd-axgbe18.11_18.11.2-1ubuntu0.19.04.1_i386.deb 18.11.2 i386 Ubuntu Updates Universe
librte-pmd-axgbe18.11_18.11-6_i386.deb 18.11 i386 Ubuntu Universe
librte-pmd-axgbe18.11_18.11-6_amd64.deb 18.11 amd64 Ubuntu Universe
librte-pmd-axgbe18.11 - - -

Requires

Name Value
libbsd0 >= 0.0
libc6 >= 2.4
libnuma1 >= 2.0.11
librte-bus-pci18.11 >= 17.11
librte-bus-vdev18.11 >= 17.11
librte-cmdline18.11 >= 16.04
librte-eal18.11 >= 17.05
librte-ethdev18.11 >= 18.05
librte-kvargs18.11 >= 16.04
librte-mbuf18.11 >= 16.04
librte-mempool18.11 >= 16.07~rc1
librte-net18.11 >= 16.11
librte-pci18.11 >= 17.11
librte-ring18.11 >= 16.04

Conflicts

Name Value
libdpdk0 -

Download

Type URL
Mirror archive.ubuntu.com
Binary Package librte-pmd-axgbe18.11_18.11.2-1ubuntu0.19.04.1_amd64.deb
Source Package dpdk

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install librte-pmd-axgbe18.11 deb package:
    # sudo apt-get install librte-pmd-axgbe18.11

Changelog

2019-07-12 - Christian Ehrhardt <christian.ehrhardt@canonical.com>
dpdk (18.11.2-1ubuntu0.19.04.1) disco; urgency=medium
* Make DPDK LTS release available in Disco (LP: #1836365)
- includes a fix for mlx rdma-core dependencies (LP: #1820957)
2019-07-04 - Christian Ehrhardt <christian.ehrhardt@canonical.com>
dpdk (18.11.2-1) experimental; urgency=medium
[ Christian Ehrhardt ]
* Merge stable update to 18.11.2; For a list of changes see
http://doc.dpdk.org/guides-18.11/rel_notes/release_18_11.html#id1
- refresh 0004-build-bump-minimum-Meson-version-to-0.47.1.patch for 18.11.2
- drop changes upstream in 18.11.2
0002-build-use-generic-march-on-arm64-when-using-default.patch
lp-1827102-kni-fix-build-with-Linux-5.1.patch
[ Santiago Ruano Rincón ]
* debian/rules: clean doc files
2019-05-08 - Christian Ehrhardt <christian.ehrhardt@canonical.com>
dpdk (18.11.1-3) experimental; urgency=medium
* d/control: add dependencies to libdpdk-dev: libelf-dev and libjansson-dev
to avoid pkg-config issues
* d/control: drop unused build dependency to libcap-dev
2019-05-03 - Christian Ehrhardt <christian.ehrhardt@canonical.com>
dpdk (18.11.1-2) experimental; urgency=medium
[ Christian Ehrhardt ]
* d/control: drop shlibs:Depends from dpdk as it has no binaries anymore
* d/p/lp-1827102-kni-fix-build-with-Linux-5.1.patch fix kni DKMS build with
Linux 5.1 kernels (LP: #1827102)
[ Luca Boccassi ]
* Bump Standards-Version to 4.3.0, no changes.
2019-04-16 - Luca Boccassi <bluca@debian.org>
dpdk (18.11.1-1) experimental; urgency=medium
[ Christian Ehrhardt ]
* Merge stable update to 18.11.1; For a list of changes see
https://doc.dpdk.org/guides-18.11/rel_notes/release_18_11.html
- refresh 0004-build-bump-minimum-Meson-version-to-0.47.1.patch for 18.11.1
- drop changes upstream in 18.11.1
0001-doc-fix-garbage-text-in-generated-HTML-guides.patch
0003-build-mention-march-in-pkg-config-description.patch
0001-kni-fix-build-for-dev_open-in-Linux-5.0.patch
0002-kni-fix-build-for-igb_ndo_bridge_setlink-in-Linux-5..patch
* d/control: fix usability issue with mlx PMDs which might need rdma-core
to be installed. In most cases users will want this, to be able to
drop rdma-core if unwanted in some cases this is only a recommends added
to librte-pmd-mlx4-18.11 and librte-pmd-mlx5-18.11 (Closes: #925141)
2019-02-07 - Luca Boccassi <bluca@debian.org>
dpdk (18.11-6) unstable; urgency=medium
[ Luca Boccassi ]
* Add NEWS entry to list changes to dpdk-dev. (Closes: #921043)
[ Christian Ehrhardt ]
* d/control: ensure break relationships are backportable (Closes: #921042)
* d/p/*kni-fix-build*: fix build with kernel 5.0 (LP: #1814919)
2019-01-30 - Luca Boccassi <bluca@debian.org>
dpdk (18.11-5) unstable; urgency=medium
[ Christian Ehrhardt ]
* d/control: add librte-mempool-ring to the list of default libs that dpdk
Recommends. This ensures a generally functional mempool backend by default
but stays configurable (remove librte-mempool-ring and/or add other
librte-mempool packages).
[ Luca Boccassi ]
* libdpdk-dev: depend on libipsec-mb-dev as its linker flag is in
pkg-config's static list.

See Also

Package Description
librte-pmd-bbdev-null18.11_18.11.2-1ubuntu0.19.04.1_amd64.deb Data Plane Development Kit (librte-pmd-bbdev-null runtime library)
librte-pmd-bnx2x18.11_18.11.2-1ubuntu0.19.04.1_amd64.deb Data Plane Development Kit (librte-pmd-bnx2x runtime library)
librte-pmd-bnxt18.11_18.11.2-1ubuntu0.19.04.1_amd64.deb Data Plane Development Kit (librte-pmd-bnxt runtime library)
librte-pmd-caam-jr18.11_18.11.2-1ubuntu0.19.04.1_amd64.deb Data Plane Development Kit (librte-pmd-caam-jr runtime library)
librte-pmd-ccp18.11_18.11.2-1ubuntu0.19.04.1_amd64.deb Data Plane Development Kit (librte-pmd-ccp runtime library)
librte-pmd-crypto-scheduler18.11_18.11.2-1ubuntu0.19.04.1_amd64.deb Data Plane Development Kit (librte_pmd_crypto_scheduler runtime library)
librte-pmd-cxgbe18.11_18.11.2-1ubuntu0.19.04.1_amd64.deb Data Plane Development Kit (librte-pmd-cxgbe runtime library)
librte-pmd-dpaa-event18.11_18.11.2-1ubuntu0.19.04.1_amd64.deb Data Plane Development Kit (librte-pmd-dpaa runtime library)
librte-pmd-dpaa-sec18.11_18.11.2-1ubuntu0.19.04.1_amd64.deb Data Plane Development Kit (librte-pmd-dpaa runtime library)
librte-pmd-dpaa18.11_18.11.2-1ubuntu0.19.04.1_amd64.deb Data Plane Development Kit (librte-pmd-dpaa runtime library)
librte-pmd-dpaa2-18.11_18.11.2-1ubuntu0.19.04.1_amd64.deb Data Plane Development Kit (librte-pmd-dpaa runtime library)
librte-pmd-dpaa2-cmdif18.11_18.11.2-1ubuntu0.19.04.1_amd64.deb Data Plane Development Kit (librte-pmd-dpaa runtime library)
librte-pmd-dpaa2-event18.11_18.11.2-1ubuntu0.19.04.1_amd64.deb Data Plane Development Kit (librte-pmd-dpaa runtime library)
librte-pmd-dpaa2-qdma18.11_18.11.2-1ubuntu0.19.04.1_amd64.deb Data Plane Development Kit (librte-pmd-dpaa runtime library)
librte-pmd-dpaa2-sec18.11_18.11.2-1ubuntu0.19.04.1_amd64.deb Data Plane Development Kit (librte-pmd-dpaa runtime library)
Advertisement
Advertisement