libkcmutils4_4.14.38-0ubuntu6.1_amd64.deb


Advertisement

Description

libkcmutils4 - utility classes for using KCM modules

Property Value
Distribution Ubuntu 19.04 (Disco Dingo)
Repository Ubuntu Updates Universe amd64
Package filename libkcmutils4_4.14.38-0ubuntu6.1_amd64.deb
Package name libkcmutils4
Package version 4.14.38
Package release 0ubuntu6.1
Package architecture amd64
Package type deb
Category universe/libs
Homepage http://www.kde.org/
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 93.60 KB
Installed size 471.00 KB
This library provides utility classes for using KCM modules
in a KDE application.
This package is part of the KDE Development Platform libraries module.

Alternatives

Package Version Architecture Repository
libkcmutils4_4.14.38-0ubuntu6.1_i386.deb 4.14.38 i386 Ubuntu Updates Universe
libkcmutils4_4.14.38-0ubuntu6_i386.deb 4.14.38 i386 Ubuntu Universe
libkcmutils4_4.14.38-0ubuntu6_amd64.deb 4.14.38 amd64 Ubuntu Universe
libkcmutils4 - - -

Requires

Name Value
libc6 >= 2.14
libkdecore5 = 4:4.14.38-0ubuntu6.1
libkdeui5 = 4:4.14.38-0ubuntu6.1
libqt4-dbus >= 4:4.8.0
libqtcore4 >= 4:4.8.0
libqtgui4 >= 4:4.8.0
libstdc++6 >= 5

Download

Type URL
Mirror archive.ubuntu.com
Binary Package libkcmutils4_4.14.38-0ubuntu6.1_amd64.deb
Source Package kde4libs

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libkcmutils4 deb package:
    # sudo apt-get install libkcmutils4

Changelog

2019-08-12 - Paulo Flabiano Smorigo <pfsmorigo@canonical.com>
kde4libs (4:4.14.38-0ubuntu6.1) disco-security; urgency=medium
* SECURITY UPDATE: malicious .desktop files (and others) would execute
code (LP: #1839432).
- debian/patches/CVE-2019-14744.patch: remove support for $(...) in
config keys with [$e] marker.
- debian/patches/kdelibs-4.14.38-openssl-1.1.patch: Make kssl compile
against OpenSSL 1.1.0
- CVE-2019-14744
2018-07-31 - Rik Mills <rikmills@kubuntu.org>
kde4libs (4:4.14.38-0ubuntu6) cosmic; urgency=medium
* Sync some Debian changes:
- Drop autopkgtests
- Update watch file to the location of the last releases.
2018-07-31 - Rik Mills <rikmills@kubuntu.org>
kde4libs (4:4.14.38-0ubuntu5) cosmic; urgency=medium
* Build without strigi (libstreamanalyser) support. Permits following
Debian's removal of src:strigi, which is FTBFS against ffmpeg 4.
2018-05-12 - Rik Mills <rikmills@kubuntu.org>
kde4libs (4:4.14.38-0ubuntu4) cosmic; urgency=medium
* No-change rebuild against latest openexr
2018-02-10 - Dimitri John Ledkov <xnox@ubuntu.com>
kde4libs (4:4.14.38-0ubuntu3) bionic; urgency=medium
* Build against libssl1.0-dev, as otherwise autopkgtests fail.
2017-12-02 - Rik Mills <rikmills@kubuntu.org>
kde4libs (4:4.14.38-0ubuntu2) bionic; urgency=medium
* Drop kdelibs5-plugins depends on katepart as nothing uses this now
2017-12-01 - Rik Mills <rikmills@kubuntu.org>
kde4libs (4:4.14.38-0ubuntu1) bionic; urgency=medium
* New upstream release (4.14.38)
* Refresh all patches
* Drop upstream_fix_build_with_cmake_3.9.diff no longer required
2017-08-20 - Rik Mills <rikmills@kubuntu.org>
kde4libs (4:4.14.34-0ubuntu2) artful; urgency=medium
* We only support x86 and KDE4 is heading for the bin soon, so skip
tests on other archictectures
2017-08-18 - José Manuel Santamaría Lema <panfaust@gmail.com>
kde4libs (4:4.14.34-0ubuntu1) artful; urgency=medium
[ José Manuel Santamaría Lema ]
* New upstream release (4.14.32)
* New upstream release (4.14.33)
* Use the build-needed restriction for testsuite instead of rebuilding
the package in debian/tests/testsuite; this change needs pkg-kde-tools
0.15.24ubuntu2~ or higher
* Add kubuntu_disable_failing_tests.diff
* Update symbols files
* Improve the way the 'testsuite' autopkgtest is executed:
- create HOME directory
- set locale as 'C'
- add tzdata to Depends
* New upstream release (4.14.34)
[ Rik Mills ]
* debian/patches: add upstream_fix_build_with_cmake_3.9.diff to fix
FTBFS with cmake 3.9
* Update symbols from build logs for GCC7
2017-05-13 - Rik Mills <rikmills@kubuntu.org>
kde4libs (4:4.14.30-0ubuntu2) artful; urgency=medium
* SECURITY UPDATE: Local privilege escalation (LP: #1689759)
- debian/patches/kauth-local-privilege-esc-CVE-2017-8422.patch
- Thanks to Sebastian Krahmer for reporting this issue,
Albert Astals Cid for fixing this issue.
- CVE-2017-8422

See Also

Package Description
libkde3support4_4.14.38-0ubuntu6.1_amd64.deb KDE 3 Support Library for the KDE 4 Platform
libkdeclarative5_4.14.38-0ubuntu6.1_amd64.deb declarative library for plasma
libkdecore5_4.14.38-0ubuntu6.1_amd64.deb KDE Platform Core Library
libkdesu5_4.14.38-0ubuntu6.1_amd64.deb Console-mode Authentication Library for the KDE Platform
libkdeui5_4.14.38-0ubuntu6.1_amd64.deb KDE Platform User Interface Library
libkdewebkit5_4.14.38-0ubuntu6.1_amd64.deb KDE WebKit Library
libkdnssd4_4.14.38-0ubuntu6.1_amd64.deb DNS-SD Protocol Library for the KDE Platform
libkemoticons4_4.14.38-0ubuntu6.1_amd64.deb utility classes to deal with emoticon themes
libkf5config-bin_5.56.0-0ubuntu1.1_amd64.deb configuration settings framework for Qt
libkf5config-data_5.56.0-0ubuntu1.1_all.deb configuration settings framework for Qt
libkf5config-dev-bin_5.56.0-0ubuntu1.1_amd64.deb configuration settings framework for Qt -- binary package
libkf5config-dev_5.56.0-0ubuntu1.1_amd64.deb configuration settings framework for Qt
libkf5config-doc_5.56.0-0ubuntu1.1_all.deb configuration settings framework for Qt (documentation)
libkf5configcore5_5.56.0-0ubuntu1.1_amd64.deb configuration settings framework for Qt
libkf5configgui5_5.56.0-0ubuntu1.1_amd64.deb configuration settings framework for Qt
Advertisement
Advertisement