dosbox_0.74-2-3+deb10u1build0.19.04.1_amd64.deb


Advertisement

Description

dosbox - x86 emulator with Tandy/Herc/CGA/EGA/VGA/SVGA graphics, sound and DOS

Property Value
Distribution Ubuntu 19.04 (Disco Dingo)
Repository Ubuntu Updates Universe amd64
Package filename dosbox_0.74-2-3+deb10u1build0.19.04.1_amd64.deb
Package name dosbox
Package version 0.74
Package release 2-3+deb10u1build0.19.04.1
Package architecture amd64
Package type deb
Category universe/otherosfs
Homepage http://www.dosbox.com/
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 888.25 KB
Installed size 2.74 MB
DOSBox is a x86 emulator with Tandy/Hercules/CGA/EGA/VGA/SVGA graphics,
sound and DOS. It's been designed to run old DOS games on platforms that
don't support it.
The following legacy sound devices are emulated: PC Speaker, Creative
CMS/Gameblaster, Tandy 3 voice, Adlib, Sound Blaster Pro/16,
Disney Soundsource and a Gravis Ultrasound. MPU-401 is forwarded to
the host.

Alternatives

Package Version Architecture Repository
dosbox_0.74-2-3+deb10u1build0.19.04.1_i386.deb 0.74 i386 Ubuntu Updates Universe
dosbox_0.74-2-3_i386.deb 0.74 i386 Ubuntu Universe
dosbox_0.74-2-3_amd64.deb 0.74 amd64 Ubuntu Universe
dosbox - - -

Requires

Name Value
libasound2 >= 1.0.16
libc6 >= 2.29
libgcc1 >= 1:3.0
libgl1 -
libpng16-16 >= 1.6.2-1
libsdl-net1.2 -
libsdl-sound1.2 >= 1.0.1
libsdl1.2debian >= 1.2.11
libstdc++6 >= 5.2
libx11-6 -
zlib1g >= 1:1.1.4

Download

Type URL
Mirror archive.ubuntu.com
Binary Package dosbox_0.74-2-3+deb10u1build0.19.04.1_amd64.deb
Source Package dosbox

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install dosbox deb package:
    # sudo apt-get install dosbox

Changelog

2019-07-15 - Steve Beattie <sbeattie@ubuntu.com>
dosbox (0.74-2-3+deb10u1build0.19.04.1) disco-security; urgency=medium
* fake sync from Debian
2019-07-08 - Stephen Kitt <skitt@debian.org>
dosbox (0.74-2-3+deb10u1) buster-security; urgency=medium
* Apply upstream fixes for two security issues:
- CVE-2019-7165: long lines in batch files would overflow the parsing
buffer;
- CVE-2019-12594: programs running inside DOSBox could access /proc.
along with a number of buffer overrun fixes. Closes: #931222.
2019-01-22 - Stephen Kitt <skitt@debian.org>
dosbox (0.74-2-3) unstable; urgency=medium
* Enable the debugger and provide it in a separate dosbox-debug
package.
* Add a number of spelling fixes.
* Update debian/copyright.
* Standards-Version 4.3.0, no change required.
2018-12-23 - Stephen Kitt <skitt@debian.org>
dosbox (0.74-2-2) unstable; urgency=medium
[ Ondřej Nový ]
* d/watch: Use https protocol
[ Stephen Kitt ]
* Apply upstream fix to allow grabbing the mouse again with recent
X.org. Closes: #907271.
2018-09-11 - Stephen Kitt <skitt@debian.org>
dosbox (0.74-2-1) unstable; urgency=medium
* New upstream bug-fix release, obsoleting
ftbfs624976_upstream_svn3691.patch, fix-ftbfs-format-security.patch,
wine-move-z-mount-svn3736.patch, and
wine-style-namemangling-svn3742.patch.
* Adopt the package. Closes: #876772.
* Allow hyphens in versions.
* Point to the Salsa repository.
* Switch to debhelper compatibility level 11.
* Set “Rules-Requires-Root: no”.
* Clean up whitespace and the package description.
* Standards-Version 4.2.1, no further change required.
2015-10-13 - Graham Inggs <ginggs@debian.org>
dosbox (0.74-4.2) unstable; urgency=medium
* non-maintainer upload
* allow dosbox to satisfy dependencies from other architectures
(Multi-Arch: foreign) - thanks Jens Reyer (Closes: #801615)
2015-10-07 - Graham Inggs <ginggs@debian.org>
dosbox (0.74-4.1) unstable; urgency=medium
* non-maintainer upload
* improve interoperability with Wine (Closes: #789092)
- allow Wine to move Z: mount (SVN r3736)
- work with Wine-style name mangling (SVN r3742)
* compile with -D_FILE_OFFSET_BITS=64 to fix mount failure
with inodes > 2^32 - thanks Vladislav Naumov (Closes: #792886)
2014-10-09 - Jan Dittberner <jandd@debian.org>
dosbox (0.74-4) unstable; urgency=medium
* bump debhelper dependency and compat level to 9 to automatically enable
hardening flags
* restrict watch file to source tarballs
* add debian/patches/fix-ftbfs-format-security.patch to fix build
failure with -Werror=format-security
* use autotools-dev
- debian/control: add autotools-dev to Build-Depends
- debian/rules: add --with autotools_dev to dh invocation
* use canonical Vcs-* URLs
* add Keywords to debian/dosbox.desktop, fix German comment spelling
* apply patches by Rodrigo Silva to add larger multiple size icons and
remove old pixmap icon (Closes: #756739) and remove old pre-XDG menu file
(Closes: #619013)
* switch debian/copyright to machine readable format
* bump Standards-Version to 3.9.6 (no changes)
2012-03-05 - Jan Dittberner <jandd@debian.org>
dosbox (0.74-3) unstable; urgency=low
* Fix manpage bugs by updating debian/patches/fix_manpage_errors.patch
(Closes: #644936)
* Bump Standards-Version to 3.9.3 (no changes)
* change Build-Depends, change from libpng12-dev to libpng-dev (Closes:
#662303)
2011-05-02 - Jan Dittberner <jandd@debian.org>
dosbox (0.74-2) unstable; urgency=low
* Fix "FTBFS: ../../include/dos_inc.h:543:78: error: expected primary-
expression before ',' token" add patch from upstream SVN as
debian/patches/ftbfs624976_upstream_svn3691.patch (Closes: #624976)
* fix another spelling error in man page in
debian/patches/fix_manpage_errors.patch
* Bump Standards-Version to 3.9.2 (No changes needed) in
debian/control
* fix description synopsis to not start with an article

See Also

Package Description
dovecot-auth-lua_2.3.4.1-1ubuntu2.4_amd64.deb secure POP3/IMAP server - Lua authentication plugin
dovecot-gssapi_2.3.4.1-1ubuntu2.4_amd64.deb secure POP3/IMAP server - GSSAPI support
dovecot-ldap_2.3.4.1-1ubuntu2.4_amd64.deb secure POP3/IMAP server - LDAP support
dovecot-lmtpd_2.3.4.1-1ubuntu2.4_amd64.deb secure POP3/IMAP server - LMTP server
dovecot-lucene_2.3.4.1-1ubuntu2.4_amd64.deb secure POP3/IMAP server - Lucene support
dovecot-managesieved_2.3.4.1-1ubuntu2.4_amd64.deb secure POP3/IMAP server - ManageSieve server
dovecot-mysql_2.3.4.1-1ubuntu2.4_amd64.deb secure POP3/IMAP server - MySQL support
dovecot-pgsql_2.3.4.1-1ubuntu2.4_amd64.deb secure POP3/IMAP server - PostgreSQL support
dovecot-sieve_2.3.4.1-1ubuntu2.4_amd64.deb secure POP3/IMAP server - Sieve filters support
dovecot-solr_2.3.4.1-1ubuntu2.4_amd64.deb secure POP3/IMAP server - Solr support
dovecot-sqlite_2.3.4.1-1ubuntu2.4_amd64.deb secure POP3/IMAP server - SQLite support
dovecot-submissiond_2.3.4.1-1ubuntu2.4_amd64.deb secure POP3/IMAP server - mail submission agent
dpdk-dev_18.11.2-1ubuntu0.19.04.1_amd64.deb Data Plane Development Kit (dev tools)
dpdk-igb-uio-dkms_18.11.2-1ubuntu0.19.04.1_amd64.deb Data Plane Development Kit (igb uio dkms)
dpdk-rte-kni-dkms_18.11.2-1ubuntu0.19.04.1_amd64.deb Data Plane Development Kit (rte kni dkms)
Advertisement
Advertisement