linux-tools-5.0.0-1012-aws_5.0.0-1012.13_amd64.deb


Advertisement

Description

linux-tools-5.0.0-1012-aws - Linux kernel version specific tools for version 5.0.0-1012

Property Value
Distribution Ubuntu 19.04 (Disco Dingo)
Repository Ubuntu Updates Main amd64
Package filename linux-tools-5.0.0-1012-aws_5.0.0-1012.13_amd64.deb
Package name linux-tools-5.0.0-1012-aws
Package version 5.0.0
Package release 1012.13
Package architecture amd64
Package type deb
Category devel
Homepage -
License -
Maintainer Ubuntu Kernel Team <kernel-team@lists.ubuntu.com>
Download size 1.90 KB
Installed size 259.00 KB
This package provides the architecture dependant parts for kernel
version locked tools (such as perf and x86_energy_perf_policy) for
version 5.0.0-1012 on
64 bit x86.

Alternatives

Package Version Architecture Repository
linux-tools-5.0.0-1012-aws - - -

Requires

Name Value
linux-aws-tools-5.0.0-1012 -

Download

Type URL
Mirror archive.ubuntu.com
Binary Package linux-tools-5.0.0-1012-aws_5.0.0-1012.13_amd64.deb
Source Package linux-aws

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install linux-tools-5.0.0-1012-aws deb package:
    # sudo apt-get install linux-tools-5.0.0-1012-aws

Changelog

2019-08-02 - Kleber Sacilotto de Souza <kleber.souza@canonical.com>
linux-aws (5.0.0-1012.13) disco; urgency=medium
* add support for Amazon Graviton PCIe controller (LP: #1834962)
- PCI: al: Add Amazon Annapurna Labs PCIe host controller driver
- genirq/msi: Add a new field in msi_desc to store an IOMMU cookie
- iommu/dma-iommu: Split iommu_dma_map_msi_msg() in two parts
- irqchip/gicv2m: Don't map the MSI page in gicv2m_compose_msi_msg()
- SAUCE: irqchip/gic: Add support for Amazon Graviton variant of GICv3+GICv2m
- SAUCE: [aws] arm64: acpi/pci: invoke _DSM whether to preserve firmware PCI
setup
- [Config] aws: set CONFIG_IRQ_MSI_IOMMU=y
* CVE-2019-1125
- x86/cpufeatures: Carve out CQM features retrieval
- x86/cpufeatures: Combine word 11 and 12 into a new scattered features word
- x86/speculation: Prepare entry code for Spectre v1 swapgs mitigations
- x86/speculation: Enable Spectre v1 swapgs mitigations
- x86/entry/64: Use JMP instead of JMPQ
- x86/speculation/swapgs: Exclude ATOMs from speculation through SWAPGS
* linux-aws builds modules which are not shipped (LP: #1836706)
- [Packaging] Start shipping modules-extra

See Also

Package Description
linux-tools-5.0.0-1012-azure_5.0.0-1012.12_amd64.deb Linux kernel version specific tools for version 5.0.0-1012
linux-tools-5.0.0-1013-gcp_5.0.0-1013.13_amd64.deb Linux kernel version specific tools for version 5.0.0-1013
linux-tools-5.0.0-1013-kvm_5.0.0-1013.14_amd64.deb Linux kernel version specific tools for version 5.0.0-1013
linux-tools-5.0.0-1014-aws_5.0.0-1014.16_amd64.deb Linux kernel version specific tools for version 5.0.0-1014
linux-tools-5.0.0-1014-azure_5.0.0-1014.14_amd64.deb Linux kernel version specific tools for version 5.0.0-1014
linux-tools-5.0.0-1015-gcp_5.0.0-1015.15_amd64.deb Linux kernel version specific tools for version 5.0.0-1015
linux-tools-5.0.0-1015-kvm_5.0.0-1015.16_amd64.deb Linux kernel version specific tools for version 5.0.0-1015
linux-tools-5.0.0-1016-aws_5.0.0-1016.18_amd64.deb Linux kernel version specific tools for version 5.0.0-1016
linux-tools-5.0.0-1016-azure_5.0.0-1016.17_amd64.deb Linux kernel version specific tools for version 5.0.0-1016
linux-tools-5.0.0-1017-gcp_5.0.0-1017.17_amd64.deb Linux kernel version specific tools for version 5.0.0-1017
linux-tools-5.0.0-1017-kvm_5.0.0-1017.18_amd64.deb Linux kernel version specific tools for version 5.0.0-1017
linux-tools-5.0.0-1018-aws_5.0.0-1018.20_amd64.deb Linux kernel version specific tools for version 5.0.0-1018
linux-tools-5.0.0-1018-azure_5.0.0-1018.19_amd64.deb Linux kernel version specific tools for version 5.0.0-1018
linux-tools-5.0.0-1019-aws_5.0.0-1019.21_amd64.deb Linux kernel version specific tools for version 5.0.0-1019
linux-tools-5.0.0-1019-kvm_5.0.0-1019.20_amd64.deb Linux kernel version specific tools for version 5.0.0-1019
Advertisement
Advertisement