libpoppler-glib8_0.74.0-0ubuntu1.3_amd64.deb


Advertisement

Description

libpoppler-glib8 - PDF rendering library (GLib-based shared library)

Property Value
Distribution Ubuntu 19.04 (Disco Dingo)
Repository Ubuntu Updates Main amd64
Package filename libpoppler-glib8_0.74.0-0ubuntu1.3_amd64.deb
Package name libpoppler-glib8
Package version 0.74.0
Package release 0ubuntu1.3
Package architecture amd64
Package type deb
Category libs
Homepage http://poppler.freedesktop.org/
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 102.96 KB
Installed size 423.00 KB
Poppler is a PDF rendering library based on Xpdf PDF viewer.
This package provides the GLib-based shared library for applications
using the GLib interface to Poppler.

Alternatives

Package Version Architecture Repository
libpoppler-glib8_0.74.0-0ubuntu1.3_i386.deb 0.74.0 i386 Ubuntu Updates Main
libpoppler-glib8_0.74.0-0ubuntu1_i386.deb 0.74.0 i386 Ubuntu Main
libpoppler-glib8_0.74.0-0ubuntu1_amd64.deb 0.74.0 amd64 Ubuntu Main
libpoppler-glib8 - - -

Requires

Name Value
libc6 >= 2.14
libcairo2 >= 1.12.0
libfreetype6 >= 2.2.1
libglib2.0-0 >= 2.41
libpoppler85 = 0.74.0-0ubuntu1.3
libstdc++6 >= 5.2

Download

Type URL
Mirror archive.ubuntu.com
Binary Package libpoppler-glib8_0.74.0-0ubuntu1.3_amd64.deb
Source Package poppler

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libpoppler-glib8 deb package:
    # sudo apt-get install libpoppler-glib8

Files

Path
/usr/lib/x86_64-linux-gnu/libpoppler-glib.so.8
/usr/lib/x86_64-linux-gnu/libpoppler-glib.so.8.12.0
/usr/share/doc/libpoppler-glib8/changelog.Debian.gz
/usr/share/doc/libpoppler-glib8/copyright

Changelog

2019-08-07 - Leonidas S. Barbosa <leo.barbosa@canonical.com>
poppler (0.74.0-0ubuntu1.3) disco-security; urgency=medium
* SECURITY UPDATE: Divide-by-zero error
- debian/patches/CVE-2019-14494.patch: Fix crash on broken file
in poppler/SplashOutputDev.cc.
- CVE-2019-14494
2019-06-26 - Marc Deslauriers <marc.deslauriers@ubuntu.com>
poppler (0.74.0-0ubuntu1.2) disco-security; urgency=medium
* SECURITY UPDATE: DoS via crafted PDF file
- debian/patches/CVE-2018-20662.patch: check XRef's Catalog for being a
Dict in utils/pdfunite.cc.
- CVE-2018-20662
* SECURITY UPDATE: buffer underwrite in ImageStream::getLine()
- debian/patches/CVE-2019-9200.patch: add check to poppler/Stream.cc.
- CVE-2019-9200
* SECURITY UPDATE: buffer over-read in downsample_row_box_filter
- debian/patches/CVE-2019-9631-1.patch: compute correct coverage values
for box filter in poppler/CairoRescaleBox.cc.
- debian/patches/CVE-2019-9631-2.patch: constrain number of cycles in
rescale filter in poppler/CairoRescaleBox.cc.
- CVE-2019-9631
* SECURITY UPDATE: dict marking mishandling
- debian/patches/CVE-2019-9903.patch: fix stack overflow on broken file
in poppler/PDFDoc.cc.
- CVE-2019-9903
* SECURITY UPDATE: heap-based buffer over-read
- debian/patches/CVE-2019-10872.patch: restrict filling of overlapping
boxes in splash/Splash.cc.
- CVE-2019-10872
* SECURITY UPDATE: NULL pointer dereference in SplashClip::clipAALine
- debian/patches/CVE-2019-10873.patch: make sure the index of
allIntersections we access is valid in splash/SplashXPathScanner.cc.
- CVE-2019-10873
* SECURITY UPDATE: buffer over-read in JPXStream::init
- debian/patches/CVE-2019-12293.patch: fail gracefully if not all
components have the same WxH in poppler/JPEG2000Stream.cc.
- CVE-2019-12293
2019-05-21 - Sebastien Bacher <seb128@ubuntu.com>
poppler (0.74.0-0ubuntu1.1) disco; urgency=medium
* debian/patches/git_unicode_search.patch:
- backport a fix for a regression on case-insensitive search
(lp: #1829785)
2019-02-21 - Sebastien Bacher <seb128@ubuntu.com>
poppler (0.74.0-0ubuntu1) disco; urgency=medium
* New upstream version, remove the patches included in the update
* Updated for the soname change libpoppler82 -> libpoppler85
* debian/rules: ENABLE_XPDF_HEADERS -> ENABLE_UNSTABLE_API_ABI_HEADERS
2019-02-11 - Leonidas S. Barbosa <leo.barbosa@canonical.com>
poppler (0.71.0-2ubuntu4) disco; urgency=medium
* SECURITY UPDATE: Denial of service
- debian/patches/CVE-2019-7310.patch: fix in
poppler/XRef.cc.
- CVE-2019-7310
2019-01-28 - Leonidas S. Barbosa <leo.barbosa@canonical.com>
poppler (0.71.0-2ubuntu3) disco; urgency=medium
* SECURITY UPDATE: infinite recursion via crafted file
- debian/patches/CVE-2018-16646.patch: avoid cycles in PDF parsing in
poppler/Parser.cc, poppler/XRef.h. This patch also includes the
regression fix in check entry.
- CVE-2018-16646
* SECURITY UPDATE: denial of service via reachable abort
- debian/patches/CVE-2018-19058.patch: check for stream before calling
stream methods when saving an embedded file in poppler/FileSpec.cc.
- CVE-2018-19058
* SECURITY UPDATE: denial of service via out-of-bounds read
- debian/patches/CVE-2018-19059.patch: check for valid embedded file
before trying to save it in utils/pdfdetach.cc.
- CVE-2018-19059
* SECURITY UPDATE: denial of service via NULL pointer dereference
- debian/patches/CVE-2018-19060.patch: check for valid file name of
embedded file in utils/pdfdetach.cc.
- CVE-2018-19060

See Also

Package Description
libpoppler-private-dev_0.74.0-0ubuntu1.3_amd64.deb PDF rendering library -- private development files
libpoppler85_0.74.0-0ubuntu1.3_amd64.deb PDF rendering library
libpq-dev_11.5-0ubuntu0.19.04.1_amd64.deb header files for libpq5 (PostgreSQL library)
libpq5_11.5-0ubuntu0.19.04.1_amd64.deb PostgreSQL C client library
libprocps-dev_3.3.15-2ubuntu2.1_amd64.deb library for accessing process information from /proc
libprocps7_3.3.15-2ubuntu2.1_amd64.deb library for accessing process information from /proc
libpspell-dev_0.60.7~20110707-6ubuntu0.1_amd64.deb Development files for applications with pspell support
libpython2.7-dev_2.7.16-2ubuntu0.2_amd64.deb Header files and a static library for Python (v2.7)
libpython2.7-minimal_2.7.16-2ubuntu0.2_amd64.deb Minimal subset of the Python language (version 2.7)
libpython2.7-stdlib_2.7.16-2ubuntu0.2_amd64.deb Interactive high-level object-oriented language (standard library, version 2.7)
libpython2.7_2.7.16-2ubuntu0.2_amd64.deb Shared Python runtime library (version 2.7)
libpython3.7-dev_3.7.3-2ubuntu0.2_amd64.deb Header files and a static library for Python (v3.7)
libpython3.7-minimal_3.7.3-2ubuntu0.2_amd64.deb Minimal subset of the Python language (version 3.7)
libpython3.7-stdlib_3.7.3-2ubuntu0.2_amd64.deb Interactive high-level object-oriented language (standard library, version 3.7)
libpython3.7_3.7.3-2ubuntu0.2_amd64.deb Shared Python runtime library (version 3.7)
Advertisement
Advertisement