libgif7_5.1.4-3ubuntu0.1_amd64.deb


Advertisement

Description

libgif7 - library for GIF images (library)

Property Value
Distribution Ubuntu 19.04 (Disco Dingo)
Repository Ubuntu Updates Main amd64
Package filename libgif7_5.1.4-3ubuntu0.1_amd64.deb
Package name libgif7
Package version 5.1.4
Package release 3ubuntu0.1
Package architecture amd64
Package type deb
Category libs
Homepage http://giflib.sourceforge.net/
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 30.08 KB
Installed size 72.00 KB
GIFLIB is a package of portable tools and library routines for working with GIF
images.
This package contains the library.

Alternatives

Package Version Architecture Repository
libgif7_5.1.4-3ubuntu0.1_i386.deb 5.1.4 i386 Ubuntu Updates Main
libgif7_5.1.4-3_i386.deb 5.1.4 i386 Ubuntu Main
libgif7_5.1.4-3_amd64.deb 5.1.4 amd64 Ubuntu Main
libgif7 - - -

Requires

Name Value
libc6 >= 2.14

Download

Type URL
Mirror archive.ubuntu.com
Binary Package libgif7_5.1.4-3ubuntu0.1_amd64.deb
Source Package giflib

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libgif7 deb package:
    # sudo apt-get install libgif7

Changelog

2019-08-19 - Leonidas S. Barbosa <leo.barbosa@canonical.com>
giflib (5.1.4-3ubuntu0.1) disco-security; urgency=medium
* SECURITY UPDATE: Denial of service
- debian/patches/CVE-2018-11490.patch: adding checks
in DGifDecompressLine in order to avoid a heap buffer overflow and
a denial of service in lib/dgif_lib.c.
- CVE-2018-11490
* SECURITY UPDATE: Divide-by-zero
- debian/patches/CVE-2019-15133.patch: adding checks bounds
in lib/dgif_lib.c.
- CVE-2019-15133
2018-06-05 - Salvatore Bonaccorso <carnil@debian.org>
giflib (5.1.4-3) unstable; urgency=medium
* QA upload.
* Heap-based buffer overflow in util/gif2rgb.c (CVE-2016-3977)
(Closes: #820526)
2018-02-11 - Andreas Metzler <ametzler@debian.org>
giflib (5.1.4-2) unstable; urgency=low
* QA upload.
* New vcs repository generated from a) "gbp import-dscs --debsnap giflib",
b) old repo on alioth c) private repo for changes > 5.1.4-0.4.
Update Vcs* in debian/control, pointing to salsa.
* [lintian] Delete trailing whitespace in changelog.
2017-08-01 - Andreas Metzler <ametzler@debian.org>
giflib (5.1.4-1) unstable; urgency=low
* QA upload.
* Set maintainer to qa.
* Build with hardening=+bindnow.
* Switch to automatic dbgsym packages.
* 03-spelling_fixes.patch: Fix another two typoes found by lintian.
* Bump standards-version - No changes.
* Use debhelper 10 compat, which uses autoreconf and --parallel by default.
2016-10-18 - Paolo Greppi <paolo.greppi@libpf.com>
giflib (5.1.4-0.4) unstable; urgency=medium
* Non-maintainer upload.
* Remove patch/issue87 because that is already present in upstream.
* Remove patch/04-fprintf_format_error.patch which was commented out anyway.
* Install manpages supplied by upstream
Closes: #809439.
2016-06-10 - Matthias Klose <doko@debian.org>
giflib (5.1.4-0.3) unstable; urgency=medium
* Non-maintainer upload.
* CVE-2016-3977: gif2rgb: heap buffer overflow. Closes: #820526.
2016-05-08 - Matthias Klose <doko@debian.org>
giflib (5.1.4-0.2) unstable; urgency=medium
* Non-maintainer upload.
* Drop the local fix for issue #81, solved differently upstream.
Closes: #823481.
2016-04-25 - Matthias Klose <doko@debian.org>
giflib (5.1.4-0.1) unstable; urgency=medium
* Non-maintainer upload.
* New upstream version.
* Security issues already fixed in 5.1.2: CVE-2016-3977.
Closes: #820594, #820526.
* Update symbols file.
2016-04-15 - Gianfranco Costamagna <locutusofborg@debian.org>
giflib (5.1.2-0.3) unstable; urgency=medium
* Non-maintainer upload.
[ Tobias Frost ]
* debian/patches/ef0cb9b4be572262b49fbc26fb2348683f44a517.patch:
try to fix testsuite failures on feh/powerpc.
(Closes: #812657)
2016-01-27 - Matthias Klose <doko@debian.org>
giflib (5.1.2-0.2) unstable; urgency=medium
* Non-maintainer upload.
* Fix DGifOpen(), uninitialized memory. Closes: #812093.

See Also

Package Description
libgl1-mesa-dev_19.0.8-0ubuntu0~19.04.1_amd64.deb free implementation of the OpenGL API -- GLX development files
libgl1-mesa-dri_19.0.8-0ubuntu0~19.04.1_amd64.deb free implementation of the OpenGL API -- DRI modules
libgl1-mesa-glx_19.0.8-0ubuntu0~19.04.1_amd64.deb transitional dummy package
libglapi-mesa_19.0.8-0ubuntu0~19.04.1_amd64.deb free implementation of the GL API -- shared library
libgles2-mesa-dev_19.0.8-0ubuntu0~19.04.1_amd64.deb free implementation of the OpenGL|ES 2.x API -- development files
libglib2.0-0_2.60.4-0ubuntu0.19.04.1_amd64.deb GLib library of C routines
libglib2.0-bin_2.60.4-0ubuntu0.19.04.1_amd64.deb Programs for the GLib library
libglib2.0-data_2.60.4-0ubuntu0.19.04.1_all.deb Common files for GLib library
libglib2.0-dev-bin_2.60.4-0ubuntu0.19.04.1_amd64.deb Development utilities for the GLib library
libglib2.0-dev_2.60.4-0ubuntu0.19.04.1_amd64.deb Development files for the GLib library
libglib2.0-doc_2.60.4-0ubuntu0.19.04.1_all.deb Documentation files for the GLib library
libglx-mesa0_19.0.8-0ubuntu0~19.04.1_amd64.deb free implementation of the OpenGL API -- GLX vendor library
libgnome-desktop-3-17_3.32.1-1ubuntu1.2_amd64.deb Utility library for loading .desktop files - runtime files
libgnome-desktop-3-dev_3.32.1-1ubuntu1.2_amd64.deb Utility library for loading .desktop files - development files
libgnutls-dane0_3.6.5-2ubuntu1.1_amd64.deb GNU TLS library - DANE security support
Advertisement
Advertisement