python-lightblue_0.3.2-5build1_i386.deb


Advertisement

Description

python-lightblue - cross-platform Bluetooth API for Python

Property Value
Distribution Ubuntu 19.04 (Disco Dingo)
Repository Ubuntu Universe i386
Package filename python-lightblue_0.3.2-5build1_i386.deb
Package name python-lightblue
Package version 0.3.2
Package release 5build1
Package architecture i386
Package type deb
Category universe/python
Homepage http://lightblue.sourceforge.net/
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 32.82 KB
Installed size 137.00 KB
The package provides a Python API which provides simple access to Bluetooth
operations. It is available for Mac OS X, GNU/Linux and Nokia's Python for
Series 60 platform for mobile phones.
LightBlue provides simple access to:
* Device and service discovery (with and without end-user GUIs)
* Standard socket interface for RFCOMM and L2CAP sockets (currently
L2CAP client sockets only, and not on PyS60)
* Sending and receiving files over OBEX
* Advertising of RFCOMM and OBEX services
* Local device information

Alternatives

Package Version Architecture Repository
python-lightblue_0.3.2-5build1_amd64.deb 0.3.2 amd64 Ubuntu Universe
python-lightblue - - -

Requires

Name Value
libbluetooth3 >= 4.91
libc6 >= 2.4
libopenobex2 -
python >= 2.7~
python << 2.8
python-bluez -
python:any >= 2.7.5-5~

Provides

Name Value
python2.7-lightblue -

Download

Type URL
Mirror archive.ubuntu.com
Binary Package python-lightblue_0.3.2-5build1_i386.deb
Source Package python-lightblue

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install python-lightblue deb package:
    # sudo apt-get install python-lightblue

Files

Path
/usr/lib/python2.7/dist-packages/_lightblueobex.i386-linux-gnu.so
/usr/lib/python2.7/dist-packages/_lightblueutil.i386-linux-gnu.so
/usr/lib/python2.7/dist-packages/lightblue-0.3.2.egg-info
/usr/lib/python2.7/dist-packages/lightblue/__init__.py
/usr/lib/python2.7/dist-packages/lightblue/_discoveryui.py
/usr/lib/python2.7/dist-packages/lightblue/_lightblue.py
/usr/lib/python2.7/dist-packages/lightblue/_lightbluecommon.py
/usr/lib/python2.7/dist-packages/lightblue/_obex.py
/usr/lib/python2.7/dist-packages/lightblue/_obexcommon.py
/usr/lib/python2.7/dist-packages/lightblue/obex.py
/usr/share/doc/python-lightblue/changelog.Debian.gz
/usr/share/doc/python-lightblue/copyright

Changelog

2016-02-17 - Matthias Klose <doko@ubuntu.com>
python-lightblue (0.3.2-5build1) xenial; urgency=medium
* No-change rebuild for openobex transition.
2016-02-07 - Mattia Rizzolo <mattia@debian.org>
python-lightblue (0.3.2-5) unstable; urgency=medium
* Team upload.
[ SVN-Git Migration ]
* git-dpm config.
* Update Vcs fields for git migration.
[ Diane Trout ]
* Add homepage link.
[ Mattia Rizzolo ]
* Switch build-depends from libopenobex1-dev to libopenobex2-dev.
2015-08-20 - Raphaël Hertzog <hertzog@debian.org>
python-lightblue (0.3.2-4) unstable; urgency=medium
* Add dh-python to Build-Depends.
* Bump debhelper compat to 9.
* Set source format to 3.0 (quilt).
2014-12-18 - Raphaël Hertzog <hertzog@debian.org>
python-lightblue (0.3.2-3) unstable; urgency=medium
* Adopt the package in the python-modules team.
* Add Vcs-Svn and Vcs-Browser control fields.
* Add a watch file.
2014-11-26 - Andrew Starr-Bochicchio <asb@debian.org>
python-lightblue (0.3.2-2) unstable; urgency=medium
* QA upload.
* Set QA Group as Maintainer.
* Add missing dependency on pybluez (Closes: #562907).
* python-support is deprecated. Port to dh_python2 and dh.
* Bump Standards-Version to 3.9.6
2008-03-31 - martin f. krafft <madduck@debian.org>
python-lightblue (0.3.2-1) unstable; urgency=low
* New upstream version.
* Remove build dir, if present, during clean; thanks to Sandro Tosi for the
patch (closes: #442712).
* Bump debhelper compatibility to 6; no changes needed.
* Bump Standards-Version to 3.7.3; no changes needed.
* Add shlibs:Depends on Depends line. Woops. :)
2007-07-22 - martin f. krafft <madduck@debian.org>
python-lightblue (0.2-3) unstable; urgency=low
* Remove python-all dependency, which is included with python-all-dev.
* Move all code from binary-indep target to binary-arch since this is an
arch:any package. Sorry about that (closes: #434115).
2007-07-20 - martin f. krafft <madduck@debian.org>
python-lightblue (0.2-2) unstable; urgency=low
* Build-depend on python-all / python-all-dev and make sure only ever to try
to compile against installed and supported versions (closes: #433903).
2007-03-14 - martin f. krafft <madduck@debian.org>
python-lightblue (0.2-1) unstable; urgency=low
* Initial release.

See Also

Package Description
python-linaro-image-tools_2016.05-1.1_all.deb Python library for the manipulation of Linaro bootable media
python-linecache2_1.0.0-3_all.deb backports of the linecache module - Python 2.7
python-link-grammar-examples_5.5.1-6_all.deb CMU's link grammar parser (Python examples)
python-link-grammar_5.5.1-6_i386.deb Carnegie Mellon University's link grammar parser (Python 2)
python-linux-procfs_0.6.1-1_i386.deb Linux /proc abstraction classes in Python - Python 2.7
python-livereload-doc_2.6.0-1_all.deb automatic browser refresher (documentation)
python-livereload_2.6.0-1_all.deb automatic browser refresher
python-lldb-6.0_6.0.1-11_i386.deb Next generation, high-performance debugger, python lib
python-lldb-7_7.0.1-8_i386.deb Next generation, high-performance debugger, python lib
python-lldb-8_8-3_i386.deb Next generation, high-performance debugger, python lib
python-lldb_8.0-48~exp1ubuntu1_i386.deb Next generation, high-performance debugger, python lib
python-llfuse-doc_1.3.6+dfsg-1_all.deb Python bindings for the low-level FUSE API (documentation)
python-llfuse_1.3.6+dfsg-1_i386.deb Python bindings for the low-level FUSE API
python-llvmlite_0.27.0-2_i386.deb LLVM Python binding for writing JIT compilers
python-lmdb_0.86-1build6_i386.deb Python binding for LMDB Lightning Memory-Mapped Database
Advertisement
Advertisement