python-cliff_2.14.1-0ubuntu1_all.deb


Advertisement

Description

python-cliff - command line interface formulation framework - Python 2.x

Property Value
Distribution Ubuntu 19.04 (Disco Dingo)
Repository Ubuntu Universe i386
Package filename python-cliff_2.14.1-0ubuntu1_all.deb
Package name python-cliff
Package version 2.14.1
Package release 0ubuntu1
Package architecture all
Package type deb
Category universe/python
Homepage https://github.com/dreamhost/cliff
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 39.46 KB
Installed size 272.00 KB
Cliff is a framework for building command line programs. It uses plugins to
define sub-commands, output formatters, and other extensions.
The cliff framework is meant to be used to create multi-level commands such as
Subversion and git, where the main program handles some basic argument parsing
and then invokes a sub-command to do the work.
This package provides the Python 2.x module.

Alternatives

Package Version Architecture Repository
python-cliff_2.14.1-0ubuntu1_all.deb 2.14.1 all Ubuntu Universe
python-cliff - - -

Requires

Name Value
python-cmd2 -
python-docutils -
python-pbr >= 2.0.0
python-prettytable >= 0.7.2
python-pyparsing >= 2.1.0
python-six >= 1.10.0
python-stevedore >= 1:1.20.0
python-unicodecsv >= 0.8.0
python-yaml >= 3.12
python:any << 2.8
python:any >= 2.7~

Download

Type URL
Mirror archive.ubuntu.com
Binary Package python-cliff_2.14.1-0ubuntu1_all.deb
Source Package python-cliff

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install python-cliff deb package:
    # sudo apt-get install python-cliff

Files

Path
/usr/lib/python2.7/dist-packages/cliff/__init__.py
/usr/lib/python2.7/dist-packages/cliff/_argparse.py
/usr/lib/python2.7/dist-packages/cliff/app.py
/usr/lib/python2.7/dist-packages/cliff/columns.py
/usr/lib/python2.7/dist-packages/cliff/command.py
/usr/lib/python2.7/dist-packages/cliff/commandmanager.py
/usr/lib/python2.7/dist-packages/cliff/complete.py
/usr/lib/python2.7/dist-packages/cliff/display.py
/usr/lib/python2.7/dist-packages/cliff/help.py
/usr/lib/python2.7/dist-packages/cliff/hooks.py
/usr/lib/python2.7/dist-packages/cliff/interactive.py
/usr/lib/python2.7/dist-packages/cliff/lister.py
/usr/lib/python2.7/dist-packages/cliff/show.py
/usr/lib/python2.7/dist-packages/cliff/sphinxext.py
/usr/lib/python2.7/dist-packages/cliff/utils.py
/usr/lib/python2.7/dist-packages/cliff-2.14.1.egg-info/PKG-INFO
/usr/lib/python2.7/dist-packages/cliff-2.14.1.egg-info/dependency_links.txt
/usr/lib/python2.7/dist-packages/cliff-2.14.1.egg-info/entry_points.txt
/usr/lib/python2.7/dist-packages/cliff-2.14.1.egg-info/not-zip-safe
/usr/lib/python2.7/dist-packages/cliff-2.14.1.egg-info/requires.txt
/usr/lib/python2.7/dist-packages/cliff-2.14.1.egg-info/top_level.txt
/usr/lib/python2.7/dist-packages/cliff/formatters/__init__.py
/usr/lib/python2.7/dist-packages/cliff/formatters/base.py
/usr/lib/python2.7/dist-packages/cliff/formatters/commaseparated.py
/usr/lib/python2.7/dist-packages/cliff/formatters/json_format.py
/usr/lib/python2.7/dist-packages/cliff/formatters/shell.py
/usr/lib/python2.7/dist-packages/cliff/formatters/table.py
/usr/lib/python2.7/dist-packages/cliff/formatters/value.py
/usr/lib/python2.7/dist-packages/cliff/formatters/yaml_format.py
/usr/lib/python2.7/dist-packages/cliff/tests/__init__.py
/usr/lib/python2.7/dist-packages/cliff/tests/base.py
/usr/lib/python2.7/dist-packages/cliff/tests/test_app.py
/usr/lib/python2.7/dist-packages/cliff/tests/test_columns.py
/usr/lib/python2.7/dist-packages/cliff/tests/test_command.py
/usr/lib/python2.7/dist-packages/cliff/tests/test_command_hooks.py
/usr/lib/python2.7/dist-packages/cliff/tests/test_commandmanager.py
/usr/lib/python2.7/dist-packages/cliff/tests/test_complete.py
/usr/lib/python2.7/dist-packages/cliff/tests/test_formatters_csv.py
/usr/lib/python2.7/dist-packages/cliff/tests/test_formatters_json.py
/usr/lib/python2.7/dist-packages/cliff/tests/test_formatters_shell.py
/usr/lib/python2.7/dist-packages/cliff/tests/test_formatters_table.py
/usr/lib/python2.7/dist-packages/cliff/tests/test_formatters_value.py
/usr/lib/python2.7/dist-packages/cliff/tests/test_formatters_yaml.py
/usr/lib/python2.7/dist-packages/cliff/tests/test_help.py
/usr/lib/python2.7/dist-packages/cliff/tests/test_interactive.py
/usr/lib/python2.7/dist-packages/cliff/tests/test_lister.py
/usr/lib/python2.7/dist-packages/cliff/tests/test_show.py
/usr/lib/python2.7/dist-packages/cliff/tests/test_sphinxext.py
/usr/lib/python2.7/dist-packages/cliff/tests/test_utils.py
/usr/lib/python2.7/dist-packages/cliff/tests/utils.py
/usr/share/doc/python-cliff/changelog.Debian.gz
/usr/share/doc/python-cliff/copyright

Changelog

2019-03-11 - Corey Bryant <corey.bryant@canonical.com>
python-cliff (2.14.1-0ubuntu1) disco; urgency=medium
* New upstream release for OpenStack Stein.
2019-02-06 - Corey Bryant <corey.bryant@canonical.com>
python-cliff (2.14.0-0ubuntu1) disco; urgency=medium
* New upstream release.
* d/control: Align (Build-)Depends with upstream.
2018-08-02 - Corey Bryant <corey.bryant@canonical.com>
python-cliff (2.13.0-0ubuntu1) cosmic; urgency=medium
* New upstream release for OpenStack Rocky.
* d/control: Align (Build-)Depends with upstream.
* d/p/align-parsed-call-with-cmd2-versions-0.7.3.patch: Dropped. Fixed in
new upstream release.
2018-05-15 - Corey Bryant <corey.bryant@canonical.com>
python-cliff (2.11.0-1ubuntu1) cosmic; urgency=low
* Merge from Debian unstable.  Remaining changes:
- d/control, d/compat: Remain at debhelper>=10.
- d/control: Enable autopkgtest-pkg-python tests.
- d/gbp.conf: Retain for pristine-tar.
- d/watch: Get tarball from pypi.debian.net.
- d/control: Drop (Build-)Depends on python3-unicodecsv as its only
needed for Python 2 (LP: #1736717).
- d/p/align-parsed-call-with-cmd2-versions-0.7.3.patch: Cherry-picked
from https://review.openstack.org/#/c/548626/ to fix AttributeError
exception with use of cmd2 parsed() method (LP: #1751822).
2018-03-03 - Thomas Goirand <zigo@debian.org>
python-cliff (2.11.0-1) unstable; urgency=medium
[ Ondřej Nový ]
* d/control: Set Vcs-* to salsa.debian.org
[ Thomas Goirand ]
* New upstream release.
* Fixed (build-)depends for this release.
* Standards-Version is now 4.1.3.
2018-02-28 - Corey Bryant <corey.bryant@canonical.com>
python-cliff (2.11.0-0ubuntu2) bionic; urgency=medium
* d/p/align-parsed-call-with-cmd2-versions-0.7.3.patch: Cherry-picked
from https://review.openstack.org/#/c/548626/ to fix AttributeError
exception with use of cmd2 parsed() method (LP: #1751822).
2018-01-23 - Corey Bryant <corey.bryant@canonical.com>
python-cliff (2.11.0-0ubuntu1) bionic; urgency=medium
* New upstream release.
* d/control: Align (Build-)Depends with upstream.
* d/*: wrap-and-sort -bast.
* d/control: Update Standards-Version to 4.1.2.
* d/control: Bump debhelper compat to 10.
2017-12-18 - James Page <james.page@ubuntu.com>
python-cliff (2.9.1-0ubuntu2) bionic; urgency=medium
* d/control: Drop (Build-)Depends on python3-unicodecsv as its only
needed for Python 2 (LP: #1736717).
2017-11-14 - Corey Bryant <corey.bryant@canonical.com>
python-cliff (2.9.1-0ubuntu1) bionic; urgency=medium
* New upstream release.
* d/control: Align (Build-)Depends with upstream.
* d/p/drop-openstackdoctheme.patch: Dropped. No longer needed.
2017-11-01 - Thomas Goirand <zigo@debian.org>
python-cliff (2.8.0-3) unstable; urgency=medium
* Uploading to unstable.
* Fixed watch file.
* Standards-Version is now 4.1.1.

See Also

Package Description
python-cligj_0.5.0-1_all.deb Python 2 library for processing GeoJSON commands
python-clint_0.5.1-1_all.deb Python Command-line Application Tools
python-clips_1.0.7.348+clips-4_i386.deb Python module to interface the CLIPS expert system shell library
python-cloud-sptheme_1.9.4-1_all.deb Cloud Sphinx theme and related extensions
python-cloudfiles_1.7.11-3_all.deb Python language bindings for Cloud Files API
python-cloudkittyclient-doc_1.2.0-4_all.deb API client for Rating as a Service project - doc
python-cloudkittyclient_1.2.0-4_all.deb API client for Rating as a Service project - Python 2.7
python-cloudpickle_0.8.0-1_all.deb Extended pickling support for Python 2 objects
python-cluster_1.3.3-1.1_all.deb allows grouping a list of arbitrary objects into related groups (clusters)
python-clustershell_1.8.1-1_all.deb clustershell python2 libraries
python-cmd2_0.7.9-0ubuntu1_all.deb enhanced Python cmd module - Python 2.x
python-cmislib-doc_0.5.1+dfsg-2_all.deb CMIS client library for Python (documentation)
python-cmislib_0.5.1+dfsg-2_all.deb CMIS client library for Python
python-cmor_3.4.0-2_i386.deb Python interface to CMOR
python-coards_1.0.5-3_all.deb COARDS-compliant time parser (Python 2)
Advertisement
Advertisement