libqt5sql5_5.12.2+dfsg-4ubuntu1_i386.deb


Advertisement

Description

libqt5sql5 - Qt 5 SQL module

Property Value
Distribution Ubuntu 19.04 (Disco Dingo)
Repository Ubuntu Universe i386
Package filename libqt5sql5_5.12.2+dfsg-4ubuntu1_i386.deb
Package name libqt5sql5
Package version 5.12.2+dfsg
Package release 4ubuntu1
Package architecture i386
Package type deb
Category universe/libs
Homepage http://qt-project.org/
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 129.79 KB
Installed size 549.00 KB
Qt is a cross-platform C++ application framework. Qt's primary feature
is its rich set of widgets that provide standard GUI functionality.
The QtSql module helps you provide seamless database integration to your Qt
applications.

Alternatives

Package Version Architecture Repository
libqt5sql5_5.12.2+dfsg-4ubuntu1.1_amd64.deb 5.12.2+dfsg amd64 Ubuntu Updates Universe
libqt5sql5_5.12.2+dfsg-4ubuntu1.1_i386.deb 5.12.2+dfsg i386 Ubuntu Updates Universe
libqt5sql5_5.12.2+dfsg-4ubuntu1_amd64.deb 5.12.2+dfsg amd64 Ubuntu Universe
libqt5sql5 - - -

Requires

Name Value
libc6 >= 2.4
libqt5core5a >= 5.12.2
libstdc++6 >= 5
qtbase-abi-5-12-2 -

Download

Type URL
Mirror archive.ubuntu.com
Binary Package libqt5sql5_5.12.2+dfsg-4ubuntu1_i386.deb
Source Package qtbase-opensource-src

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libqt5sql5 deb package:
    # sudo apt-get install libqt5sql5

Files

Path
/usr/lib/i386-linux-gnu/libQt5Sql.so.5
/usr/lib/i386-linux-gnu/libQt5Sql.so.5.12
/usr/lib/i386-linux-gnu/libQt5Sql.so.5.12.2
/usr/share/doc/libqt5sql5/changelog.Debian.gz
/usr/share/doc/libqt5sql5/copyright
/usr/share/lintian/overrides/libqt5sql5

Changelog

2019-04-11 - Dmitry Shachnev <mitya57@ubuntu.com>
qtbase-opensource-src (5.12.2+dfsg-4ubuntu1) disco; urgency=medium
* Fix an endianness issue in the bundled copy of tinyCBOR library.
2019-04-07 - Dmitry Shachnev <mitya57@debian.org>
qtbase-opensource-src (5.12.2+dfsg-4) experimental; urgency=medium
* Build-depend on libxcb-xinput-dev, to fix mouse events handling.
2019-04-05 - Dmitry Shachnev <mitya57@debian.org>
qtbase-opensource-src (5.12.2+dfsg-3) experimental; urgency=medium
* Update symbols files from buildds’ logs.
* Add a patch to make qt_is_ascii function work properly on big endian.
2019-03-24 - Dmitry Shachnev <mitya57@debian.org>
qtbase-opensource-src (5.12.2+dfsg-2) experimental; urgency=medium
* Backport upstream patch to fix generation of Qt5::GLESv2 target on ARM.
* Change Perl shebangs to /usr/bin/perl as required by Policy § 10.4.
* Update symbols files from buildds’ logs.
2019-03-15 - Dmitry Shachnev <mitya57@debian.org>
qtbase-opensource-src (5.12.2+dfsg-1) experimental; urgency=medium
[ Dmitry Shachnev ]
* New upstream release.
* Drop patches, applied upstream:
- fix-selection-rendering.patch
- reference_dpi.diff
- remove_need_for_glXGetProcAddressARB.patch
- qprintdialog_duplex.diff
- no_arc4random_buf.diff
- kfreebsd_qstrncpy.diff
- alpha_atimensec.diff
- hurd_missing_include.diff
* Refresh and rebase other patches.
* Restore GLES-related changes that were dropped in 5.11.3+dfsg-4.
* Add libqt5gui5-gles alternative dependency to platformtheme packages.
* Update symbols files from the current build log.
* Bump ABI version to qtbase-abi-5-12-2.
* debian/scripts/update-copyright: Map upstream MIT license to Expat.
* Regenerate the Qt part of debian/copyright.
* Manually update the 3rdparty part of debian/copyright.
[ Simon Quigley ]
* Move the Flatpak platform theme to a generic XDG Desktop Portal platform
theme.
* Remove qxcbintegrationfunctions.h which is no longer provided by upstream.
* Add new files from upstream.
2019-03-15 - Dmitry Shachnev <mitya57@debian.org>
qtbase-opensource-src (5.11.3+dfsg1-1) unstable; urgency=medium
* Repack the tarball and strip some files and directories with copyright
issues (closes: #924599).
2019-02-10 - Lisandro Damián Nicanor Pérez Meyer <lisandro@debian.org>
qtbase-opensource-src (5.11.3+dfsg-5) unstable; urgency=medium
* Revert part of the mkspecs movements between packages. The private ones
were put into qtbase5-private-dev, but it seems that they are not ready
for that (Closes: #921930).
2019-02-08 - Dmitry Shachnev <mitya57@debian.org>
qtbase-opensource-src (5.11.3+dfsg-4) unstable; urgency=medium
* Revert the GLES-related symbols changes from the previous upload.
These changes were only for experimental and not yet for unstable.
* Upload to unstable.
[ Lisandro Damián Nicanor Pérez Meyer ]
* Backport mysql_free_results_when_qsqlquery_finished_is_called.patch,
required by akonadi (closes: #921584).
[ Dmitry Shachnev ]
* Fix installed files list on hurd and kfreebsd (closes: #920236).
Thanks to Samuel Thibault!
* Move qt_lib_opengl.pri from qtbase5-dev to libqt5opengl5-dev.
* Backport upstream commit to fix duplex printing (LP: #1776173).
Thanks to Robert Bredereck for the initial patch!
* Add missing features.h include to hurd-g++ mkspec (closes: #920613).
Thanks to Samuel Thibault for the patch!
* Update symbols files from ia64 build logs.

See Also

Package Description
libqt5svg5-dev_5.12.2-1_i386.deb Qt 5 SVG module development files
libqt5svg5_5.12.2-1_i386.deb Qt 5 SVG module
libqt5test5_5.12.2+dfsg-4ubuntu1_i386.deb Qt 5 test module
libqt5texttospeech5-dev_5.12.2-1_i386.deb Speech library for Qt - development files
libqt5texttospeech5_5.12.2-1_i386.deb Speech library for Qt - libraries
libqt5virtualkeyboard5-dev_5.12.2+dfsg-1_i386.deb Qt virtual keyboard - development files
libqt5virtualkeyboard5_5.12.2+dfsg-1_i386.deb Qt virtual keyboard - public shared library
libqt5waylandclient5-dev_5.12.2-1_i386.deb QtWayland client development files
libqt5waylandclient5_5.12.2-1_i386.deb QtWayland client library
libqt5waylandcompositor5-dev_5.12.2-1_i386.deb QtWayland compositor development files
libqt5waylandcompositor5_5.12.2-1_i386.deb QtWayland compositor library
libqt5webchannel5-dev_5.12.2-1_i386.deb Web communication library for Qt - development files
libqt5webchannel5_5.12.2-1_i386.deb Web communication library for Qt
libqt5webengine-data_5.12.2+dfsg-2ubuntu1_all.deb Web content engine library for Qt - Data
libqt5webengine5_5.12.2+dfsg-2ubuntu1_i386.deb Web content engine library for Qt
Advertisement
Advertisement