libmeep-openmpi12_1.7.0-3_i386.deb


Advertisement

Description

libmeep-openmpi12 - library for using parallel (OpenMPI) version of meep

Property Value
Distribution Ubuntu 19.04 (Disco Dingo)
Repository Ubuntu Universe i386
Package filename libmeep-openmpi12_1.7.0-3_i386.deb
Package name libmeep-openmpi12
Package version 1.7.0
Package release 3
Package architecture i386
Package type deb
Category universe/libs
Homepage https://meep.readthedocs.i
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 322.48 KB
Installed size 1.10 MB
Meep is a free and open-source software package for electromagnetics
simulation via the finite-difference time-domain (FDTD) method.
Its features include:
* Free and open-source software under the GNU GPL.
* Complete scriptability via Python, Scheme, or C++ APIs.
* Simulation in 1d, 2d, 3d, and cylindrical coordinates.
* Distributed memory parallelism on any system supporting MPI.
* Arbitrary anisotropic electric permittivity ε and magnetic permeability μ,
along with dispersive ε(ω) and μ(ω) including loss/gain,
nonlinear (Kerr & Pockels) dielectric and magnetic materials,
electric/magnetic conductivities σ, and saturable gain/absorption.
* Perfectly-matched layer (PML) absorbing boundaries as well as
Bloch-periodic and perfect-conductor boundary conditions.
* Exploitation of symmetries to reduce the computation size, including
even/odd mirror planes and 90°/180° rotations.
* Arbitrary current sources including a guided-mode launcher.
* Frequency-domain solver for finding the response to a
continuous-wave (CW) source.
* ε/μ and field import/export in the HDF5 data format.
* GDSII file import for planar geometries.
* Materials library containing predefined broadband, complex
refractive indices.
* Field analyses including Poynting flux, mode decomposition, near to far
transformations, frequency extraction, local density of states (LDOS),
modal volume, Maxwell stress tensor, arbitrary functions; completely
programmable.
This package contains the MPI version of the library.

Alternatives

Package Version Architecture Repository
libmeep-openmpi12_1.7.0-3_amd64.deb 1.7.0 amd64 Ubuntu Universe
libmeep-openmpi12 - - -

Requires

Name Value
libatlas3-base -
libc6 >= 2.4
libfftw3-double3 >= 3.3.5
libgcc1 >= 1:4.0
libgsl23 >= 2.5
libharminv3 >= 1.4
libhdf5-openmpi-103 >= 1.8.14
liblapack.so.3 -
liblapack3 -
libopenmpi3 -
libstdc++6 >= 5.2

Conflicts

Name Value
libmeep-lam4-12 -
libmeep-lam4-6 -
libmeep-lam4-7 -
libmeep-lam4-8 -
libmeep-mpi-default12 -
libmeep-mpi-default6 -
libmeep-mpi-default7 -
libmeep-mpi-default8 -
libmeep-mpich2-12 -
libmeep-mpich2-6 -
libmeep-mpich2-7 -
libmeep-mpich2-8 -
libmeep-openmpi6 -
libmeep-openmpi7 -
libmeep-openmpi8 -
libmeep10 -
libmeep12 -
libmeep6 -
libmeep7 -
libmeep8 -

Download

Type URL
Mirror archive.ubuntu.com
Binary Package libmeep-openmpi12_1.7.0-3_i386.deb
Source Package meep-openmpi

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libmeep-openmpi12 deb package:
    # sudo apt-get install libmeep-openmpi12

Files

Path
/usr/lib/i386-linux-gnu/libmeep.so.12
/usr/lib/i386-linux-gnu/libmeep.so.12.0.0
/usr/lib/i386-linux-gnu/libmeepgeom.so.12
/usr/lib/i386-linux-gnu/libmeepgeom.so.12.0.0
/usr/share/doc/libmeep-openmpi12/changelog.Debian.gz
/usr/share/doc/libmeep-openmpi12/copyright
/usr/share/lintian/overrides/libmeep-openmpi12
/usr/share/meep/casimir.scm
/usr/share/meep/materials.scm
/usr/share/meep/meep-enums.scm
/usr/share/meep/meep.scm

Changelog

2019-02-04 - Thorsten Alteholz <debian@alteholz.de>
meep-openmpi (1.7.0-3) sid; urgency=medium
* debian/*postinst debian/*prerm: add correct package name
(Closes: #918858)
Thanks to Peter Green and Andreas Beckmann for their hints
* debian/control: update description according to upstream wishes
* debian/control: update homepage
* debian/control: Standards Version to 4.3.0. (No changes needed).
* debian/copyright: update Upstream-Source:
2018-12-25 - Thorsten Alteholz <debian@alteholz.de>
meep-openmpi (1.7.0-2) unstable; urgency=medium
* upload to unstable
2018-12-22 - Thorsten Alteholz <debian@alteholz.de>
meep-openmpi (1.7.0-1) experimental; urgency=medium
* New upstream release
* debian/control: use dh11
* debian/control: Standards Version to 4.2.1. (No changes needed).
* debian/control: use libctl>=4.1.4-2
* debian/control: add swig dependency
* debian/control: remove dependencies: autotools-dev, dh-autoreconf
* debian/control: depend on newest libctl and thus on guile2.2
(Closes: #885228)
* debian/control: depend on newest libharminv
* debian/control: add salsa VCS URLs
* debian/control: bump SONAME to 12
* debian/control: upstream does not support parallel installation of
serial and MPI version any longer
add conflicts accordingly
* debian/rules: add --enable-maintainer-mode to configure flags
* debian/rules: enable hardening flags
* update debian/watch
[ Ruben Undheim ]
* add python package
2015-12-20 - Thorsten Alteholz <debian@alteholz.de>
meep-openmpi (1.3-3) unstable; urgency=medium
* Update build dependencies for GSL 2, change libgsl0-dev to libgsl-dev.
Thanks to Bas Couwenberg for the patch. (Closes: #807215)
* debian/rules: put correct path to --with-libctl
2015-07-05 - Thorsten Alteholz <debian@alteholz.de>
meep-openmpi (1.3-2) unstable; urgency=medium
* debian/control: add conflict with old version of libs (Closes: #790749)
2015-06-21 - Thorsten Alteholz <debian@alteholz.de>
meep-openmpi (1.3-1) unstable; urgency=medium
* new upstream version
* soname changed to 8
* debian/control: Standards Version to 3.9.6. (No changes needed).
2014-08-03 - Thorsten Alteholz <debian@alteholz.de>
meep-openmpi (1.2.1-2) unstable; urgency=medium
* Support hdf5 1.8.13 new packaging layout. (Closes: #756683)
(patch by Gilles Filippini <pini@debian.org>)
2014-05-11 - Thorsten Alteholz <debian@alteholz.de>
meep-openmpi (1.2.1-1) unstable; urgency=medium
* new upstream version
* soname changed to 7
* debian/rules: upstream ChangeLog is now called NEWS
* debian/control: Standards Version to 3.9.5. (No changes needed).
* debian/control: switch to dh 9
* debian/control: use guile 2.0 now
* debian/rules: use debhelper
* debian/rules: use --with autoreconf (Closes: #744464)
* debian/copyright: adapt years
2014-01-21 - Thorsten Alteholz <debian@alteholz.de>
meep-openmpi (1.1.1-10) unstable; urgency=low
* Configure with --with-gcc-arch=no to generate generic code.
(Closes: #735369)
* debian/control: remove DM-Upload-Allowed
* debian/copyright: fix lintian warning about duplicate field
2013-11-27 - Thorsten Alteholz <debian@alteholz.de>
meep-openmpi (1.1.1-9~deb7u1) wheezy; urgency=low
* upload to wheezy; Closes: #711766 in stable

See Also

Package Description
libmeep12_1.7.0-3_i386.deb library for using meep
libmelt-ocaml-dev_1.4.0-2build2_i386.deb LaTeX with OCaml (libraries)
libmemcached-libmemcached-perl_1.001801+dfsg-2build3_i386.deb thin, fast, full interface to the libmemcached client API
libmemoize-expirelru-perl_0.56-1_all.deb Expiry plug-in for Memoize that adds LRU cache expiration
libmemoize-memcached-perl_0.04-1_all.deb implementation of Memoize using memcached for storage
libmemory-usage-perl_0.201-3_all.deb Determine actual memory usage of Perl programs
libmems-dev_1.6.0+4725-8_i386.deb development library to support DNA string matching and comparative genomics
libmems1_1.6.0+4725-8_i386.deb library to support DNA string matching and comparative genomics
libmemtailor-dev_1.0~git20160311-2ubuntu1_i386.deb C++ library of special purpose memory allocators (developer tools)
libmemtailor0_1.0~git20160311-2ubuntu1_i386.deb C++ library of special purpose memory allocators (shared library)
libmenhir-ocaml-dev_20171222-1_i386.deb Menhir library for OCaml
libmenlo-legacy-perl_1.9022-1_all.deb legacy internal and client support for Menlo
libmenlo-perl_1.9019-1_all.deb CPAN client backend
libmenu-cache-bin_1.1.0-1_i386.deb LXDE implementation of the freedesktop Menu's cache (libexec)
libmenu-cache-dev_1.1.0-1_i386.deb LXDE implementation of the freedesktop Menu's cache (devel)
Advertisement
Advertisement