libgnome-2-0_2.32.1-6_i386.deb


Advertisement

Description

libgnome-2-0 - Deprecated GNOME 2 library - runtime files

Property Value
Distribution Ubuntu 19.04 (Disco Dingo)
Repository Ubuntu Universe i386
Package filename libgnome-2-0_2.32.1-6_i386.deb
Package name libgnome-2-0
Package version 2.32.1
Package release 6
Package architecture i386
Package type deb
Category universe/oldlibs
Homepage -
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 55.59 KB
Installed size 176.00 KB
This package contains the shared library for the deprecated GNOME 2 library
functions.

Alternatives

Package Version Architecture Repository
libgnome-2-0_2.32.1-6_amd64.deb 2.32.1 amd64 Ubuntu Universe
libgnome-2-0 - - -

Requires

Name Value
gconf-service -
libbonobo2-0 >= 2.32.1-3~
libc6 >= 2.4
libcanberra0 >= 0.2
libgconf-2-4 >= 3.2.5
libglib2.0-0 >= 2.35.9
libgnome2-common = 2.32.1-6
libgnomevfs2-0 >= 1:2.17.90
liborbit-2-0 >= 1:2.14.10
libpopt0 >= 1.14

Replaces

Name Value
libgnome2-0 << 2.32.1-5

Download

Type URL
Mirror archive.ubuntu.com
Binary Package libgnome-2-0_2.32.1-6_i386.deb
Source Package libgnome

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libgnome-2-0 deb package:
    # sudo apt-get install libgnome-2-0

Files

Path
/usr/lib/i386-linux-gnu/libgnome-2.so.0
/usr/lib/i386-linux-gnu/libgnome-2.so.0.3200.1
/usr/lib/i386-linux-gnu/bonobo/monikers/libmoniker_extra_2.so
/usr/lib/i386-linux-gnu/bonobo/servers/GNOME_Moniker_std.server
/usr/share/doc/libgnome-2-0/AUTHORS
/usr/share/doc/libgnome-2-0/NEWS.gz
/usr/share/doc/libgnome-2-0/README
/usr/share/doc/libgnome-2-0/changelog.Debian.gz
/usr/share/doc/libgnome-2-0/copyright

Changelog

2017-09-03 - Jeremy Bicha <jbicha@debian.org>
libgnome (2.32.1-6) unstable; urgency=medium
* Cherry-pick 05_fix_invalid_utf8.patch to fix build with latest glib2.0
(Closes: #870742)
* Modernize packaging:
- Convert to dh
- Bump debhelper compat to 10
- Bump Standards-Version to 4.1.0
- Convert to automatic dbgsym package
- Update package description to mention that this is the deprecated
GNOME 2 library
2013-12-27 - Josselin Mouette <joss@debian.org>
libgnome (2.32.1-5) unstable; urgency=low
[ Emilio Pozuelo Monfort ]
* debian/control.in:
+ Move to section oldlibs.
[ Josselin Mouette ]
* Add missing build-dependency on gnome-common.
* Migrate to multiarch. Closes: #642415, #731295.
+ Bump build-dependencies.
+ Split libgnome2-0 into libgnome-2-0 (library, MA: same) and 
libgnome2-bin (binary, MA: foreign).
+ Make libgnome2-common MA: foreign and libgnome2-dev MA: same.
+ Keep libgnome2-0 arch: any and MA: same so that multi-arch 
packages can still depend on it.
+ Update installation paths.
+ Build-depend on MA version of libbonobo.
* Remove gnome:Version.
* 00_as-needed.patch: dropped, obsolete.
* 03_multiarch.patch: revert the logic, use /usr/lib as a fallback in 
search paths.
2013-05-11 - Emilio Pozuelo Monfort <pochu@debian.org>
libgnome (2.32.1-4) unstable; urgency=low
* debian/patches/04_disable_deprecated.patch:
+ Add patch from upstream git, don't define G_DISABLE_DEPRECATED.
Fixes FTBFS. Closes: #707466.
* debian/control.in,
debian/rules:
+ Run autoreconf needed by the above patch.
2013-04-28 - Michael Biebl <biebl@debian.org>
libgnome (2.32.1-3) unstable; urgency=low
[ Andreas Beckmann ]
* libgnome2-common: Add dummy prerm/postrm as a workaround for gconf2
related upgrade failures caused by a dangling /usr/bin/python symlink.
Closes: #706110
2011-10-05 - Michael Biebl <biebl@debian.org>
libgnome (2.32.1-2) unstable; urgency=low
* Bump Standards-Version to 3.9.2. No further changes.
* Bump debhelper compatibility level to 8:
- Update Build-Depends on debhelper.
- Strip debian/tmp/ from .install files.
* debian/libgnome2-dev.install
- Remove libtool .la file.
* debian/rules
- Remove clean-la.mk include.
- Create a header file containing DEB_HOST_MULTIARCH.
* debian/patches/03_multiarch.patch
- Look for accessibility modules in multiarch directories. Closes: #636197
* debian/control
- Add Suggests: devhelp to libgnome2-doc for the gtk-doc API
documentation.
- Remove obsolete Conflicts and Replaces.
2011-05-29 - Josselin Mouette <joss@debian.org>
libgnome (2.32.1-1) unstable; urgency=low
* New upstream release.
* Switch to 3.0 quilt format.
* Watch for tar.bz2 files.
* Build-depend on libcanberra instead of libesd.
* 00_as-needed.patch, 02_path_max.patch: refreshed.
* libgnome2-common.gconf-defaults: set default cursor theme to 
Adwaita, to match the default in gsettings-desktop-schemas. In GNOME 
3, g-s-d uses GSettings to read the theme, while metacity/mutter 
still use GConf.
* Update -dev dependencies according to the .pc file.
2010-04-05 - Josselin Mouette <joss@debian.org>
libgnome (2.30.0-1) unstable; urgency=low
* New upstream release.
2009-09-29 - Josselin Mouette <joss@debian.org>
libgnome (2.28.0-1) unstable; urgency=low
* New upstream release.
* Break gnome-panel < 2.28 since disabling the icons in menus must not 
affect the main menu.
2009-04-28 - Josselin Mouette <joss@debian.org>
libgnome (2.26.0-1) unstable; urgency=low
[ Josselin Mouette ]
* Add libglib2.0-doc to b-d-i to ensure proper xrefs.
* Move gvfs from recommends to depends. Closes: #519263.
* Stop mentioning GNOME 2.
[ Luca Bruno ]
* New upstream release.
* debian/control.in:
- Bump intltool Build-Depend to 0.40.0.
- Update to Standards-Version 3.8.1, no additional changes needed.
- Fix debug package section.

See Also

Package Description
libgnome-keyring-common_3.12.0-1build1_all.deb GNOME keyring services library - data files
libgnome-keyring-dev_3.12.0-1build1_i386.deb Development files for GNOME keyring service
libgnome-keyring0_3.12.0-1build1_i386.deb GNOME keyring services library
libgnome2-0_2.32.1-6_i386.deb Deprecated GNOME 2 library - transition package
libgnome2-bin_2.32.1-6_i386.deb Deprecated GNOME 2 library - binary files
libgnome2-common_2.32.1-6_all.deb Deprecated GNOME 2 library - common files
libgnome2-dev_2.32.1-6_i386.deb Deprecated GNOME 2 library - development files
libgnome2-doc_2.32.1-6_all.deb Deprecated GNOME 2 library - documentation files
libgnomecanvas2-0_2.30.3-4_i386.deb powerful object-oriented display engine - runtime files
libgnomecanvas2-common_2.30.3-4_all.deb powerful object-oriented display engine - common files
libgnomecanvas2-dev_2.30.3-4_i386.deb powerful object-oriented display engine - development files
libgnomecanvas2-doc_2.30.3-4_all.deb powerful object-oriented display engine - documentation files
libgnomecanvasmm-2.6-1v5_2.26.0-3_i386.deb C++ wrappers for libgnomecanvas2 (shared library)
libgnomecanvasmm-2.6-dev_2.26.0-3_i386.deb C++ wrappers for libgnomecanvas2 (development files)
libgnomecanvasmm-2.6-doc_2.26.0-3_all.deb C++ wrappers for libgnomecanvas2 (documentation)
Advertisement
Advertisement