python-evdev_1.1.2+dfsg-1_amd64.deb


Advertisement

Description

python-evdev - Python bindings for the Linux input subsystem

Property Value
Distribution Ubuntu 19.04 (Disco Dingo)
Repository Ubuntu Universe amd64
Package filename python-evdev_1.1.2+dfsg-1_amd64.deb
Package name python-evdev
Package version 1.1.2+dfsg
Package release 1
Package architecture amd64
Package type deb
Category universe/python
Homepage https://github.com/gvalkov/python-evdev
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 29.98 KB
Installed size 144.00 KB
This package provides bindings to the generic input event interface
in Linux. The evdev interface serves the purpose of passing events
generated in the kernel directly to userspace through character
devices that are typically located in /dev/input/.
This package also comes with bindings to uinput, the userspace input
subsystem. Uinput allows userspace programs to create and handle
input devices that can inject events directly into the input
subsystem.
This package installs the library for Python 2.

Alternatives

Package Version Architecture Repository
python-evdev_1.1.2+dfsg-1_i386.deb 1.1.2+dfsg i386 Ubuntu Universe
python-evdev - - -

Requires

Name Value
libc6 >= 2.4
python << 2.8
python >= 2.7~
python:any << 2.8
python:any >= 2.7~

Download

Type URL
Mirror archive.ubuntu.com
Binary Package python-evdev_1.1.2+dfsg-1_amd64.deb
Source Package python-evdev

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install python-evdev deb package:
    # sudo apt-get install python-evdev

Files

Path
/usr/lib/python2.7/dist-packages/evdev/__init__.py
/usr/lib/python2.7/dist-packages/evdev/_ecodes.x86_64-linux-gnu.so
/usr/lib/python2.7/dist-packages/evdev/_input.x86_64-linux-gnu.so
/usr/lib/python2.7/dist-packages/evdev/_uinput.x86_64-linux-gnu.so
/usr/lib/python2.7/dist-packages/evdev/device.py
/usr/lib/python2.7/dist-packages/evdev/ecodes.py
/usr/lib/python2.7/dist-packages/evdev/eventio.py
/usr/lib/python2.7/dist-packages/evdev/eventio_async.py
/usr/lib/python2.7/dist-packages/evdev/events.py
/usr/lib/python2.7/dist-packages/evdev/evtest.py
/usr/lib/python2.7/dist-packages/evdev/ff.py
/usr/lib/python2.7/dist-packages/evdev/genecodes.py
/usr/lib/python2.7/dist-packages/evdev/uinput.py
/usr/lib/python2.7/dist-packages/evdev/util.py
/usr/lib/python2.7/dist-packages/evdev-1.1.2.egg-info/PKG-INFO
/usr/lib/python2.7/dist-packages/evdev-1.1.2.egg-info/dependency_links.txt
/usr/lib/python2.7/dist-packages/evdev-1.1.2.egg-info/top_level.txt
/usr/lib/python2.7/dist-packages/evdev-1.1.2.egg-info/zip-safe
/usr/share/doc/python-evdev/changelog.Debian.gz
/usr/share/doc/python-evdev/copyright

Changelog

2018-09-19 - Stephen Kitt <skitt@debian.org>
python-evdev (1.1.2+dfsg-1) unstable; urgency=medium
* New upstream release.
* Enable tests, skipping those requiring root. Closes: #908988.
* Ensure that the module is available when the documentation is built,
so that the API documentation can be included. As a result, the
documentation is now architecture-dependent. Closes: #908990.
* Set “Rules-Requires-Root: no”.
* Standards-Version 4.2.1, no further change required.
2018-06-02 - Stephen Kitt <skitt@debian.org>
python-evdev (1.0.0+dfsg-1) unstable; urgency=medium
* New upstream release.
* Drop X-Python-Version, the minimum versions are satisfied
everywhere.
* Switch to debhelper compatibility level 11.
* Standards-Version 4.1.4, no further change required.
2018-04-07 - Stephen Kitt <skitt@debian.org>
python-evdev (0.8.1+dfsg-1) unstable; urgency=medium
* New upstream release.
* Don't run sphinx during arch-only builds. Thanks to Helmut Grohne for
the initial patch! Closes: #895108.
* Install the examples.
* Standards-Version 4.1.3, no change required.
* Migrate to Salsa.
2017-10-07 - Stephen Kitt <skitt@debian.org>
python-evdev (0.7.0+dfsg-2) unstable; urgency=medium
* Limit the architecture to linux-any. Closes: #875624.
* Switch to Python 3 Docutils and Sphinx, build-conflicting on
python-sphinx to avoid issues with that being picked in preference to
python3-sphinx.
* Clean up debian/control with cme.
* Drop the new-package-should-not-package-python2-module override
since this is no longer a new package.
* Standards-Version 4.1.1, no change required.
2017-09-01 - Stephen Kitt <skitt@debian.org>
python-evdev (0.7.0+dfsg-1) unstable; urgency=medium
* Initial release. Closes: #709988.

See Also

Package Description
python-evemu_2.7.0-1_amd64.deb Linux Input Event Device Emulation Library - Python bindings
python-evtx_0.6.1-1_all.deb parser for recent Windows Event Log files -- Python 2 version
python-ewmh-doc_0.1.6-1_all.deb Python interface to EWMH-compliant window managers (common documentation)
python-ewmh_0.1.6-1_all.deb Python interface to EWMH-compliant window managers (Python 2)
python-exabgp_4.0.8-1_all.deb BGP swiss army knife of networking - Python 2 module
python-exactimage_1.0.2-1_amd64.deb fast image manipulation library (Python bindings)
python-exam_0.10.5-2_all.deb Python module to help write better tests
python-excelerator_0.6.4.1-3_all.deb module for reading/writing Excel spreadsheet files
python-exconsole_0.1.5+git20131201-1_all.deb emergency/postmortem Python console
python-execnet_1.5.0-4_all.deb rapid multi-Python deployment (Python 2)
python-exif_2.1.2-1_all.deb Python library to extract Exif data from TIFF and JPEG files
python-exotel_0.1.5-1_all.deb Python library for exotel APIs (Python 2)
python-expiringdict_1.1.2-1_all.deb Python caching library
python-expyriment_0.7.0+git34-g55a4e7e-3.3_all.deb Python library for cognitive and neuroscientific experiments
python-extractor_0.6-7_all.deb extracts meta-data from files of arbitrary type (Python bindings)
Advertisement
Advertisement