python-diamond_4.0.515-5ubuntu1_all.deb


Advertisement

Description

python-diamond - smart data producer for Graphite graphing package (Python module)

Property Value
Distribution Ubuntu 19.04 (Disco Dingo)
Repository Ubuntu Universe amd64
Package filename python-diamond_4.0.515-5ubuntu1_all.deb
Package name python-diamond
Package version 4.0.515
Package release 5ubuntu1
Package architecture all
Package type deb
Category universe/python
Homepage https://github.com/python-diamond/Diamond
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 39.41 KB
Installed size 224.00 KB
Diamond is a python daemon that collects system metrics and publishes them to
Graphite (and others). It is capable of collecting cpu, memory, network, i/o,
load and disk metrics. Additionally, it features an API for implementing custom
collectors for gathering metrics from almost any source.
This package contains the 'diamond' python module.

Alternatives

Package Version Architecture Repository
python-diamond_4.0.515-5ubuntu1_all.deb 4.0.515 all Ubuntu Universe
python-diamond - - -

Requires

Name Value
python-configobj -
python-pkg-resources -
python:any >= 2.7~
python:any << 2.8

Download

Type URL
Mirror archive.ubuntu.com
Binary Package python-diamond_4.0.515-5ubuntu1_all.deb
Source Package diamond

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install python-diamond deb package:
    # sudo apt-get install python-diamond

Files

Path
/usr/lib/python2.7/dist-packages/diamond-4.0.515.egg-info
/usr/lib/python2.7/dist-packages/diamond/__init__.py
/usr/lib/python2.7/dist-packages/diamond/collector.py
/usr/lib/python2.7/dist-packages/diamond/convertor.py
/usr/lib/python2.7/dist-packages/diamond/error.py
/usr/lib/python2.7/dist-packages/diamond/gmetric.py
/usr/lib/python2.7/dist-packages/diamond/metric.py
/usr/lib/python2.7/dist-packages/diamond/server.py
/usr/lib/python2.7/dist-packages/diamond/util.py
/usr/lib/python2.7/dist-packages/diamond/version.py
/usr/lib/python2.7/dist-packages/diamond/handler/Handler.py
/usr/lib/python2.7/dist-packages/diamond/handler/__init__.py
/usr/lib/python2.7/dist-packages/diamond/handler/archive.py
/usr/lib/python2.7/dist-packages/diamond/handler/cloudwatch.py
/usr/lib/python2.7/dist-packages/diamond/handler/datadog.py
/usr/lib/python2.7/dist-packages/diamond/handler/g_metric.py
/usr/lib/python2.7/dist-packages/diamond/handler/graphite.py
/usr/lib/python2.7/dist-packages/diamond/handler/graphitepickle.py
/usr/lib/python2.7/dist-packages/diamond/handler/hostedgraphite.py
/usr/lib/python2.7/dist-packages/diamond/handler/httpHandler.py
/usr/lib/python2.7/dist-packages/diamond/handler/influxdbHandler.py
/usr/lib/python2.7/dist-packages/diamond/handler/libratohandler.py
/usr/lib/python2.7/dist-packages/diamond/handler/logentries_diamond.py
/usr/lib/python2.7/dist-packages/diamond/handler/mqtt.py
/usr/lib/python2.7/dist-packages/diamond/handler/multigraphite.py
/usr/lib/python2.7/dist-packages/diamond/handler/multigraphitepickle.py
/usr/lib/python2.7/dist-packages/diamond/handler/mysql.py
/usr/lib/python2.7/dist-packages/diamond/handler/null.py
/usr/lib/python2.7/dist-packages/diamond/handler/queue.py
/usr/lib/python2.7/dist-packages/diamond/handler/rabbitmq_pubsub.py
/usr/lib/python2.7/dist-packages/diamond/handler/rabbitmq_topic.py
/usr/lib/python2.7/dist-packages/diamond/handler/riemann.py
/usr/lib/python2.7/dist-packages/diamond/handler/rrdtool.py
/usr/lib/python2.7/dist-packages/diamond/handler/sentry.py
/usr/lib/python2.7/dist-packages/diamond/handler/signalfx.py
/usr/lib/python2.7/dist-packages/diamond/handler/stats_d.py
/usr/lib/python2.7/dist-packages/diamond/handler/statsite.py
/usr/lib/python2.7/dist-packages/diamond/handler/tsdb.py
/usr/lib/python2.7/dist-packages/diamond/handler/zmq_pubsub.py
/usr/lib/python2.7/dist-packages/diamond/utils/__init__.py
/usr/lib/python2.7/dist-packages/diamond/utils/classes.py
/usr/lib/python2.7/dist-packages/diamond/utils/config.py
/usr/lib/python2.7/dist-packages/diamond/utils/log.py
/usr/lib/python2.7/dist-packages/diamond/utils/scheduler.py
/usr/lib/python2.7/dist-packages/diamond/utils/signals.py
/usr/share/doc/python-diamond/changelog.Debian.gz
/usr/share/doc/python-diamond/copyright

Changelog

2019-02-04 - Graham Inggs <ginggs@ubuntu.com>
diamond (4.0.515-5ubuntu1) disco; urgency=medium
* Do not use upstart for Ubuntu
2019-02-03 - Sandro Tosi <morph@debian.org>
diamond (4.0.515-5) unstable; urgency=medium
* debian/copyright
- extend packaging copyright years
* debian/control
- bump Standards-Version to 4.3.0 (no changes needed)
* bump compat level to 11
2017-05-28 - Sandro Tosi <morph@debian.org>
diamond (4.0.515-4) unstable; urgency=medium
* debian/diamond.service
- set KillMode to `mixed`; Closes: #854842
2017-01-22 - Sandro Tosi <morph@debian.org>
diamond (4.0.515-3) unstable; urgency=medium
* debian/control
- install python-pkg-resources with python-diamond; Closes: #851198
- add lsb-base (>= 3.0-6) to diamond suggests, for those still using init.d;
Closes: #851745
2017-01-05 - Sandro Tosi <morph@debian.org>
diamond (4.0.515-2) unstable; urgency=medium
* debian/control
- add configobj to depends on both bin packages; Closes: #824228
* debian/copyright
- extend packaging copyright years
2016-12-17 - Sandro Tosi <morph@debian.org>
diamond (4.0.515-1) unstable; urgency=medium
* New upstream release
* compat level 10
2016-06-16 - Sandro Tosi <morph@debian.org>
diamond (4.0.451-1) unstable; urgency=medium
* New upstream release
* debian/rules
- dont install README.md, removed upstream
* debian/control
- suggests psutil, used by memory collector
- bump Standards-Version to 3.9.8 (no changes needed)
2016-02-15 - Sandro Tosi <morph@debian.org>
diamond (4.0.195-1) unstable; urgency=low
* Initial release (Closes: #814784)

See Also

Package Description
python-diaspy-doc_0.6.0-1_all.deb unofficial interface to the Diaspora social network (documentation)
python-diaspy_0.6.0-1_all.deb unofficial interface to the Diaspora social network (Python 2)
python-dib-utils_0.0.6-2_all.deb Standalone tools related to diskimage-builder - Python 2.x
python-dicom_1.2.1-1_all.deb transitional package for python-pydicom
python-dictclient_1.0.3.2_all.deb Python client library for DICT (RFC2229) protocol
python-dictdlib_2.0.4.1+nmu1build1_all.deb Python library for generating dictd dictionaries
python-dictobj_0.4-3_all.deb Python dictionary where keys can be accessed as instance attributes
python-dicttoxml_1.7.4-1_all.deb Python module for converting dict into a XML string
python-diff-match-patch_20121119-4_all.deb robust algorithms for synchronizing plain text (Python 2 module)
python-digitalocean-doc_1.13.2-1_all.deb Python bindings for the DigitalOcean API (common documentation)
python-digitalocean_1.13.2-1_all.deb Python bindings for the DigitalOcean API (Python 2)
python-dijitso_2018.1.1~git1-1_all.deb distributed just-in-time building of shared libraries
python-dill_0.2.9-1_all.deb Serialize all of Python (almost)
python-dingus_0.3.4-1_all.deb A record-then-assert mocking library
python-dipy-doc_0.14.0-1_all.deb Python library for the analysis of diffusion MRI datasets -- documentation
Advertisement
Advertisement