python-cvxopt_1.1.9+dfsg-3build2_amd64.deb


Advertisement

Description

python-cvxopt - Python package for convex optimization

Property Value
Distribution Ubuntu 19.04 (Disco Dingo)
Repository Ubuntu Universe amd64
Package filename python-cvxopt_1.1.9+dfsg-3build2_amd64.deb
Package name python-cvxopt
Package version 1.1.9+dfsg
Package release 3build2
Package architecture amd64
Package type deb
Category universe/python
Homepage http://cvxopt.org/
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 246.47 KB
Installed size 1.21 MB
CVXOPT is a Python package for convex optimization. It includes
* Python classes for storing and manipulating dense and sparse matrices
* an interface to most of the double-precision real and complex BLAS
* an interface to the dense linear equation solvers and eigenvalue
routines from LAPACK
* interfaces to the sparse LU and Cholesky solvers from UMFPACK and
CHOLMOD.
* routines for solving convex optimization problems, an interface to
the linear programming solver in GLPK, and interfaces to the
linear and quadratic programming solvers in MOSEK
* a modeling tool for specifying convex piecewise-linear
optimization problems.
This package contains the Python 2 module.

Alternatives

Package Version Architecture Repository
python-cvxopt_1.1.9+dfsg-3build2_i386.deb 1.1.9+dfsg i386 Ubuntu Universe
python-cvxopt - - -

Requires

Name Value
libamd2 >= 1:4.5.2
libblas.so.3 -
libblas3 -
libc6 >= 2.14
libcholmod3 >= 1:4.5.2
libdsdp-5.8gf -
libfftw3-double3 >= 3.3.5
libglpk40 >= 4.59
libgsl23 >= 2.5
liblapack.so.3 -
liblapack3 -
libumfpack5 >= 1:4.5.2
python >= 2.7~
python << 2.8
python:any << 2.8
python:any >= 2.7~

Provides

Name Value
python2.7-cvxopt -

Download

Type URL
Mirror archive.ubuntu.com
Binary Package python-cvxopt_1.1.9+dfsg-3build2_amd64.deb
Source Package cvxopt

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install python-cvxopt deb package:
    # sudo apt-get install python-cvxopt

Files

Path
/usr/lib/python2.7/dist-packages/cvxopt-1.1.9.egg-info
/usr/lib/python2.7/dist-packages/cvxopt/__init__.py
/usr/lib/python2.7/dist-packages/cvxopt/_version.py
/usr/lib/python2.7/dist-packages/cvxopt/amd.x86_64-linux-gnu.so
/usr/lib/python2.7/dist-packages/cvxopt/base.x86_64-linux-gnu.so
/usr/lib/python2.7/dist-packages/cvxopt/blas.x86_64-linux-gnu.so
/usr/lib/python2.7/dist-packages/cvxopt/cholmod.x86_64-linux-gnu.so
/usr/lib/python2.7/dist-packages/cvxopt/coneprog.py
/usr/lib/python2.7/dist-packages/cvxopt/cvxprog.py
/usr/lib/python2.7/dist-packages/cvxopt/dsdp.x86_64-linux-gnu.so
/usr/lib/python2.7/dist-packages/cvxopt/fftw.x86_64-linux-gnu.so
/usr/lib/python2.7/dist-packages/cvxopt/glpk.x86_64-linux-gnu.so
/usr/lib/python2.7/dist-packages/cvxopt/gsl.x86_64-linux-gnu.so
/usr/lib/python2.7/dist-packages/cvxopt/info.py
/usr/lib/python2.7/dist-packages/cvxopt/lapack.x86_64-linux-gnu.so
/usr/lib/python2.7/dist-packages/cvxopt/misc.py
/usr/lib/python2.7/dist-packages/cvxopt/misc_solvers.x86_64-linux-gnu.so
/usr/lib/python2.7/dist-packages/cvxopt/modeling.py
/usr/lib/python2.7/dist-packages/cvxopt/msk.py
/usr/lib/python2.7/dist-packages/cvxopt/printing.py
/usr/lib/python2.7/dist-packages/cvxopt/solvers.py
/usr/lib/python2.7/dist-packages/cvxopt/umfpack.x86_64-linux-gnu.so
/usr/share/doc/python-cvxopt/changelog.Debian.gz
/usr/share/doc/python-cvxopt/copyright

Changelog

2018-11-03 - Matthias Klose <doko@ubuntu.com>
cvxopt (1.1.9+dfsg-3build2) disco; urgency=medium
* No-change rebuild to build without python3.6 support.
2018-06-28 - Matthias Klose <doko@ubuntu.com>
cvxopt (1.1.9+dfsg-3build1) cosmic; urgency=medium
* No-change rebuild to build for python3.7.
2018-04-16 - Andreas Tille <tille@debian.org>
cvxopt (1.1.9+dfsg-3) unstable; urgency=medium
* Build-Depends: s/python-sphinx*/python3-sphinx*/
* Testsuite: autopkgtest-pkg-python
* Standards-Version: 4.1.4
* Point Vcs fields to salsa.debian.org
2017-08-21 - Sébastien Villemot <sebastien@debian.org>
cvxopt (1.1.9+dfsg-2) unstable; urgency=medium
* Team upload.
[ Julian Gilbey ]
* Fix breakage of earlier version by adding Replaces+Breaks
python-cvxopt (<< 1.1.8) to -doc package (closes: #859579)
[ Sébastien Villemot ]
* Update homepage.
* Use https for Format field of d/copyright.
* Remove useless build-dependency on libatlas-base-dev.
* python{,3}-cvxopt now suggest python-cvxopt-doc (Closes: #858106).
* Add a build-dependency on latexmk, required to build with Sphinx 1.6
(Closes: #872170).
* Drop glpk-4.49.diff, no longer needed (Closes: #840159).
* Support nodoc flag of DEB_BUILD_OPTIONS.
* Bump Standards-Version to 4.0.1.
2017-06-19 - Andreas Tille <tille@debian.org>
cvxopt (1.1.9+dfsg-1) unstable; urgency=medium
* New upstream version
* debhelper 10
* drop Soeren Sonnenburg from Uploaders
* delete empty dirs usr/cvxopt from binary package
2016-07-20 - Andreas Tille <tille@debian.org>
cvxopt (1.1.8+dfsg-1) experimental; urgency=medium
* New upstream version
Closes: #708347
* Team maintenance in Debian Science team
* DEP5
* cme fix dpkg-control
* debhelper 9
* debian/rules: dh + pybuild
* exclude suitesparse code copy
Closes: #719804
* hardening=+bindnow
* Python3 + doc package
Closes: #822557 
2016-07-16 - Bas Couwenberg <sebastic@debian.org>
cvxopt (1.1.4-1.5) unstable; urgency=medium
* Non-maintainer upload.
* Add build dependency on texlive-generic-extra for iftex.sty.
(closes: #830343)
* Update watch file for GitHub releases.
(closes: #780307)
2016-01-26 - Mattia Rizzolo <mattia@debian.org>
cvxopt (1.1.4-1.4) unstable; urgency=medium
* Non-maintainer upload.
[ Bas Couwenberg ]
* Update build dependencies for GSL 2, change libgsl0-dev to libgsl-dev.
Closes: #807196
2015-03-11 - Jean-Michel Nirgal Vourgère <jmv_deb@nirgal.com>
cvxopt (1.1.4-1.3) unstable; urgency=medium
* Non-maintainer upload.
* Fix glpk-4.49.diff: Link the lpx emulation file, fix the #if activation
test. This fixes "undefined symbol: lpx_create_prob" bugs. (Closes: #780251)
2013-12-06 - Sébastien Villemot <sebastien@debian.org>
cvxopt (1.1.4-1.2) unstable; urgency=medium
* Non-maintainer upload.
* glpk-4.49.diff: fix GLPK version detection (the wrong macro was used).
(Closes: #731445)

See Also

Package Description
python-cwiid_0.6.00+svn201-4_amd64.deb library to interface with the wiimote
python-cxx-dev_7.0.3-2_all.deb Set of facilities to extend Python with C++
python-cycler-doc_0.10.0-1_all.deb composable kwarg iterator (documentation)
python-cycler_0.10.0-1_all.deb composable kwarg iterator (Python 2)
python-cyclone_1.1-2_all.deb web server framework for Python Twisted using the Tornado API
python-cylc_7.8.0-5_amd64.deb Python libraries for cylc workflow scheduler
python-cymruwhois-doc_1.6-3.1_all.deb python-cymruwhois common documentation
python-cymruwhois_1.6-3.1_all.deb Python library for interfacing with the whois.cymru.com service (Python 2)
python-cypari2-doc_1.3.1-2_all.deb Python interface to PARI -- documentation
python-cypari2_1.3.1-2_amd64.deb Python interface to PARI -- Python 2
python-cysignals-bare_1.8.1+ds-2_amd64.deb interrupt and signal handling for Cython -- Python - bare
python-cysignals-doc_1.8.1+ds-2_all.deb interrupt and signal handling for Cython -- doc
python-cysignals-pari_1.8.1+ds-2_amd64.deb interrupt and signal handling for Cython -- Python - PARI/GP
python-cyvcf2_0.10.8-1_amd64.deb VCF parser based on htslib (Python 2)
python-d2to1_0.2.12-1_all.deb Python support for distutils2-like setup.cfg files as package metadata
Advertisement
Advertisement