python-colorlog_4.0.1-1_all.deb


Advertisement

Description

python-colorlog - formatter to use with the logging module of Python 2

Property Value
Distribution Ubuntu 19.04 (Disco Dingo)
Repository Ubuntu Universe amd64
Package filename python-colorlog_4.0.1-1_all.deb
Package name python-colorlog
Package version 4.0.1
Package release 1
Package architecture all
Package type deb
Category universe/python
Homepage https://github.com/borntyping/python-colorlog
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 19.59 KB
Installed size 81.00 KB
python-colorlog allows colors to be placed in the format string, which is
mostly useful when paired with a StreamHandler that is outputting to a
terminal. This is accomplished by adding a set of terminal color codes to the
record before it is used to format the string.
This is the Python 2 version.

Alternatives

Package Version Architecture Repository
python-colorlog_4.0.1-1_all.deb 4.0.1 all Ubuntu Universe
python-colorlog - - -

Requires

Name Value
python:any >= 2.7~
python:any << 2.8

Download

Type URL
Mirror archive.ubuntu.com
Binary Package python-colorlog_4.0.1-1_all.deb
Source Package python-colorlog

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install python-colorlog deb package:
    # sudo apt-get install python-colorlog

Files

Path
/usr/lib/python2.7/dist-packages/colorlog/__init__.py
/usr/lib/python2.7/dist-packages/colorlog/colorlog.py
/usr/lib/python2.7/dist-packages/colorlog/escape_codes.py
/usr/lib/python2.7/dist-packages/colorlog/logging.py
/usr/lib/python2.7/dist-packages/colorlog-4.0.1.egg-info/PKG-INFO
/usr/lib/python2.7/dist-packages/colorlog-4.0.1.egg-info/dependency_links.txt
/usr/lib/python2.7/dist-packages/colorlog-4.0.1.egg-info/requires.txt
/usr/lib/python2.7/dist-packages/colorlog-4.0.1.egg-info/top_level.txt
/usr/lib/python2.7/dist-packages/colorlog/tests/conftest.py
/usr/lib/python2.7/dist-packages/colorlog/tests/test_colorlog.py
/usr/lib/python2.7/dist-packages/colorlog/tests/test_config.py
/usr/lib/python2.7/dist-packages/colorlog/tests/test_escape_codes.py
/usr/lib/python2.7/dist-packages/colorlog/tests/test_example.py
/usr/lib/python2.7/dist-packages/colorlog/tests/test_exports.py
/usr/lib/python2.7/dist-packages/colorlog/tests/test_logging.py
/usr/share/doc/python-colorlog/README.md.gz
/usr/share/doc/python-colorlog/changelog.Debian.gz
/usr/share/doc/python-colorlog/copyright
/usr/share/doc/python-colorlog/examples/custom_level.py
/usr/share/doc/python-colorlog/examples/example.png
/usr/share/doc/python-colorlog/examples/example.py
/usr/share/lintian/overrides/python-colorlog

Changelog

2019-01-03 - Philipp Huebner <debalance@debian.org>
python-colorlog (4.0.1-1) unstable; urgency=medium
* New upstream version 4.0.1
* Updated years in debian/copyright
* Updated Standards-Version: 4.3.0 (no changes needed)
* Switched to debhelper compat level 12
2018-05-09 - Philipp Huebner <debalance@debian.org>
python-colorlog (3.1.4-1) unstable; urgency=medium
* New upstream version 3.1.4
* Fixed a long description in debian/control
* Updated Standards-Version: 4.1.4 (no changes needed)
* Updated debian/copyright
* Switched to debhelper 11
2018-01-28 - Philipp Huebner <debalance@debian.org>
python-colorlog (3.1.2-1) unstable; urgency=medium
* New upstream version 3.1.2
* Updated Vcs-* fields in debian/control
* Updated Standards-Version: 4.1.3 (no changes needed)
* Updated years in debian/copyright
2017-09-21 - Philipp Huebner <debalance@debian.org>
python-colorlog (3.1.0-1) unstable; urgency=medium
* New upstream version 3.1.0
2017-07-07 - Philipp Huebner <debalance@debian.org>
python-colorlog (2.10.0-2) unstable; urgency=medium
* Fix python3 dependencies (Closes: #867422)
* Updated Standards-Version: 3.9.8 (no changes needed)
* Updated years in debian/copyright
2016-11-23 - Philipp Huebner <debalance@debian.org>
python-colorlog (2.10.0-1) unstable; urgency=medium
* New upstream version 2.10.0
2016-05-29 - Philipp Huebner <debalance@debian.org>
python-colorlog (2.7.0-1) unstable; urgency=medium
* Imported Upstream version 2.7.0
2016-05-01 - Philipp Huebner <debalance@debian.org>
python-colorlog (2.6.3-1) unstable; urgency=medium
* Imported Upstream version 2.6.3
* Updated Standards-Version: 3.9.8 (no changes needed)
* Updated years in debian/copyright
* Updated Vcs-* fields in debian/control
* Install docs and examples correctly
2015-04-26 - Philipp Huebner <debalance@debian.org>
python-colorlog (2.6.0-1) unstable; urgency=medium
* New upstream release
* Correct debian/watch
* Add Vcs links to debian/control
* Update Standards-Version: 3.9.6 (no changes needed)
2014-09-04 - Philipp Huebner <debalance@debian.org>
python-colorlog (2.4.0-1) unstable; urgency=low
* Initial release (Closes: #760356)

See Also

Package Description
python-colormap_1.0.2-1_all.deb ease manipulation of matplotlib colormaps and color codecs (Python 2)
python-colorspacious_1.1.2-1_all.deb library for doing colorspace conversions - Python 2.X
python-colour_0.1.5-1_all.deb converts and manipulates various color representation - Python 2.X
python-comedilib_0.11.0-1_amd64.deb Python wrapper for Comedilib
python-commando_1.0.0-0.2_all.deb wrapper for argparse to define declaratively (Python 2)
python-commonmark-bkrs-doc_0.5.4+ds-2_all.deb Python parser for the CommonMark Markdown spec -- doc
python-commonmark-bkrs_0.5.4+ds-2_all.deb Python parser for the CommonMark Markdown spec -- Python
python-concurrent.futures_3.2.0-2_all.deb backport of concurrent.futures package from Python 3.2
python-confget_2.2.0-3_all.deb read variables from INI-style configuration files - Python 2.x library
python-configargparse_0.13.0-1_all.deb replacement for argparse with config files and environment variables (Python 2)
python-configglue_1.1.2-0ubuntu3_all.deb Glues together optparse.OptionParser and ConfigParser.ConfigParser
python-configobj_5.0.6-3_all.deb simple but powerful config file reader and writer for Python 2
python-configshell-fb-doc_1.1.24-1_all.deb Python library for building configuration shells - doc
python-configshell-fb_1.1.24-1_all.deb Python library for building configuration shells - Python 2
python-confluent-kafka_0.11.6-1_amd64.deb Python client to interact with Kafka - Python 2.7
Advertisement
Advertisement