python-bumps_0.7.11-2_all.deb


Advertisement

Description

python-bumps - data fitting and Bayesian uncertainty modeling for inverse problems (Python 2)

Property Value
Distribution Ubuntu 19.04 (Disco Dingo)
Repository Ubuntu Universe amd64
Package filename python-bumps_0.7.11-2_all.deb
Package name python-bumps
Package version 0.7.11
Package release 2
Package architecture all
Package type deb
Category universe/python
Homepage https://github.com/bumps/bumps
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 381.01 KB
Installed size 1.50 MB
Bumps is a set of routines for curve fitting and uncertainty analysis
from a Bayesian perspective. In addition to traditional optimizers
which search for the best minimum they can find in the search space,
bumps provides uncertainty analysis which explores all viable minima
and finds confidence intervals on the parameters based on uncertainty
in the measured values. Bumps has been used for systems of up to 100
parameters with tight constraints on the parameters. Full uncertainty
analysis requires hundreds of thousands of function evaluations,
which is only feasible for cheap functions, systems with many
processors, or lots of patience.
Bumps includes several traditional local optimizers such as
Nelder-Mead simplex, BFGS and differential evolution. Bumps
uncertainty analysis uses Markov chain Monte Carlo to explore the
parameter space. Although it was created for curve fitting problems,
Bumps can explore any probability density function, such as those
defined by PyMC. In particular, the bumps uncertainty analysis works
well with correlated parameters.
Bumps can be used as a library within your own applications, or as a
framework for fitting, complete with a graphical user interface to
manage your models.
This package installs the library for Python 2.

Alternatives

Package Version Architecture Repository
python-bumps_0.7.11-2_all.deb 0.7.11 all Ubuntu Universe
python-bumps - - -

Requires

Name Value
python << 2.8
python >= 2.7~
python-matplotlib >= 1.0
python-numpy >= 1.3.0
python-scipy >= 0.7.0
python-six -
python-typing -
python:any >= 2.7~
python:any << 2.8

Download

Type URL
Mirror archive.ubuntu.com
Binary Package python-bumps_0.7.11-2_all.deb
Source Package python-bumps

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install python-bumps deb package:
    # sudo apt-get install python-bumps

Files

Path
/usr/bin/bumps2
/usr/lib/python2.7/dist-packages/bumps/__init__.py
/usr/lib/python2.7/dist-packages/bumps/bounds.py
/usr/lib/python2.7/dist-packages/bumps/bspline.py
/usr/lib/python2.7/dist-packages/bumps/cheby.py
/usr/lib/python2.7/dist-packages/bumps/cli.py
/usr/lib/python2.7/dist-packages/bumps/curve.py
/usr/lib/python2.7/dist-packages/bumps/data.py
/usr/lib/python2.7/dist-packages/bumps/errplot.py
/usr/lib/python2.7/dist-packages/bumps/fitproblem.py
/usr/lib/python2.7/dist-packages/bumps/fitservice.py
/usr/lib/python2.7/dist-packages/bumps/fitters.py
/usr/lib/python2.7/dist-packages/bumps/formatnum.py
/usr/lib/python2.7/dist-packages/bumps/history.py
/usr/lib/python2.7/dist-packages/bumps/initpop.py
/usr/lib/python2.7/dist-packages/bumps/lsqerror.py
/usr/lib/python2.7/dist-packages/bumps/mapper.py
/usr/lib/python2.7/dist-packages/bumps/monitor.py
/usr/lib/python2.7/dist-packages/bumps/mono.py
/usr/lib/python2.7/dist-packages/bumps/mpfit.py
/usr/lib/python2.7/dist-packages/bumps/names.py
/usr/lib/python2.7/dist-packages/bumps/openmp_ext.py
/usr/lib/python2.7/dist-packages/bumps/options.py
/usr/lib/python2.7/dist-packages/bumps/parameter.py
/usr/lib/python2.7/dist-packages/bumps/partemp.py
/usr/lib/python2.7/dist-packages/bumps/pdfwrapper.py
/usr/lib/python2.7/dist-packages/bumps/plotutil.py
/usr/lib/python2.7/dist-packages/bumps/plugin.py
/usr/lib/python2.7/dist-packages/bumps/pmath.py
/usr/lib/python2.7/dist-packages/bumps/pymcfit.py
/usr/lib/python2.7/dist-packages/bumps/pytwalk.py
/usr/lib/python2.7/dist-packages/bumps/quasinewton.py
/usr/lib/python2.7/dist-packages/bumps/random_lines.py
/usr/lib/python2.7/dist-packages/bumps/simplex.py
/usr/lib/python2.7/dist-packages/bumps/util.py
/usr/lib/python2.7/dist-packages/bumps/wsolve.py
/usr/lib/python2.7/dist-packages/bumps-0.7.11.egg-info/PKG-INFO
/usr/lib/python2.7/dist-packages/bumps-0.7.11.egg-info/dependency_links.txt
/usr/lib/python2.7/dist-packages/bumps-0.7.11.egg-info/requires.txt
/usr/lib/python2.7/dist-packages/bumps-0.7.11.egg-info/top_level.txt
/usr/lib/python2.7/dist-packages/bumps/dream/__init__.py
/usr/lib/python2.7/dist-packages/bumps/dream/_compiled.so
/usr/lib/python2.7/dist-packages/bumps/dream/acr.py
/usr/lib/python2.7/dist-packages/bumps/dream/bounds.py
/usr/lib/python2.7/dist-packages/bumps/dream/compiled.py
/usr/lib/python2.7/dist-packages/bumps/dream/core.py
/usr/lib/python2.7/dist-packages/bumps/dream/corrplot.py
/usr/lib/python2.7/dist-packages/bumps/dream/crossover.py
/usr/lib/python2.7/dist-packages/bumps/dream/diffev.py
/usr/lib/python2.7/dist-packages/bumps/dream/entropy.py
/usr/lib/python2.7/dist-packages/bumps/dream/exppow.py
/usr/lib/python2.7/dist-packages/bumps/dream/formatnum.py
/usr/lib/python2.7/dist-packages/bumps/dream/gelman.py
/usr/lib/python2.7/dist-packages/bumps/dream/geweke.py
/usr/lib/python2.7/dist-packages/bumps/dream/initpop.py
/usr/lib/python2.7/dist-packages/bumps/dream/ksmirnov.py
/usr/lib/python2.7/dist-packages/bumps/dream/mahal.py
/usr/lib/python2.7/dist-packages/bumps/dream/matlab.py
/usr/lib/python2.7/dist-packages/bumps/dream/metropolis.py
/usr/lib/python2.7/dist-packages/bumps/dream/model.py
/usr/lib/python2.7/dist-packages/bumps/dream/outliers.py
/usr/lib/python2.7/dist-packages/bumps/dream/state.py
/usr/lib/python2.7/dist-packages/bumps/dream/stats.py
/usr/lib/python2.7/dist-packages/bumps/dream/tile.py
/usr/lib/python2.7/dist-packages/bumps/dream/util.py
/usr/lib/python2.7/dist-packages/bumps/dream/views.py
/usr/lib/python2.7/dist-packages/bumps/dream/walk.py
/usr/lib/python2.7/dist-packages/bumps/gui/__init__.py
/usr/lib/python2.7/dist-packages/bumps/gui/about.py
/usr/lib/python2.7/dist-packages/bumps/gui/app_frame.py
/usr/lib/python2.7/dist-packages/bumps/gui/app_panel.py
/usr/lib/python2.7/dist-packages/bumps/gui/console.py
/usr/lib/python2.7/dist-packages/bumps/gui/convergence_view.py
/usr/lib/python2.7/dist-packages/bumps/gui/data_view.py
/usr/lib/python2.7/dist-packages/bumps/gui/fit_dialog.py
/usr/lib/python2.7/dist-packages/bumps/gui/fit_thread.py
/usr/lib/python2.7/dist-packages/bumps/gui/fit_view.py
/usr/lib/python2.7/dist-packages/bumps/gui/gui_app.py
/usr/lib/python2.7/dist-packages/bumps/gui/input_list.py
/usr/lib/python2.7/dist-packages/bumps/gui/log_view.py
/usr/lib/python2.7/dist-packages/bumps/gui/parameter_view.py
/usr/lib/python2.7/dist-packages/bumps/gui/plot_view.py
/usr/lib/python2.7/dist-packages/bumps/gui/resfiles.py
/usr/lib/python2.7/dist-packages/bumps/gui/signal.py
/usr/lib/python2.7/dist-packages/bumps/gui/summary_view.py
/usr/lib/python2.7/dist-packages/bumps/gui/uncertainty_view.py
/usr/lib/python2.7/dist-packages/bumps/gui/util.py
/usr/lib/python2.7/dist-packages/bumps/gui/utilities.py
/usr/lib/python2.7/dist-packages/bumps/gui/resources/__init__.py
/usr/lib/python2.7/dist-packages/bumps/gui/resources/bumps.ico
/usr/lib/python2.7/dist-packages/bumps/gui/resources/bumps_splash.jpg
/usr/lib/python2.7/dist-packages/bumps/gui/resources/done.wav
/usr/lib/python2.7/dist-packages/bumps/gui/resources/import_script.png
/usr/lib/python2.7/dist-packages/bumps/gui/resources/reload.png
/usr/lib/python2.7/dist-packages/bumps/gui/resources/start_fit.png
/usr/lib/python2.7/dist-packages/bumps/gui/resources/stop_fit.png
/usr/lib/python2.7/dist-packages/bumps/mystic/__init__.py
/usr/lib/python2.7/dist-packages/bumps/mystic/condition.py
/usr/lib/python2.7/dist-packages/bumps/mystic/solver.py
/usr/lib/python2.7/dist-packages/bumps/mystic/stop.py
/usr/lib/python2.7/dist-packages/bumps/mystic/util.py
/usr/lib/python2.7/dist-packages/bumps/mystic/examples/__init__.py
/usr/lib/python2.7/dist-packages/bumps/mystic/examples/circle.py
/usr/lib/python2.7/dist-packages/bumps/mystic/examples/corana.py
/usr/lib/python2.7/dist-packages/bumps/mystic/examples/decay.py
/usr/lib/python2.7/dist-packages/bumps/mystic/examples/model.py
/usr/lib/python2.7/dist-packages/bumps/mystic/examples/simple.py
/usr/lib/python2.7/dist-packages/bumps/mystic/optimizer/__init__.py
/usr/lib/python2.7/dist-packages/bumps/mystic/optimizer/de.py
/usr/lib/python2.7/dist-packages/bumps/mystic/optimizer/diffev_compat.py
/usr/lib/python2.7/dist-packages/bumps/numdifftools/__init__.py
/usr/lib/python2.7/dist-packages/bumps/numdifftools/core.py
/usr/lib/python2.7/dist-packages/bumps/numdifftools/extrapolation.py
/usr/lib/python2.7/dist-packages/bumps/numdifftools/info.py
/usr/lib/python2.7/dist-packages/bumps/numdifftools/multicomplex.py
/usr/share/doc/python-bumps/changelog.Debian.gz
/usr/share/doc/python-bumps/copyright
/usr/share/man/man1/bumps2.1.gz

Changelog

2018-12-26 - Stuart Prescott <stuart@debian.org>
python-bumps (0.7.11-2) unstable; urgency=medium
* Ensure arch-dep and arch-indep parts can be built separately
(Closes: #917062).
* Only try to build shared object on supported architectures.
* Make the python-bumps modules packages depend on the compiled libraries
in bumps-private-libs where possible (Closes: #916617).
* Update Standards-Version to 4.3.0 (no changes required).
2018-12-12 - Stuart Prescott <stuart@debian.org>
python-bumps (0.7.11-1) unstable; urgency=medium
[ Drew Parsons ]
* add BSD-3 licence entry for Random123 to debian/copyright.
* build compiled.c with Random123 to speed up bumps/dream
- destabilises build time tests of dream, so skip them
[ Stuart Prescott ]
* New upstream release.
* Add new bumps-private-libs package for .so.
* Fix compile flags for .so.
* Also skip dream tests in the autopkgtests.
* Update Standards-Version to 4.2.1 (no changes required).
2018-06-17 - Drew Parsons <dparsons@debian.org>
python-bumps (0.7.10-1) unstable; urgency=medium
* New upstream version.
- now (0.7.9) supports wx 4 in python3
- applies Debian patches matplotlibwx.patch, numpy-whitespace.patch
and test-precision.patch
* Standards-Version: 4.1.4
* remove ancient-python-version-field X-Python-Version: >= 2.6 and
X-Python3-Version: >= 3.2
2018-05-09 - Stuart Prescott <stuart@debian.org>
python-bumps (0.7.6-5) unstable; urgency=medium
* Fix doctests to work with numpy 1.14.
2018-04-16 - Stuart Prescott <stuart@debian.org>
python-bumps (0.7.6-4) unstable; urgency=medium
* Update to new matplotlib API.
* Add missing dependencies to packages.
2017-12-30 - Stuart Prescott <stuart@debian.org>
python-bumps (0.7.6-3) unstable; urgency=medium
* Allow numerical fuzz in tests.
* Update Standards-Version to 4.1.2 (no changes required).
* Set Rules-Require-Root: no.
* Switch to dehelper compat 11.
- update to place documentation in /usr/share/doc/python-bumps as per
Policy ยง12.3.
2017-11-14 - Drew Parsons <dparsons@debian.org>
python-bumps (0.7.6-2) unstable; urgency=medium
* Team upload.
* Fix package name in debian/watch.
* Add stray GPL and Expat licences to debian/copyright.
* python3 package now available (Thanks Stuart Prescott)
- rename the python2 version of /usr/bin/bumps as bumps2
- bumps.gui will fail in python3 since wx is not available
2017-10-29 - Drew Parsons <dparsons@debian.org>
python-bumps (0.7.6-1) unstable; urgency=medium
* Team upload.
* Initial release (Closes: #879829)
* python3-bumps can be built but has been deactivated since wx is
not yet available for python3, see Bug#880032.

See Also

Package Description
python-bunch_1.0.1-1_all.deb Dot-accessible Python dictionary (a la JavaScript objects)
python-burrito_0.9.1-3_all.deb Python 2 framework for wrapping and controlling command-line applications
python-buzhug_1.8-3_all.deb pure-Python database engine, using a Pythonic, no-SQL syntax
python-bx-tools_0.8.2-1_all.deb command line interface to python3-bx
python-bx_0.8.2-1_amd64.deb library to manage genomic data and its aligment
python-bz2file_0.98-2_all.deb Python library for reading and writing bzip2-compressed files
python-bzrlib.tests_2.7.0+bzr6622-15_all.deb distributed version control system - testsuite
python-bzrlib_2.7.0+bzr6622-15_amd64.deb distributed version control system - python library
python-cachecontrol_0.11.7-1_all.deb caching algorithms in httplib2 for use with requests
python-cached-property_1.5.1-2_all.deb Provides cached-property for decorating methods in classes (Python 2)
python-cachetools_3.1.0-2_all.deb extensible memoizing collections and decorators for Python
python-cairo-dev_1.16.2-1build2_all.deb Python cairo bindings: development files
python-cairo_1.16.2-1build2_amd64.deb Python bindings for the Cairo vector graphics library
python-cairocffi-doc_0.8.0-0ubuntu2_all.deb cffi-based cairo bindings for Python - Documentation
python-cairocffi_0.8.0-0ubuntu2_all.deb cffi-based cairo bindings for Python
Advertisement
Advertisement