python-blosc_1.7.0+ds1-1_amd64.deb


Advertisement

Description

python-blosc - Python bindings for the Blosc meta-compressor

Property Value
Distribution Ubuntu 19.04 (Disco Dingo)
Repository Ubuntu Universe amd64
Package filename python-blosc_1.7.0+ds1-1_amd64.deb
Package name python-blosc
Package version 1.7.0+ds1
Package release 1
Package architecture amd64
Package type deb
Category universe/python
Homepage https://github.com/Blosc/python-blosc
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 21.05 KB
Installed size 92.00 KB
Blosc (http://blosc.org) is a high performance compressor optimized for
binary data. It has been designed to transmit data to the processor cache
faster than the traditional, non-compressed, direct memory fetch approach
via a memcpy() OS call.
This package provides the official Python bindings in the Python 2 import
path.

Alternatives

Package Version Architecture Repository
python-blosc_1.7.0+ds1-1_i386.deb 1.7.0+ds1 i386 Ubuntu Universe
python-blosc - - -

Requires

Name Value
libblosc1 -
libc6 >= 2.4
python << 2.8
python >= 2.7~
python:any << 2.8
python:any >= 2.7~

Download

Type URL
Mirror archive.ubuntu.com
Binary Package python-blosc_1.7.0+ds1-1_amd64.deb
Source Package python-blosc

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install python-blosc deb package:
    # sudo apt-get install python-blosc

Files

Path
/usr/lib/python2.7/dist-packages/blosc/__init__.py
/usr/lib/python2.7/dist-packages/blosc/blosc_extension.x86_64-linux-gnu.so
/usr/lib/python2.7/dist-packages/blosc/test.py
/usr/lib/python2.7/dist-packages/blosc/toplevel.py
/usr/lib/python2.7/dist-packages/blosc/version.py
/usr/lib/python2.7/dist-packages/blosc-1.7.0.egg-info/PKG-INFO
/usr/lib/python2.7/dist-packages/blosc-1.7.0.egg-info/dependency_links.txt
/usr/lib/python2.7/dist-packages/blosc-1.7.0.egg-info/not-zip-safe
/usr/lib/python2.7/dist-packages/blosc-1.7.0.egg-info/top_level.txt
/usr/share/doc/python-blosc/README.gz
/usr/share/doc/python-blosc/changelog.Debian.gz
/usr/share/doc/python-blosc/copyright

Changelog

2018-12-29 - Daniel Stender <stender@debian.org>
python-blosc (1.7.0+ds1-1) unstable; urgency=medium
* New upstream release:
+ drop py2-coding-headers.patch (applied upstream).
* deb/control:
+ bump standards to 4.3.0 (no changes needed).
2018-11-18 - Daniel Stender <stender@debian.org>
python-blosc (1.6.2+ds1-2) unstable; urgency=medium
* restore (and unfuzz) catch-cpuinfo-import-error.patch.
2018-11-18 - Daniel Stender <stender@debian.org>
python-blosc (1.6.2+ds1-1) unstable; urgency=medium
* New upstream release.
* deb/control:
+ bump standards to 4.2.1 (no further changes needed).
* deb/copyright:
+ expand copyright span.
* deb/rules:
+ build with DH_VERBOSE=1 (according to policy 4.2.0).
+ drop unnecessary export line for DEB_BUILD_OPTIONS.
+ build with hardening=+all.
+ add checks for "nodoc" build option in related overrides.
* drop debian/patches/catch-cpuinfo-import-error.patch (obsolete).
* drop temporarily-disable-numpydoc.patch (not needed anymore).
* add py2-coding-headers.patch
* use build profile switches:
+ add !nodoc and !nocheck switches to b-deps in d/control.
+ add Build-Profiles field to docs package in d/control.
+ add check for nodoc in DEB_BUILD_PROFILES to dh sequencer call in d/rules,
skip sphinxdoc extension accordingly.
* build with dh level 11 (changes in d/compat and d/control).
[ Ondřej Nový ]
* d/control: Remove ancient X-Python-Version field
* d/control: Remove ancient X-Python3-Version field
* Use 'python3 -m sphinx' instead of sphinx-build for building docs
2018-05-01 - Daniel Stender <stender@debian.org>
python-blosc (1.5.1+ds2-1) unstable; urgency=medium
* use python-cpuinfo in the archive instead of vendored file:
+ add cpuinfo.py to Files-Excluded in deb/copyright.
+ drop license paragraph in deb/copyright.
+ add python{,3}-cpuinfo to build deps in deb/control.
* deb/control:
+ add psutil to build deps (needed by tests).
+ bump standards to 4.1.4 (no changes needed).
+ add numpy to Recommends (needed for running the tests).
* add DEP-8 testsuite.
2018-03-20 - Daniel Stender <stender@debian.org>
python-blosc (1.5.1+ds1-1) unstable; urgency=medium
* New upstream release.
* deb/control: pull numpydoc to build-deps.
* deb/copyright: expand copyright span.
* deb/rules: build extension inplace for docs.
* deb/clean: add inplace extension to cleans.
2018-02-19 - Daniel Stender <stender@debian.org>
python-blosc (1.4.4+ds1-5) unstable; urgency=medium
* deb/control: bump standards version to 4.1.3 (no further changes needed).
* deb/copyright: expand copyright span.
[ Ondřej Nový ]
* d/control: Set Vcs-* to salsa.debian.org
* d/copyright: Use https protocol in Format field
2017-08-25 - Daniel Stender <stender@debian.org>
python-blosc (1.4.4+ds1-4) unstable; urgency=medium
* add temporarily-disable-numpydoc.patch (Closes: #869195).
* deb/control:
+ add DPMT as Uploaders.
+ update Vcs fields (package source moved to python-modules).
* deb/gbp.conf:
+ set debian-branch to meet DEP-14.
+ add sign-tags set to True.
2016-12-18 - Daniel Stender <stender@debian.org>
python-blosc (1.4.4+ds1-3) unstable; urgency=medium
* Uploaded to unstable.
* deb/control:
+ drop build-deps on python-setuptools-scm (not needed).
* catch-cpuinfo-import-error.patch:
+ improved description text.
2016-12-17 - Daniel Stender <stender@debian.org>
python-blosc (1.4.4+ds1-2) experimental; urgency=medium
* Add catch-cpuinfo-import-error.patch.
2016-09-05 - Daniel Stender <stender@debian.org>
python-blosc (1.4.4+ds1-1) experimental; urgency=medium
* Initial release (Closes: #834777).

See Also

Package Description
python-bluez_0.22+really0.22-1_amd64.deb Python 2 wrappers around BlueZ for rapid bluetooth development
python-bobo_0.2.2-3build1_all.deb Web application framework for the impatient
python-boltons_18.0.1-1_all.deb set of pure-Python utilities (Python 2)
python-bond_1.8.3-1_all.deb Messages related to Robot OS bond_core - Python 2
python-bondpy_1.8.3-1_amd64.deb Python 2 implementation of bond
python-bootstrapform-doc_3.4-2_all.deb generate twitter-bootstrap form output for django form - doc
python-bootstrapform_3.4-2_all.deb generate twitter-bootstrap form output for django form - Python 2.x
python-boto3_1.9.86-1_all.deb Python interface to Amazon's Web Services - Python 2.x
python-boto_2.44.0-1.1ubuntu1_all.deb Python interface to Amazon's Web Services - Python 2.x
python-botocore_1.12.71+repack-1_all.deb Low-level, data-driven core of boto 3 (Python 2)
python-bottle-beaker_0.1.3-2_all.deb Bottle plugin beaker, WSGI middleware for sessions and caching - Python 2.X
python-bottle-cork_0.12.0-3_all.deb Authentication/Authorization library for Bottle - Python 2
python-bottle-doc_0.12.15-2_all.deb fast and simple WSGI-framework for Python - documentation
python-bottle-sqlite_0.1.3-2_all.deb SQLite3 integration for Bottle - Python 2.X
python-bottle_0.12.15-2_all.deb fast and simple WSGI-framework for Python
Advertisement
Advertisement