python-billiard_3.6.0.0-1_amd64.deb


Advertisement

Description

python-billiard - Multiprocessing Pool Extensions for Python

Property Value
Distribution Ubuntu 19.04 (Disco Dingo)
Repository Ubuntu Universe amd64
Package filename python-billiard_3.6.0.0-1_amd64.deb
Package name python-billiard
Package version 3.6.0.0
Package release 1
Package architecture amd64
Package type deb
Category universe/python
Homepage https://github.com/celery/billiard
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 70.16 KB
Installed size 366.00 KB
This package contains extensions to the multiprocessing Pool.
It extends the multiprocessing.Pool with a billiard.pool.DynamicPool
that can grow in size.

Alternatives

Package Version Architecture Repository
python-billiard_3.6.0.0-1_i386.deb 3.6.0.0 i386 Ubuntu Universe
python-billiard - - -

Requires

Name Value
libc6 >= 2.4
python << 2.8
python >= 2.7~
python:any << 2.8
python:any >= 2.7~

Download

Type URL
Mirror archive.ubuntu.com
Binary Package python-billiard_3.6.0.0-1_amd64.deb
Source Package billiard

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install python-billiard deb package:
    # sudo apt-get install python-billiard

Files

Path
/usr/lib/python2.7/dist-packages/_billiard.x86_64-linux-gnu.so
/usr/lib/python2.7/dist-packages/billiard/__init__.py
/usr/lib/python2.7/dist-packages/billiard/_ext.py
/usr/lib/python2.7/dist-packages/billiard/_win.py
/usr/lib/python2.7/dist-packages/billiard/common.py
/usr/lib/python2.7/dist-packages/billiard/compat.py
/usr/lib/python2.7/dist-packages/billiard/connection.py
/usr/lib/python2.7/dist-packages/billiard/context.py
/usr/lib/python2.7/dist-packages/billiard/einfo.py
/usr/lib/python2.7/dist-packages/billiard/exceptions.py
/usr/lib/python2.7/dist-packages/billiard/five.py
/usr/lib/python2.7/dist-packages/billiard/forkserver.py
/usr/lib/python2.7/dist-packages/billiard/heap.py
/usr/lib/python2.7/dist-packages/billiard/managers.py
/usr/lib/python2.7/dist-packages/billiard/pool.py
/usr/lib/python2.7/dist-packages/billiard/popen_fork.py
/usr/lib/python2.7/dist-packages/billiard/popen_forkserver.py
/usr/lib/python2.7/dist-packages/billiard/popen_spawn_posix.py
/usr/lib/python2.7/dist-packages/billiard/popen_spawn_win32.py
/usr/lib/python2.7/dist-packages/billiard/process.py
/usr/lib/python2.7/dist-packages/billiard/queues.py
/usr/lib/python2.7/dist-packages/billiard/reduction.py
/usr/lib/python2.7/dist-packages/billiard/resource_sharer.py
/usr/lib/python2.7/dist-packages/billiard/semaphore_tracker.py
/usr/lib/python2.7/dist-packages/billiard/sharedctypes.py
/usr/lib/python2.7/dist-packages/billiard/spawn.py
/usr/lib/python2.7/dist-packages/billiard/synchronize.py
/usr/lib/python2.7/dist-packages/billiard/util.py
/usr/lib/python2.7/dist-packages/billiard-3.6.0.0.egg-info/PKG-INFO
/usr/lib/python2.7/dist-packages/billiard-3.6.0.0.egg-info/dependency_links.txt
/usr/lib/python2.7/dist-packages/billiard-3.6.0.0.egg-info/not-zip-safe
/usr/lib/python2.7/dist-packages/billiard-3.6.0.0.egg-info/top_level.txt
/usr/lib/python2.7/dist-packages/billiard/dummy/__init__.py
/usr/lib/python2.7/dist-packages/billiard/dummy/connection.py
/usr/share/doc/python-billiard/README.rst
/usr/share/doc/python-billiard/changelog.Debian.gz
/usr/share/doc/python-billiard/copyright

Changelog

2019-02-10 - Michael Fladischer <fladi@debian.org>
billiard (3.6.0.0-1) unstable; urgency=low
* New upstream release.
* Refresh patches.
* Add python(3)-psutil to Build-Depends as it is used in tests.
* Bump Standards-Version to 4.3.0.
* Bump debhelper compatibility and version to 12.
* Add hardening maintainer flags to debian/rules.
2018-12-17 - Michael Fladischer <fladi@debian.org>
billiard (3.5.0.5-1) unstable; urgency=low
[ Ondřej Nový ]
* Use 'python3 -m sphinx' instead of sphinx-build for building docs
[ Michael Fladischer ]
* New upstream release.
* Disable PGP signature check in uscan as upstream is not providing a
signature for current releases.
* Clean up files in .pytest_cache/ to allow two builds in a row.
* Bump Standards-Version to 4.2.1.
2018-08-07 - Michael Fladischer <fladi@debian.org>
billiard (3.5.0.4-1) unstable; urgency=low
[ Thomas Bechtold ]
* Remove myself from Uploaders
[ Ondřej Nový ]
* d/control: Set Vcs-* to salsa.debian.org
* d/watch: Use https protocol
* d/control: Remove ancient X-Python-Version field
* d/control: Remove ancient X-Python3-Version field
[ Michael Fladischer ]
* New upstream release.
* Replace debian/upstream-signing-key.pgp with debian/upstream/signing-
key.asc.
* Bump debhelper compatibility and version to 11.
* Bump Standards-Version to 4.1.5.
* Install README.rst for python3-billiard package.
* Replace python(3)-nose with python(3)-pytest for tests during
package build.
* Add python(3)-case to Build-Depends to satisfy test requirements.
* Clean up .pytest_cache/v/cache/nodeids during builds.
* Build documentation in override_dh_sphinxdoc.
* Enable autopkgtest-pkg-python testsuite.
* Run wrap-and-sort -bast to reduce diff size of future changes.
2017-07-30 - Michael Fladischer <fladi@debian.org>
billiard (3.5.0.3-1) unstable; urgency=low
* New upstream release.
* Add new upstream signing key.
* Refresh patches for 3.5.0.3.
* Use https:// for copyright-format 1.0 URL.
* Update d/copyright.
2017-07-13 - Brian May <bam@debian.org>
billiard (3.5.0.2-1) unstable; urgency=medium
* New upstream version.
* Update standards version to 4.0.0.
2016-04-17 - Brian May <bam@debian.org>
billiard (3.3.0.23-2) unstable; urgency=medium
* Fix up git repository so that Debian release is in the Master branch.
* Fix Git-Vcs header.
2016-03-31 - Michael Fladischer <fladi@debian.org>
billiard (3.3.0.23-1) unstable; urgency=low
* New upstream release.
* Bump Standards-Version to 3.9.7.
* Use https in Vcs-Git field.
* Use python3-sphinx to build documentation.
2015-12-20 - Michael Fladischer <fladi@debian.org>
billiard (3.3.0.22-1) unstable; urgency=low
* New upstream release.
* Add a patch to fix a typo in multiprocessing.c.
2015-11-19 - Brian May <bam@debian.org>
billiard (3.3.0.21-1) unstable; urgency=medium
* New upstream version.
2015-11-06 - Brian May <bam@debian.org>
billiard (3.3.0.20-3) unstable; urgency=medium
* Clean up debian/rules.
* Ensure Python3 tests run.
* Fix FTBFS error. Closes: #804137.

See Also

Package Description
python-binaryornot_0.4.4+dfsg-2_all.deb check if a file is binary or text (Python 2 module)
python-binplist_0.1.5-2_all.deb binary property list parser module
python-bioblend-doc_0.7.0-2_all.deb CloudMan and Galaxy API library (common documentation)
python-bioblend_0.7.0-2_all.deb CloudMan and Galaxy API library (Python 2)
python-biom-format-doc_2.1.6+dfsg-2ubuntu2_all.deb documentation for BIOM format
python-biom-format_2.1.6+dfsg-2ubuntu2_amd64.deb Biological Observation Matrix (BIOM) format (Python 2)
python-biopython-doc_1.73+dfsg-1ubuntu1_all.deb Documentation for the Biopython library
python-biopython-sql_1.73+dfsg-1ubuntu1_all.deb Biopython support for the BioSQL database schema (Python 2)
python-biopython_1.73+dfsg-1ubuntu1_amd64.deb Python library for bioinformatics (implemented in Python 2)
python-biosig_1.9.3-2_amd64.deb Python bindings for BioSig library
python-biotools_1.2.12-3_all.deb Python bioinformatics utilities for high-throughput genomic sequencing
python-biplist_1.0.3-1_all.deb Python 2 library for reading/writing Mac OS X binary plists
python-bitarray_0.8.1-1build6_amd64.deb Python module for efficient boolean array handling
python-bitbucket_0.1-1_all.deb Python bindings for the bitbucket.org REST API
python-bitcoin_1.1.42-1_all.deb library for cryptocurrency transactions — Python 2
Advertisement
Advertisement