python-alsaaudio_0.8.4-1_amd64.deb


Advertisement

Description

python-alsaaudio - Alsa bindings for Python

Property Value
Distribution Ubuntu 19.04 (Disco Dingo)
Repository Ubuntu Universe amd64
Package filename python-alsaaudio_0.8.4-1_amd64.deb
Package name python-alsaaudio
Package version 0.8.4
Package release 1
Package architecture amd64
Package type deb
Category universe/sound
Homepage http://larsimmisch.github.io/pyalsaaudio/
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 64.14 KB
Installed size 320.00 KB
This package contains wrappers for accessing the ALSA API from Python.
Access to PCM devices and Mixer is supported. Access to MIDI sequencers
is not supported yet.
This package provides the alsaaudio module for Python 2.

Alternatives

Package Version Architecture Repository
python-alsaaudio_0.8.4-1_i386.deb 0.8.4 i386 Ubuntu Universe
python-alsaaudio - - -

Requires

Name Value
libasound2 >= 1.0.16
libc6 >= 2.4
python << 2.8
python >= 2.7~
python:any << 2.8
python:any >= 2.7~

Download

Type URL
Mirror archive.ubuntu.com
Binary Package python-alsaaudio_0.8.4-1_amd64.deb
Source Package pyalsaaudio

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install python-alsaaudio deb package:
    # sudo apt-get install python-alsaaudio

Files

Path
/usr/lib/python2.7/dist-packages/alsaaudio.x86_64-linux-gnu.so
/usr/lib/python2.7/dist-packages/pyalsaaudio-0.8.4.egg-info/PKG-INFO
/usr/lib/python2.7/dist-packages/pyalsaaudio-0.8.4.egg-info/dependency_links.txt
/usr/lib/python2.7/dist-packages/pyalsaaudio-0.8.4.egg-info/top_level.txt
/usr/share/doc/python-alsaaudio/TODO
/usr/share/doc/python-alsaaudio/changelog.Debian.gz
/usr/share/doc/python-alsaaudio/copyright
/usr/share/doc/python-alsaaudio/examples/mixertest.py
/usr/share/doc/python-alsaaudio/examples/playbacktest.py
/usr/share/doc/python-alsaaudio/examples/recordtest.py
/usr/share/doc/python-alsaaudio/html/.buildinfo
/usr/share/doc/python-alsaaudio/html/genindex.html
/usr/share/doc/python-alsaaudio/html/index.html
/usr/share/doc/python-alsaaudio/html/libalsaaudio.html
/usr/share/doc/python-alsaaudio/html/objects.inv
/usr/share/doc/python-alsaaudio/html/py-modindex.html
/usr/share/doc/python-alsaaudio/html/pyalsaaudio.html
/usr/share/doc/python-alsaaudio/html/search.html
/usr/share/doc/python-alsaaudio/html/searchindex.js
/usr/share/doc/python-alsaaudio/html/terminology.html
/usr/share/doc/python-alsaaudio/html/_sources/index.rst.txt
/usr/share/doc/python-alsaaudio/html/_sources/libalsaaudio.rst.txt
/usr/share/doc/python-alsaaudio/html/_sources/pyalsaaudio.rst.txt
/usr/share/doc/python-alsaaudio/html/_sources/terminology.rst.txt
/usr/share/doc/python-alsaaudio/html/_static/ajax-loader.gif
/usr/share/doc/python-alsaaudio/html/_static/basic.css
/usr/share/doc/python-alsaaudio/html/_static/classic.css
/usr/share/doc/python-alsaaudio/html/_static/comment-bright.png
/usr/share/doc/python-alsaaudio/html/_static/comment-close.png
/usr/share/doc/python-alsaaudio/html/_static/comment.png
/usr/share/doc/python-alsaaudio/html/_static/doctools.js
/usr/share/doc/python-alsaaudio/html/_static/documentation_options.js
/usr/share/doc/python-alsaaudio/html/_static/down-pressed.png
/usr/share/doc/python-alsaaudio/html/_static/down.png
/usr/share/doc/python-alsaaudio/html/_static/file.png
/usr/share/doc/python-alsaaudio/html/_static/jquery.js
/usr/share/doc/python-alsaaudio/html/_static/minus.png
/usr/share/doc/python-alsaaudio/html/_static/plus.png
/usr/share/doc/python-alsaaudio/html/_static/pygments.css
/usr/share/doc/python-alsaaudio/html/_static/searchtools.js
/usr/share/doc/python-alsaaudio/html/_static/sidebar.js
/usr/share/doc/python-alsaaudio/html/_static/underscore.js
/usr/share/doc/python-alsaaudio/html/_static/up-pressed.png
/usr/share/doc/python-alsaaudio/html/_static/up.png
/usr/share/doc/python-alsaaudio/html/_static/websupport.js

Changelog

2018-09-21 - Paul Brossier <piem@debian.org>
pyalsaaudio (0.8.4-1) unstable; urgency=medium
* New upstream version 0.8.4 (closes: #613091, #909226)
* debian/watch: use pypi.debian.net
* debian/changelog: remove trailing space
* debian/compat: bump to 10
* debian/control:
- add python3-alsaaubio binary
- depends on sphinx and debhelper 10
- add homepage, bump S-V to 4.2.1
- update long descriptions
* debian/rules:
- rewrite for modern debhelper
- run tests and build documentation
* debian/python*-alsaaudio.docs:
- moved from debian/docs
- README removed upstream
- add python3 docs
* debian/python*-alsaaudio.examples:
- renamed from examples
- remove test.py
* debian/patches/:
- playwav_py3.patch: fix playwav.py for python3
- mixertest_args.patch: update mixertest.py arguments
- update_doc_style.patch: use classic theme for docs
- fix_tests.py: fix all tests in user mode
- fix_tests.py: skip tests on alsa exception
- series: update list of patches
* debian/tests/: add minimal autopkgtest config
2013-12-29 - Paul Brossier <piem@debian.org>
pyalsaaudio (0.7-1) unstable; urgency=medium
* New upstream release
* Upgrade package to 3.0 (quilt)
2009-09-16 - Paul Brossier <piem@debian.org>
pyalsaaudio (0.5+svn36-1) unstable; urgency=low
* New upstream version with more patches in svn
* debian/control:
- remove rafl from maintainer field (closes: #523169)
- add Build-Depends on sphinx
- span Build-Depends on multiple lines
- change section to python, bump Standards-Version, fix typo on API
- add a recommends on libjs-jquery
* debian/rules:
- rebuild documentation using sphinx
- remove dh_python call
- make a link to packaged jquery.js
- do not compress javascript files
* debian/docs: install freshly generated documentation (closes: #408349)
* debian/watch: update to match new tarballs
2006-08-13 - Paul Brossier <piem@debian.org>
pyalsaaudio (0.2-1) unstable; urgency=low
* New upstream release
* Add a watch file
* Use debian/examples and debian/docs
* Merge changelog with ubuntu
* Add myself to uploaders field
* Upload to debian (closes: #382796)
2006-08-09 - Florian Ragwitz <rafl@debian.org>
pyalsaaudio (0.1-1) unstable; urgency=low
* Initial release.
2005-01-29 - Thom May <thom@ubuntu.com>
pyalsaaudio (0.1-1ubuntu1) hoary; urgency=low
* Upload to hoary with python2.4 support
2005-01-07 - Thom May <thom@debian.org>
pyalsaaudio (0.1-1) unstable; urgency=low
* First upload.

See Also

Package Description
python-altgraph-doc_0.16.1~repack0-1_all.deb Python graph (network) package - API documentation
python-altgraph_0.16.1~repack0-1_all.deb Python 2 graph (network) package
python-amqp_2.4.0-1_all.deb Low-level AMQP client
python-amqplib-doc_1.0.2-1_all.deb simple non-threaded Python AMQP client library (Documentation)
python-amqplib_1.0.2-1_all.deb simple non-threaded Python AMQP client library
python-angles_1.9.11-3_all.deb Robot OS set of simple math utilities to work with angles (Python 2)
python-aniso8601_4.1.0-1_all.deb python2 library for parsing dates and time
python-antlr3_3.5.2-1_all.deb ANother Tool for Language Recognition - Python 2.7 bindings
python-antlr_2.7.7+dfsg-9.2build2_all.deb language tool for constructing recognizers, compilers etc - Python 2.7
python-anyjson_0.3.3-1build1_all.deb Common interface for the best available JSON implementation
python-aodhclient_1.1.1-0ubuntu1_all.deb OpenStack Alarming as a Service - Python 2.7 client
python-apache-openid_2.0.1-0ubuntu4_all.deb OpenID consumer module for Apache
python-apipkg_1.5-2_all.deb namespace control and lazy-import mechanism for Python
python-apns-client_0.1.8-2_all.deb Python client for the Apple Push Notification service (APNS)
python-appdirs_1.4.3-1_all.deb determining appropriate platform-specific directories (Python 2)
Advertisement
Advertisement