pyqt5-dev-tools_5.12.1+dfsg-1_amd64.deb


Advertisement

Description

pyqt5-dev-tools - Development tools for PyQt5

Property Value
Distribution Ubuntu 19.04 (Disco Dingo)
Repository Ubuntu Universe amd64
Package filename pyqt5-dev-tools_5.12.1+dfsg-1_amd64.deb
Package name pyqt5-dev-tools
Package version 5.12.1+dfsg
Package release 1
Package architecture amd64
Package type deb
Category universe/python
Homepage https://riverbankcomputing.com/software/pyqt/intro
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 98.10 KB
Installed size 390.00 KB
This package contains various support tools for PyQt5 developers:
* a user interface compiler (pyuic5)
* a resource file generator (pyrcc5)
* a translation string finder (pylupdate5)

Alternatives

Package Version Architecture Repository
pyqt5-dev-tools_5.12.1+dfsg-1_i386.deb 5.12.1+dfsg i386 Ubuntu Universe
pyqt5-dev-tools - - -

Requires

Name Value
libc6 >= 2.14
libqt5core5a >= 5.12.2
libqt5xml5 >= 5.1.0
libstdc++6 >= 5
python3 << 3.8
python3 >= 3.7~
python3-pyqt5 = 5.12.1+dfsg-1
python3:any -

Download

Type URL
Mirror archive.ubuntu.com
Binary Package pyqt5-dev-tools_5.12.1+dfsg-1_amd64.deb
Source Package pyqt5

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install pyqt5-dev-tools deb package:
    # sudo apt-get install pyqt5-dev-tools

Files

Path
/usr/bin/pylupdate5
/usr/bin/pyrcc5
/usr/bin/pyuic5
/usr/lib/python3/dist-packages/PyQt5/pylupdate.cpython-37m-x86_64-linux-gnu.so
/usr/lib/python3/dist-packages/PyQt5/pylupdate_main.py
/usr/lib/python3/dist-packages/PyQt5/pyrcc.cpython-37m-x86_64-linux-gnu.so
/usr/lib/python3/dist-packages/PyQt5/pyrcc_main.py
/usr/share/doc/pyqt5-dev-tools/NEWS.gz
/usr/share/doc/pyqt5-dev-tools/changelog.Debian.gz
/usr/share/doc/pyqt5-dev-tools/copyright
/usr/share/man/man1/pylupdate5.1.gz
/usr/share/man/man1/pyrcc5.1.gz
/usr/share/man/man1/pyuic5.1.gz

Changelog

2019-03-27 - Dmitry Shachnev <mitya57@debian.org>
pyqt5 (5.12.1+dfsg-1) experimental; urgency=medium
* New upstream release.
* Update debian/watch for another upstream change.
2019-03-06 - Dmitry Shachnev <mitya57@debian.org>
pyqt5 (5.12+dfsg-1) experimental; urgency=medium
[ Bastian Germann ]
* Provide dist-info metadata (closes: #890200; LP: #1814019).
[ Scott Kitterman ]
* Remove myself from uploaders
[ Dmitry Shachnev ]
* Build the tools for all supported Python 3 versions.
* Bump Standards-Version to 4.3.0, no changes needed.
* Update debian/watch to use the new tarballs location.
* New upstream release.
* Refresh debian/patches/public_sip.diff.
* Drop Qt WebEngine packages, they are now in a separate source.
* Update debian/copyright.
* Bump sip build-dependencies to 4.19.14, following configure.py.
2018-10-12 - Dmitry Shachnev <mitya57@debian.org>
pyqt5 (5.11.3+dfsg-1) unstable; urgency=medium
[ Ondřej Nový ]
* d/watch: Use https protocol
[ Dmitry Shachnev ]
* New upstream release.
* Update public_sip.diff, revert some more upstream changes.
* Do not override default dh_builddeb parameters.
* Install both upstream changelog and NEWS, per Policy 12.7.
* Bump Standards-Version to 4.2.1, no changes needed.
2018-07-06 - Dmitry Shachnev <mitya57@debian.org>
pyqt5 (5.11.2+dfsg-1) unstable; urgency=medium
* New upstream release.
* Bump sip build-dependencies to 4.19.11, following configure.py.
* Drop cura_crash.diff, applied in the new release.
* Use the public version of sip module, per Policy § 4.13.
* Configure with --no-dist-info for now, mk_distinfo.py does not work
well with DESTDIR yet.
* Update debhelper compat level to 11.
* Bump Standards-Version to 4.1.5, no changes needed.
* Update Homepage field in debian/control.
2018-05-10 - Dmitry Shachnev <mitya57@debian.org>
pyqt5 (5.10.1+dfsg-2) unstable; urgency=medium
[ Ondřej Nový ]
* d/tests: Use AUTOPKGTEST_TMP instead of ADTTMP
[ Dmitry Shachnev ]
* Backport three upstream commits to fix crashes when running Cura
(closes: #898211).
* Drop ancient X-Python{,3}-Version fields.
2018-04-14 - Dmitry Shachnev <mitya57@debian.org>
pyqt5 (5.10.1+dfsg-1) unstable; urgency=medium
[ Dmitry Shachnev ]
* New upstream release.
* Preserve timestamps when copying jquery.min.js, to make pyrcc generate
the resource file reproducibly.
* Install sip files directly in the .install file, to fix race condition
when doing arch+indep build.
* Update debhelper compatibility level to 10.
* Use dh_missing instead of deprecated dh_install --fail-missing.
* Bump Standards-Version to 4.1.4, no changes needed.
* Bump copyright years in debian/copyright.
[ Scott Kitterman ]
* Fix mismatch python:Version substitution variable for
python-pyqt5.qtsensors and python-pyqt5.qtx11extras
[ Ondřej Nový ]
* d/control: Set Vcs-* to salsa.debian.org
* d/copyright: Use https protocol in Format field
2017-12-05 - Dmitry Shachnev <mitya57@debian.org>
pyqt5 (5.9.2+dfsg-1) unstable; urgency=medium
* New upstream release.
* Bump sip build-dependencies to 4.19.4, following configure.py.
* Update pyrcc5 manpage for -name option removal.
* Drop disabled_features.diff, applied upstream.
* Regenerate the resources with QT_HASH_SEED=0, for reproducibility.
* Bump Standards-Version to 4.1.2, no changes needed.
2017-09-23 - Dmitry Shachnev <mitya57@debian.org>
pyqt5 (5.9+dfsg-2) unstable; urgency=medium
* Backport upstream patch to fix handling of disabled features (fixes
build on architectures with OpenGL ES).
* Enable Qt WebEngine support on mipsel.
* Drop Breaks/Replaces on versions that are not even in oldstable.
* Bump Standards-Version to 4.1.0, stop using deprecated Priority: extra.
* Upload to unstable.

See Also

Package Description
pyqt5-dev_5.12.1+dfsg-1_all.deb Development files for PyQt5
pyqt5-examples_5.12.1+dfsg-1_all.deb Examples and demos for PyQt5
pyqt5.qsci-dev_2.10.4+dfsg-1build2_all.deb Development files for Python Qscintilla2 (Qt5)
pyqt5chart-dev_5.11.3+dfsg-1_all.deb Development files for PyQtCharts
pyracerz_0.2-8_all.deb multiplayer top view 2D racing game
pyragua_0.2.5-6_all.deb Very lightweight Python editor
pyrex-mode_0.9.9-1_all.deb emacs-lisp pyrex-mode for pyrex
pyrit-opencl_0.4.0-1build1_amd64.deb OpenCL extension module for Pyrit
pyrit_0.5.1+git20180801-1_amd64.deb GPGPU-driven WPA/WPA2-PSK key cracker
pyrite-publisher_2.1.1-11_amd64.deb Convert html and text documents to palm DOC format
pyro-doc_3.16-3_all.deb documentation for Pyro
pyro-examples_3.16-3_all.deb examples for Pyro
pyro-gui_3.16-3_all.deb graphical tool for Pyro
pyro4-doc_4.75-1_all.deb distributed object middleware for Python (RPC), documentation
pyro4-examples_4.75-1_all.deb distributed object middleware for Python (RPC), examples
Advertisement
Advertisement