pypy3_7.0.0+dfsg-3_amd64.deb


Advertisement

Description

pypy3 - fast alternative implementation of Python 3.x - PyPy interpreter

Property Value
Distribution Ubuntu 19.04 (Disco Dingo)
Repository Ubuntu Universe amd64
Package filename pypy3_7.0.0+dfsg-3_amd64.deb
Package name pypy3
Package version 7.0.0+dfsg
Package release 3
Package architecture amd64
Package type deb
Category universe/python
Homepage http://pypy.org/
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 8.75 MB
Installed size 59.54 MB
PyPy is a fast, compliant alternative implementation of the Python language
(3.x). It has several advantages and distinct features:
* Speed: thanks to its Just-in-Time compiler (on x86), Python programs often
run faster on PyPy.
* Memory usage: large, memory-hungry Python programs might end up taking less
space than they do in CPython.
* Compatibility: PyPy is highly compatible with existing Python code.
It supports ctypes and can run popular Python libraries like twisted and
django.
* Stackless: PyPy supports stackless mode on most platforms, providing
micro-threads for massive concurrency.
This package contains the PyPy interpreter for Python 3.x.

Alternatives

Package Version Architecture Repository
pypy3_7.0.0+dfsg-3_i386.deb 7.0.0+dfsg i386 Ubuntu Universe
pypy3 - - -

Requires

Name Value
dpkg >= 1.15.6~
libbz2-1.0 -
libc6 >= 2.28
libexpat1 >= 2.0.1
libffi6 >= 3.0.4
libgcc1 >= 1:4.2
libgdbm6 >= 1.16
liblzma5 >= 5.1.1alpha+20120614
libncurses6 >= 6
libncursesw6 >= 6
libsqlite3-0 >= 3.5.9
libssl1.1 >= 1.1.1
libtinfo6 >= 6
pypy3-lib = 7.0.0+dfsg-3
zlib1g >= 1:1.1.4

Provides

Name Value
pypy3-abi-70 -

Download

Type URL
Mirror archive.ubuntu.com
Binary Package pypy3_7.0.0+dfsg-3_amd64.deb
Source Package pypy3

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install pypy3 deb package:
    # sudo apt-get install pypy3

Files

Path
/usr/bin/pypy3
/usr/bin/pypy3clean
/usr/bin/pypy3compile
/usr/lib/libpypy3-c.so
/usr/lib/pypy3/bin/libpypy3-c.so
/usr/lib/pypy3/bin/pypy3-c
/usr/lib/pypy3/include/pypy_decl.h
/usr/lib/pypy3/include/pypy_macros.h
/usr/lib/pypy3/include/pypy_marshal_decl.h
/usr/lib/pypy3/include/pypy_structmember_decl.h
/usr/lib/pypy3/lib_pypy/_audioop_cffi.pypy3-70-x86_64-linux-gnu.so
/usr/lib/pypy3/lib_pypy/_curses_cffi.pypy3-70-x86_64-linux-gnu.so
/usr/lib/pypy3/lib_pypy/_curses_cffi_check.pypy3-70-x86_64-linux-gnu.so
/usr/lib/pypy3/lib_pypy/_decimal_cffi.pypy3-70-x86_64-linux-gnu.so
/usr/lib/pypy3/lib_pypy/_gdbm_cffi.pypy3-70-x86_64-linux-gnu.so
/usr/lib/pypy3/lib_pypy/_lzma_cffi.pypy3-70-x86_64-linux-gnu.so
/usr/lib/pypy3/lib_pypy/_pwdgrp_cffi.pypy3-70-x86_64-linux-gnu.so
/usr/lib/pypy3/lib_pypy/_pypy_openssl.pypy3-70-x86_64-linux-gnu.so
/usr/lib/pypy3/lib_pypy/_resource_cffi.pypy3-70-x86_64-linux-gnu.so
/usr/lib/pypy3/lib_pypy/_sqlite3_cffi.pypy3-70-x86_64-linux-gnu.so
/usr/lib/pypy3/lib_pypy/_syslog_cffi.pypy3-70-x86_64-linux-gnu.so
/usr/share/doc/pypy3/TODO.Debian
/usr/share/doc/pypy3/changelog.Debian.gz
/usr/share/doc/pypy3/copyright
/usr/share/lintian/overrides/pypy3
/usr/share/man/man1/pypy3.1.gz

Changelog

2019-02-20 - Stefano Rivera <stefanor@debian.org>
pypy3 (7.0.0+dfsg-3) unstable; urgency=medium
* Let pypy3 attempt to build on hurd. It has been previously ported.
* Fix webbrowser module. We had a patch that wasn't well ported to pypy3.
* Patch hurd-sysmacros: Include <sys/sysmacros.h> on GNU/Hurd.
* Remove old copyright file blocks for lib-python/2.7, it's no longer
included, upstream.
2019-02-08 - Stefano Rivera <stefanor@debian.org>
pypy3 (7.0.0+dfsg-2) unstable; urgency=medium
* Remove dh_builddeb override, no longer necessary.
* Bump Standards-Version to 4.3.0, no changes needed.
* Don't use dh_python3, it wasn't doing anything, anyway.
* Patches from upstream release branch:
- Set the version to 7.0.0, accidentally updated in a merge.
- hypothesis-crashes: Handle older hypothesis versions better.
2019-02-07 - Stefano Rivera <stefanor@debian.org>
pypy3 (7.0.0+dfsg-1) unstable; urgency=medium
* New upstream release.
* Refresh patches.
* Drop patches avoid-rvmprof-dummy, hurd, and rvmprof-dummy. Superseded
upstream.
* Update copyright.
* Clean up after the new "extra_tests" directory.
2019-02-06 - Stefano Rivera <stefanor@debian.org>
pypy3 (6.0.0+dfsg-3) unstable; urgency=medium
* Build-Depend on liblzma-dev, to build the lzma cffi module.
Thanks Helmut Grohne. (Closes: #921494)
* Bump Standards-Version to 4.3.0, no changes needed.
* Ignore lib_pypy/_testmultiphase.c in clean.
2019-01-31 - Stefano Rivera <stefanor@debian.org>
pypy3 (6.0.0+dfsg-2) unstable; urgency=medium
* Upload to unstable.
* Patch graphlib-dots: Print some more mandlebrot while breaking cycles, to
avoid build timeouts.
* Add some superficial autopkgtests.
* Support pip 10 in ensurepip.
* pypy3-lib-testsuite: Don't attempt to byte-compile lib2to3's test data.
2019-01-01 - Stefano Rivera <stefanor@debian.org>
pypy3 (6.0.0+dfsg-1) experimental; urgency=medium
* Initial release (based on pypy 6.0.0+dfsg-2 packaging). (Closes: #762346)

See Also

Package Description
pypy_7.0.0+dfsg-3_amd64.deb fast alternative implementation of Python - PyPy interpreter
pyqi_0.3.2+dfsg-3_all.deb Python framework for wrapping general commands in multiple interfaces
pyqso_1.1.0-1_all.deb logging tool for amateur radio operators
pyqt4-dev-tools_4.12.1+dfsg-2build2_amd64.deb Development tools for PyQt4
pyqt4.qsci-dev_2.10.4+dfsg-1build2_all.deb Development files for Python Qscintilla2 (Qt4)
pyqt5-dev-tools_5.12.1+dfsg-1_amd64.deb Development tools for PyQt5
pyqt5-dev_5.12.1+dfsg-1_all.deb Development files for PyQt5
pyqt5-examples_5.12.1+dfsg-1_all.deb Examples and demos for PyQt5
pyqt5.qsci-dev_2.10.4+dfsg-1build2_all.deb Development files for Python Qscintilla2 (Qt5)
pyqt5chart-dev_5.11.3+dfsg-1_all.deb Development files for PyQtCharts
pyracerz_0.2-8_all.deb multiplayer top view 2D racing game
pyragua_0.2.5-6_all.deb Very lightweight Python editor
pyrex-mode_0.9.9-1_all.deb emacs-lisp pyrex-mode for pyrex
pyrit-opencl_0.4.0-1build1_amd64.deb OpenCL extension module for Pyrit
pyrit_0.5.1+git20180801-1_amd64.deb GPGPU-driven WPA/WPA2-PSK key cracker
Advertisement
Advertisement