pypy-py_1.7.0-2_all.deb


Advertisement

Description

pypy-py - Advanced Python development support library (PyPy)

Property Value
Distribution Ubuntu 19.04 (Disco Dingo)
Repository Ubuntu Universe amd64
Package filename pypy-py_1.7.0-2_all.deb
Package name pypy-py
Package version 1.7.0
Package release 2
Package architecture all
Package type deb
Category universe/python
Homepage https://github.com/pytest-dev/py
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 63.92 KB
Installed size 337.00 KB
The Codespeak py lib aims at supporting a decent Python development process
addressing deployment, versioning and documentation perspectives. It includes:
* py.path: path abstractions over local and Subversion files
* py.code: dynamic code compile and traceback printing support
This package provides the PyPy 2 modules.

Alternatives

Package Version Architecture Repository
pypy-py_1.7.0-2_all.deb 1.7.0 all Ubuntu Universe
pypy-py - - -

Requires

Name Value
pypy -
pypy-pkg-resources -

Download

Type URL
Mirror archive.ubuntu.com
Binary Package pypy-py_1.7.0-2_all.deb
Source Package python-py

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install pypy-py deb package:
    # sudo apt-get install pypy-py

Files

Path
/usr/lib/pypy/dist-packages/py/__init__.py
/usr/lib/pypy/dist-packages/py/__metainfo.py
/usr/lib/pypy/dist-packages/py/_builtin.py
/usr/lib/pypy/dist-packages/py/_error.py
/usr/lib/pypy/dist-packages/py/_std.py
/usr/lib/pypy/dist-packages/py/_version.py
/usr/lib/pypy/dist-packages/py/_xmlgen.py
/usr/lib/pypy/dist-packages/py/test.py
/usr/lib/pypy/dist-packages/py-1.7.0.egg-info/PKG-INFO
/usr/lib/pypy/dist-packages/py-1.7.0.egg-info/dependency_links.txt
/usr/lib/pypy/dist-packages/py-1.7.0.egg-info/not-zip-safe
/usr/lib/pypy/dist-packages/py-1.7.0.egg-info/top_level.txt
/usr/lib/pypy/dist-packages/py/_code/__init__.py
/usr/lib/pypy/dist-packages/py/_code/_assertionnew.py
/usr/lib/pypy/dist-packages/py/_code/_assertionold.py
/usr/lib/pypy/dist-packages/py/_code/_py2traceback.py
/usr/lib/pypy/dist-packages/py/_code/assertion.py
/usr/lib/pypy/dist-packages/py/_code/code.py
/usr/lib/pypy/dist-packages/py/_code/source.py
/usr/lib/pypy/dist-packages/py/_io/__init__.py
/usr/lib/pypy/dist-packages/py/_io/capture.py
/usr/lib/pypy/dist-packages/py/_io/saferepr.py
/usr/lib/pypy/dist-packages/py/_io/terminalwriter.py
/usr/lib/pypy/dist-packages/py/_log/__init__.py
/usr/lib/pypy/dist-packages/py/_log/log.py
/usr/lib/pypy/dist-packages/py/_log/warning.py
/usr/lib/pypy/dist-packages/py/_path/__init__.py
/usr/lib/pypy/dist-packages/py/_path/cacheutil.py
/usr/lib/pypy/dist-packages/py/_path/common.py
/usr/lib/pypy/dist-packages/py/_path/local.py
/usr/lib/pypy/dist-packages/py/_path/svnurl.py
/usr/lib/pypy/dist-packages/py/_path/svnwc.py
/usr/lib/pypy/dist-packages/py/_process/__init__.py
/usr/lib/pypy/dist-packages/py/_process/cmdexec.py
/usr/lib/pypy/dist-packages/py/_process/forkedfunc.py
/usr/lib/pypy/dist-packages/py/_process/killproc.py
/usr/lib/pypy/dist-packages/py/_vendored_packages/__init__.py
/usr/lib/pypy/dist-packages/py/_vendored_packages/apipkg.py
/usr/lib/pypy/dist-packages/py/_vendored_packages/iniconfig.py
/usr/share/doc/pypy-py/changelog.Debian.gz
/usr/share/doc/pypy-py/copyright
/usr/share/doc/pypy-py/examples/genhtml.py
/usr/share/doc/pypy-py/examples/genhtmlcss.py
/usr/share/doc/pypy-py/examples/genxml.py

Changelog

2019-01-01 - Ondřej Nový <onovy@debian.org>
python-py (1.7.0-2) unstable; urgency=medium
* Use --ignore instead of -k- for ignoring tests (Closes: #915896)
* Bump standards version to 4.3.0 (no changes)
* Bump debhelper compat level to 12 and use debhelper-compat
2018-11-08 - Ondřej Nový <onovy@debian.org>
python-py (1.7.0-1) unstable; urgency=medium
* New upstream release
2018-08-31 - Ondřej Nový <onovy@debian.org>
python-py (1.6.0-1) unstable; urgency=medium
* New upstream release
* Convert git repository from git-dpm to gbp layout
* Bump standards version 4.2.1 (no changes)
* Add upstream metadata
2018-07-31 - Ondřej Nový <onovy@debian.org>
python-py (1.5.4-1) unstable; urgency=medium
* New upstream release
* d/control: Remove ancient X-Python3-Version field
* Bump Standards-Version to 4.1.5 (no changes needed)
* Add {pypy,python,python3}-setuptools-scm to B-D
2018-04-06 - Ondřej Nový <onovy@debian.org>
python-py (1.5.3-1) unstable; urgency=medium
* New upstream release
2018-02-26 - Ondřej Nový <onovy@debian.org>
python-py (1.5.2-1) unstable; urgency=medium
* New upstream release
* Move under DPMT, add me as uploaders (Closes: #873657)
* Bump debhelper compat level to 11
* d/copyright:
- Use https protocol in Format field
- Add myself for Debian part
* d/watch: Use https protocol
* d/control: Set Vcs-* to salsa.debian.org
* Set PYBUILD_NAME
* Remove d/gbp.conf: Not needed anymore
* Bump Standards-Version to 4.1.3
* Bump X-Python3-Version to 3.4
* Run tests during build
* Replace d/tests with autopkgtest-pkg-python testsuite
* Drop versioning of depends on python{,3}-all
* Install examples
2017-09-27 - Adrian Bunk <bunk@debian.org>
python-py (1.4.34-3) unstable; urgency=medium
* QA upload.
* Set maintainer to Debian QA Group. (see #873657)
* Add patch to fix autopkgtest failures.
2017-06-18 - Sebastian Ramacher <sramacher@debian.org>
python-py (1.4.34-2) unstable; urgency=medium
* Upload to unstable.
2017-06-12 - Sebastian Ramacher <sramacher@debian.org>
python-py (1.4.34-1) experimental; urgency=medium
* New upstream release.
2017-03-21 - Sebastian Ramacher <sramacher@debian.org>
python-py (1.4.33-1) experimental; urgency=medium
* New upstream release.
* debian/patches: Removed, included upstream.
* debian/tests: No longer remove byte code.

See Also

Package Description
pypy-pyaes_1.6.1-2_all.deb Pure-Python implementation of the AES cipher (PyPy)
pypy-pyasn1_0.4.2-3_all.deb ASN.1 library for Python (PyPy module)
pypy-pymediainfo_3.0-1_all.deb Library to fetch multimedia metadata information - PyPy version
pypy-pyparsing_2.2.0+dfsg1-2_all.deb alternative to creating and executing simple grammars - pypy
pypy-pytest_3.10.1-2_all.deb Simple, powerful testing in PyPy
pypy-rawkit_0.6.0-1_all.deb CTypes based LibRaw bindings - Python 2.X
pypy-rply_0.7.4-3_all.deb pure Python based parser that also works with RPython (PyPy)
pypy-scandir_1.9.0-2_amd64.deb Backport of the "scandir" stdlib module (PyPy)
pypy-schema_0.6.7-1_all.deb simple data validation library (PyPy)
pypy-setuptools-scm_3.2.0-1_all.deb blessed package to manage your versions by scm tags for PyPy
pypy-setuptools_40.8.0-1_all.deb PyPy Distutils Enhancements
pypy-simplejson_3.16.0-1_all.deb simple, fast, extensible JSON encoder/decoder for Python - PyPy
pypy-six_1.12.0-1_all.deb Python 2 and 3 compatibility library (PyPy interface)
pypy-soupsieve_1.8+dfsg-1_all.deb Modern CSS selector implementation for BeautifulSoup (PyPy)
pypy-sqlparse_0.2.4-1_all.deb non-validating SQL parser for PyPy
Advertisement
Advertisement