pypy-bs4_4.7.1-1build1_all.deb


Advertisement

Description

pypy-bs4 - error-tolerant HTML parser for PyPy

Property Value
Distribution Ubuntu 19.04 (Disco Dingo)
Repository Ubuntu Universe amd64
Package filename pypy-bs4_4.7.1-1build1_all.deb
Package name pypy-bs4
Package version 4.7.1
Package release 1build1
Package architecture all
Package type deb
Category universe/python
Homepage https://www.crummy.com/software/BeautifulSoup
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 70.36 KB
Installed size 383.00 KB
Beautiful Soup is a Python library for pulling data out of HTML and XML files.
It works with your favorite parser to provide idiomatic ways of navigating,
searching, and modifying the parse tree. It commonly saves programmers hours
or days of work.
This package contains BeautifulSoup 4, for Python 2.x PyPy.

Alternatives

Package Version Architecture Repository
pypy-bs4_4.7.1-1build1_all.deb 4.7.1 all Ubuntu Universe
pypy-bs4 - - -

Requires

Name Value
pypy -
pypy-soupsieve -

Download

Type URL
Mirror archive.ubuntu.com
Binary Package pypy-bs4_4.7.1-1build1_all.deb
Source Package beautifulsoup4

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install pypy-bs4 deb package:
    # sudo apt-get install pypy-bs4

Files

Path
/usr/lib/pypy/dist-packages/beautifulsoup4-4.7.1.egg-info/PKG-INFO
/usr/lib/pypy/dist-packages/beautifulsoup4-4.7.1.egg-info/dependency_links.txt
/usr/lib/pypy/dist-packages/beautifulsoup4-4.7.1.egg-info/requires.txt
/usr/lib/pypy/dist-packages/beautifulsoup4-4.7.1.egg-info/top_level.txt
/usr/lib/pypy/dist-packages/bs4/__init__.py
/usr/lib/pypy/dist-packages/bs4/dammit.py
/usr/lib/pypy/dist-packages/bs4/diagnose.py
/usr/lib/pypy/dist-packages/bs4/element.py
/usr/lib/pypy/dist-packages/bs4/testing.py
/usr/lib/pypy/dist-packages/bs4/builder/__init__.py
/usr/lib/pypy/dist-packages/bs4/builder/_html5lib.py
/usr/lib/pypy/dist-packages/bs4/builder/_htmlparser.py
/usr/lib/pypy/dist-packages/bs4/builder/_lxml.py
/usr/lib/pypy/dist-packages/bs4/tests/__init__.py
/usr/lib/pypy/dist-packages/bs4/tests/test_builder_registry.py
/usr/lib/pypy/dist-packages/bs4/tests/test_docs.py
/usr/lib/pypy/dist-packages/bs4/tests/test_html5lib.py
/usr/lib/pypy/dist-packages/bs4/tests/test_htmlparser.py
/usr/lib/pypy/dist-packages/bs4/tests/test_lxml.py
/usr/lib/pypy/dist-packages/bs4/tests/test_soup.py
/usr/lib/pypy/dist-packages/bs4/tests/test_tree.py
/usr/share/doc/pypy-bs4/changelog.Debian.gz
/usr/share/doc/pypy-bs4/copyright

Changelog

2019-02-03 - Stefano Rivera <stefanor@ubuntu.com>
beautifulsoup4 (4.7.1-1build1) disco; urgency=medium
* Re-build against a bootstrapped soupsieve.
2019-02-02 - Stefano Rivera <stefanor@debian.org>
beautifulsoup4 (4.7.1-1) unstable; urgency=medium
* New upstream release.
* Now depends on {python,python3,pypy}-soupsieve.
- Tag test dependencies <!nocheck>, to keep the stack bootstrappable.
* Bump copyright years.
* Test with html5lib, where possible.
2018-12-30 - Stefano Rivera <stefanor@debian.org>
beautifulsoup4 (4.6.3-2) unstable; urgency=medium
[ Ondřej Nový ]
* Use 'python3 -m sphinx' instead of sphinx-build for building docs
[ Stefano Rivera ]
* Use pybuild's --name feature to place files in the right binary package.
* Bump Standards-Version to 4.3.0, no changes needed.
* Bump debhelper compat to 11.
2018-08-21 - Stefano Rivera <stefanor@debian.org>
beautifulsoup4 (4.6.3-1) unstable; urgency=medium
* New upstream release.
* Bump copyright years.
* Upstream renamed the README.
2018-08-09 - Stefano Rivera <stefanor@debian.org>
beautifulsoup4 (4.6.1-1) unstable; urgency=medium
[ Stefano Rivera ]
* New upstream release.
* Declare Rules-Requires-Root: no.
* Bump Standards-Version to 4.2.0, no changes needed.
* Bump debhelper compat level to 10.
* Build Sphinx docs with Python 3.
* Patch: Avoid 2to3 differences between Python 3.6 and 3.7.
[ Ondřej Nový ]
* d/control: Set Vcs-* to salsa.debian.org
* d/copyright: Use https protocol in Format field
* d/tests: Use AUTOPKGTEST_TMP instead of ADTTMP
* d/control: Remove ancient X-Python-Version field
* Convert git repository from git-dpm to gbp layout
2017-06-22 - Stefano Rivera <stefanor@debian.org>
beautifulsoup4 (4.6.0-1) unstable; urgency=medium
* New upstream release.
* Bump Standards_version to 4.0.0, no changes needed.
2017-01-08 - Stefano Rivera <stefanor@debian.org>
beautifulsoup4 (4.5.3-1) unstable; urgency=medium
* New upstream release.
* Bump copyright years.
2016-08-08 - Stefano Rivera <stefanor@debian.org>
beautifulsoup4 (4.5.1-1) unstable; urgency=medium
* New upstream release.
* Switch upstream URLs to https.
2016-07-25 - Stefano Rivera <stefanor@debian.org>
beautifulsoup4 (4.5.0-1) unstable; urgency=medium
[ Stefano Rivera ]
* New upstream release.
* Bump copyright years.
* Upstream dropped Python 2.6 support.
* Bump Standards-Version to 3.9.8, no changes needed.
* Bump debhelper compat level to 9.
[ Ondřej Nový ]
* Fixed VCS URL (https)
2015-10-21 - Stefano Rivera <stefanor@debian.org>
beautifulsoup4 (4.4.1-1) unstable; urgency=medium
* New upstream release.

See Also

Package Description
pypy-confget_2.2.0-3_all.deb read variables from INI-style configuration files - PyPy library
pypy-coverage_4.5.2+dfsg.1-1_all.deb code coverage tool for Python 2 PyPy
pypy-dev_7.0.0+dfsg-3_all.deb header files for PyPy (an alternative Python interpreter)
pypy-doc_7.0.0+dfsg-3_all.deb developer Documentation for PyPy (an alternative Python interpreter)
pypy-dulwich_0.19.11-2_amd64.deb Python Git library - pypy module
pypy-enum34_1.1.6-2_all.deb backport of Python 3.4's enum package (PyPy package)
pypy-fastimport_0.9.8-2_all.deb Fastimport file format parser and generator library
pypy-feature-check_0.2.2-2_all.deb query a program for supported features - PyPy library
pypy-flaky_3.3.0-1_all.deb Plugin for nose or py.test that automatically reruns flaky tests (PyPy)
pypy-funcsigs_1.0.2-4_all.deb function signatures from PEP362 - PyPy
pypy-genty_1.3.0-1_all.deb Allows you to run a test with multiple data sets (PyPy)
pypy-hypothesis_3.71.11-1_all.deb advanced Quickcheck style testing library for PyPy
pypy-idna_2.6-1_all.deb Python IDNA2008 (RFC 5891) handling (PyPy)
pypy-ipaddress_1.0.17-1_all.deb Backport of Python 3 ipaddress module (PyPy)
pypy-iso8601_0.1.11-1_all.deb Python module to parse ISO 8601 dates - PyPy
Advertisement
Advertisement