pypy-attr_18.2.0-1_all.deb


Advertisement

Description

pypy-attr - Attributes without boilerplate (PyPy)

Property Value
Distribution Ubuntu 19.04 (Disco Dingo)
Repository Ubuntu Universe amd64
Package filename pypy-attr_18.2.0-1_all.deb
Package name pypy-attr
Package version 18.2.0
Package release 1
Package architecture all
Package type deb
Category universe/python
Homepage https://attrs.readthedocs.org/
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 28.97 KB
Installed size 141.00 KB
attrs is an MIT-licensed Python package with class decorators that ease the
chores of implementing the most common attribute-related object protocols.
You just specify the attributes to work with and attrs gives you:
- a nice human-readable __repr__,
- a complete set of comparison methods,
- an initializer,
- and much more
without writing dull boilerplate code again and again.
This package contains attrs packged for PyPy.

Alternatives

Package Version Architecture Repository
pypy-attr_18.2.0-1_all.deb 18.2.0 all Ubuntu Universe
pypy-attr - - -

Requires

Name Value
pypy -

Download

Type URL
Mirror archive.ubuntu.com
Binary Package pypy-attr_18.2.0-1_all.deb
Source Package python-attrs

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install pypy-attr deb package:
    # sudo apt-get install pypy-attr

Files

Path
/usr/lib/pypy/dist-packages/attr/__init__.py
/usr/lib/pypy/dist-packages/attr/__init__.pyi
/usr/lib/pypy/dist-packages/attr/_compat.py
/usr/lib/pypy/dist-packages/attr/_config.py
/usr/lib/pypy/dist-packages/attr/_funcs.py
/usr/lib/pypy/dist-packages/attr/_make.py
/usr/lib/pypy/dist-packages/attr/converters.py
/usr/lib/pypy/dist-packages/attr/converters.pyi
/usr/lib/pypy/dist-packages/attr/exceptions.py
/usr/lib/pypy/dist-packages/attr/exceptions.pyi
/usr/lib/pypy/dist-packages/attr/filters.py
/usr/lib/pypy/dist-packages/attr/filters.pyi
/usr/lib/pypy/dist-packages/attr/py.typed
/usr/lib/pypy/dist-packages/attr/validators.py
/usr/lib/pypy/dist-packages/attr/validators.pyi
/usr/lib/pypy/dist-packages/attrs-18.2.0.egg-info/PKG-INFO
/usr/lib/pypy/dist-packages/attrs-18.2.0.egg-info/dependency_links.txt
/usr/lib/pypy/dist-packages/attrs-18.2.0.egg-info/not-zip-safe
/usr/lib/pypy/dist-packages/attrs-18.2.0.egg-info/requires.txt
/usr/lib/pypy/dist-packages/attrs-18.2.0.egg-info/top_level.txt
/usr/share/doc/pypy-attr/changelog.Debian.gz
/usr/share/doc/pypy-attr/copyright

Changelog

2018-10-10 - Salvo 'LtWorf' Tomaselli <tiposchi@tiscali.it>
python-attrs (18.2.0-1) unstable; urgency=medium
* Team upload.
* New upstream release (Closes: #901013)
* Mark python-attr-doc Multi-Arch: foreign
* After this rebuild the changelog is fully present (Closes: #897408)
* Bump Standards-Version to 4.1.3
* set Rules-Requires-Root to no
[ Ondřej Nový ]
* d/tests: Use AUTOPKGTEST_TMP instead of ADTTMP
* Convert git repository from git-dpm to gbp layout
* Use 'python3 -m sphinx' instead of sphinx-build for building docs
2018-03-14 - Piotr Ożarowski <piotr@debian.org>
python-attrs (17.4.0-2) unstable; urgency=medium
[ Ondřej Nový ]
* d/control: Set Vcs-* to salsa.debian.org
[ Piotr Ożarowski ]
* use pybuild --print build_dir istead of patching docs/conf.py
(requires dh-python >= 3.20180313)
* do not ship conftest.py (used only during tests)
2018-01-23 - Tristan Seligmann <mithrandi@debian.org>
python-attrs (17.4.0-1) unstable; urgency=medium
* New upstream release (closes: #887508).
* Use https for copyright format.
* Bump debhelper compat level to 11.
* Bump Standards-Version to 4.1.3 (no changes).
* Replace extra priority with optional.
2017-06-30 - Tristan Seligmann <mithrandi@debian.org>
python-attrs (17.2.0-1) unstable; urgency=medium
* New upstream release.
- Add build-dependency on six.
- Link to local copy of attrs logo from changelog.
* Use a more reliable method for adding the build path to sys.path for
autodoc.
* Bump Standards-Version to 4.0.0 (no changes).
* Update repository location in debian/watch.
* Add DEP-8 tests.
2016-12-12 - Tristan Seligmann <mithrandi@debian.org>
python-attrs (16.3.0-1) unstable; urgency=medium
* New upstream release.
2016-10-10 - Tristan Seligmann <mithrandi@debian.org>
python-attrs (16.2.0-1) unstable; urgency=medium
* New upstream release.
- Doc build is now reproducible (closes: #833886).
* Fix API documentation build, and use the local copy of the Python
documentation (closes: #834639).
2016-06-23 - Tristan Seligmann <mithrandi@debian.org>
python-attrs (16.0.0-1) unstable; urgency=medium
* New upstream release.
* Install doc-base entry.
2016-04-27 - Tristan Seligmann <mithrandi@debian.org>
python-attrs (15.2.0-2) unstable; urgency=medium
* Fix debian/watch.
* Add python-attr-doc to Suggests: (closes: #816577).
* Bump Standards-Version to 3.9.8 (no changes).
2016-02-21 - Tristan Seligmann <mithrandi@debian.org>
python-attrs (15.2.0-1) unstable; urgency=low
* Initial upload (closes: #815387).

See Also

Package Description
pypy-backports.functools-lru-cache_1.5-3_all.deb backport of functools.lru_cache from Python 3.3 to PyPy
pypy-bdist-nsi_0.1.5-1_all.deb Create NSIS windows installers for Python modules (PyPy)
pypy-bs4_4.7.1-1build1_all.deb error-tolerant HTML parser for PyPy
pypy-confget_2.2.0-3_all.deb read variables from INI-style configuration files - PyPy library
pypy-coverage_4.5.2+dfsg.1-1_all.deb code coverage tool for Python 2 PyPy
pypy-dev_7.0.0+dfsg-3_all.deb header files for PyPy (an alternative Python interpreter)
pypy-doc_7.0.0+dfsg-3_all.deb developer Documentation for PyPy (an alternative Python interpreter)
pypy-dulwich_0.19.11-2_amd64.deb Python Git library - pypy module
pypy-enum34_1.1.6-2_all.deb backport of Python 3.4's enum package (PyPy package)
pypy-fastimport_0.9.8-2_all.deb Fastimport file format parser and generator library
pypy-feature-check_0.2.2-2_all.deb query a program for supported features - PyPy library
pypy-flaky_3.3.0-1_all.deb Plugin for nose or py.test that automatically reruns flaky tests (PyPy)
pypy-funcsigs_1.0.2-4_all.deb function signatures from PEP362 - PyPy
pypy-genty_1.3.0-1_all.deb Allows you to run a test with multiple data sets (PyPy)
pypy-hypothesis_3.71.11-1_all.deb advanced Quickcheck style testing library for PyPy
Advertisement
Advertisement