pypy-argon2_18.3.0-1_amd64.deb


Advertisement

Description

pypy-argon2 - Argon2 password hashing library - PyPy Module

Property Value
Distribution Ubuntu 19.04 (Disco Dingo)
Repository Ubuntu Universe amd64
Package filename pypy-argon2_18.3.0-1_amd64.deb
Package name pypy-argon2
Package version 18.3.0
Package release 1
Package architecture amd64
Package type deb
Category universe/python
Homepage https://argon2-cffi.readthedocs.io/
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 25.38 KB
Installed size 118.00 KB
Argon2 is a password-hashing function that can be used to hash passwords
for credential storage, key derivation, or other applications.
There are two main versions of Argon2: Argon2i and Argon2d.
Argon2i is the safest against side-channel attacks, while Argon2d provides
the highest resistance against GPU cracking attacks.
Argon2i and Argon2d are parametrized by:
* A time cost, which defines the amount of computation realized and
therefore the execution time, given in number of iterations
* A memory cost, which defines the memory usage, given in kibibytes
* A parallelism degree, which defines the number of parallel threads
This module provides argon2 hashing primitives for the PyPy programming
language.

Alternatives

Package Version Architecture Repository
pypy-argon2_18.3.0-1_i386.deb 18.3.0 i386 Ubuntu Universe
pypy-argon2 - - -

Requires

Name Value
libargon2-1 >= 0~20171227
pypy -
pypy-abi-41 -
pypy-cffi-backend-api-max >= 10241
pypy-cffi-backend-api-min <= 10241
pypy-enum34 -
pypy-six -

Download

Type URL
Mirror archive.ubuntu.com
Binary Package pypy-argon2_18.3.0-1_amd64.deb
Source Package python-argon2

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install pypy-argon2 deb package:
    # sudo apt-get install pypy-argon2

Files

Path
/usr/lib/pypy/dist-packages/argon2/__init__.py
/usr/lib/pypy/dist-packages/argon2/__main__.py
/usr/lib/pypy/dist-packages/argon2/_ffi.pypy-41-x86_64-linux-gnu.so
/usr/lib/pypy/dist-packages/argon2/_ffi_build.py
/usr/lib/pypy/dist-packages/argon2/_legacy.py
/usr/lib/pypy/dist-packages/argon2/_password_hasher.py
/usr/lib/pypy/dist-packages/argon2/_utils.py
/usr/lib/pypy/dist-packages/argon2/exceptions.py
/usr/lib/pypy/dist-packages/argon2/low_level.py
/usr/lib/pypy/dist-packages/argon2_cffi-18.3.0.egg-info/PKG-INFO
/usr/lib/pypy/dist-packages/argon2_cffi-18.3.0.egg-info/dependency_links.txt
/usr/lib/pypy/dist-packages/argon2_cffi-18.3.0.egg-info/not-zip-safe
/usr/lib/pypy/dist-packages/argon2_cffi-18.3.0.egg-info/requires.txt
/usr/lib/pypy/dist-packages/argon2_cffi-18.3.0.egg-info/top_level.txt
/usr/share/doc/pypy-argon2/changelog.Debian.gz
/usr/share/doc/pypy-argon2/copyright

Changelog

2018-11-07 - Nicolas Dandrimont <olasd@debian.org>
python-argon2 (18.3.0-1) unstable; urgency=medium
* New upstream release 18.3.0
* Stop exporting HYPOTHESIS_DATABASE_FILE, now handled by pybuild
* Don't install cffi bindings in multiple python3 versioned dirs
* Review debian/copyright for missing attributions (Closes: #909512)
* Update Standards-Version to 4.2.1 (no further changes)
* Set Rules-Requires-Root: no
* Set Vcs-Git to a redirect-less URI
2018-04-18 - Nicolas Dandrimont <olasd@debian.org>
python-argon2 (18.1.0-1) unstable; urgency=medium
* Initial release (Closes: #864156).
- Provide the python-argon2 binary package to allow usage of the
algorithm by existing Python2 packages such as python-passlib.

See Also

Package Description
pypy-asn1crypto_0.24.0-1_all.deb Fast ASN.1 parser and serializer (PyPy)
pypy-atomicwrites_1.1.5-2_all.deb Atomic file writes - PyPy
pypy-attr_18.2.0-1_all.deb Attributes without boilerplate (PyPy)
pypy-backports.functools-lru-cache_1.5-3_all.deb backport of functools.lru_cache from Python 3.3 to PyPy
pypy-bdist-nsi_0.1.5-1_all.deb Create NSIS windows installers for Python modules (PyPy)
pypy-bs4_4.7.1-1build1_all.deb error-tolerant HTML parser for PyPy
pypy-confget_2.2.0-3_all.deb read variables from INI-style configuration files - PyPy library
pypy-coverage_4.5.2+dfsg.1-1_all.deb code coverage tool for Python 2 PyPy
pypy-dev_7.0.0+dfsg-3_all.deb header files for PyPy (an alternative Python interpreter)
pypy-doc_7.0.0+dfsg-3_all.deb developer Documentation for PyPy (an alternative Python interpreter)
pypy-dulwich_0.19.11-2_amd64.deb Python Git library - pypy module
pypy-enum34_1.1.6-2_all.deb backport of Python 3.4's enum package (PyPy package)
pypy-fastimport_0.9.8-2_all.deb Fastimport file format parser and generator library
pypy-feature-check_0.2.2-2_all.deb query a program for supported features - PyPy library
pypy-flaky_3.3.0-1_all.deb Plugin for nose or py.test that automatically reruns flaky tests (PyPy)
Advertisement
Advertisement