psi4_1.2.1-2_amd64.deb


Advertisement

Description

psi4 - Quantum Chemical Program Suite

Property Value
Distribution Ubuntu 19.04 (Disco Dingo)
Repository Ubuntu Universe amd64
Package filename psi4_1.2.1-2_amd64.deb
Package name psi4
Package version 1.2.1
Package release 2
Package architecture amd64
Package type deb
Category universe/science
Homepage http://www.psicode.org/
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 6.60 MB
Installed size 26.67 MB
PSI4 is an ab-initio quantum chemistry program.  It is especially designed to
accurately compute properties of small to medium molecules using highly
correlated techniques. PSI4 is the parallelized successor of PSI3 and includes
many state-of-the-art theoretical methods.
It can compute energies, gradients and hessians for the following methods:
* Restricted Hartree-Fock (RHF)
It can compute energies and gradients for the following methods:
* Restricted, unrestricted and general restricted open shell Hartree-Fock
(RHF/ROHF)
* Restricted, unrestricted and general restricted open shell
Densitry-Functional Theory, including density-fitting (DF-DFT)
* Density Cumulant Functional Theory (DCFT)
* Density-fitted Moeller-Plesset perturbation theory (DF-MP2)
* Density-fitted Orbital-Optimized MP2 theory (DF-OMP2)
* (Orbital-Optimized) MP3 theory (OMP3/MP3)
* Coupled-cluster singles doubles (CCSD)
* Density-fitted coupled-cluster singles doubles (DF-CCSD) and with
perturbative triples (DF-CCSD(T))
* Second-order approximate coupled-cluster singles doubles (CC2)
* Equation-of-motion coupled-cluster singles doubles (EOM-CCSD)
Additionally, it can compute energies for the following methods:
* Spin-component scaled MP2 theory (SCS-MP2)
* Fourth order Moeller-Plesset perturbation theory (MP4)
* Density-fitted symmetry-adapted perturbation theory (DF-SAPT)
* Density-fitted complete active space SCF (DF-CASSCF)
* Configuration-interaction singles doubles (CISD)
* Full configuration-interaction (FCI)
* Closed-shell Density-fitted coupled-cluster singles doubles (DF-CCSD)
* Closed-shell Density-fitted Coupled-cluster singles doubles with
perturbative triples (DF-CCSD(T))
* Second/third-order approximate coupled-cluster singles doubles (CC2/CC3)
* Mukherjee Multireference coupled-cluster singles doubles theory (mk-MRCCSD)
* Mukherjee Multireference coupled-cluster singles doubles with perturbative
triples theory (mk-MRCCSD(T))
* Second order algebraic-diagrammatic construction theory (ADC(2))
* Quadratic configuration interaction singles doubles (QCISD)
* Quadratic configuration interaction singles doubles with perturbative
triples (QCISD(T))
* Density Matrix Renormalization Group SCF (DMRG-SCF), CASPT2 (DMRG-CASPT2)
and CI (DMRG-CI)
Further features include:
* Flexible, modular and customizable input format via python
* Excited state calculations with the EOM-CC2/CC3, EOM-CCSD, ADC(2), MRCI and
mk-MRCC methods
* Utilization of molecular point-group symmetry to increase efficiency
* Internal coordinate geometry optimizer
* Harmonic frequencies calculations (via finite differences)
* Potential surface scans
* Counterpoise correction
* One-electron properties like dipole/quadrupole moments, transition dipole
moments, natural orbitals occupations or electrostatic potential
* Composite methods like complete basis set extrapolation or G2/G3
* Scalar-relativistic corrections via two-component approach (X2C)

Alternatives

Package Version Architecture Repository
psi4_1.2.1-2_i386.deb 1.2.1 i386 Ubuntu Universe
psi4 - - -

Requires

Name Value
libblas.so.3 -
libblas3 -
libc6 >= 2.14
libchemps2-3 >= 1.8.7
libgcc1 >= 1:3.0
libgg1 -
libgomp1 >= 4.9
libint1 -
liblapack.so.3 -
liblapack3 -
libstdc++6 >= 6
libxc5 >= 3.0.0
psi4-data = 1:1.2.1-2
python3-deepdiff -
python3-networkx -
python3-numpy -
python3-pybind11 -
python3:any -

Download

Type URL
Mirror archive.ubuntu.com
Binary Package psi4_1.2.1-2_amd64.deb
Source Package psi4

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install psi4 deb package:
    # sudo apt-get install psi4

Files

Path
/usr/bin/psi4
/usr/lib/x86_64-linux-gnu/psi4/__init__.py
/usr/lib/x86_64-linux-gnu/psi4/core.so
/usr/lib/x86_64-linux-gnu/psi4/extras.py
/usr/lib/x86_64-linux-gnu/psi4/header.py
/usr/lib/x86_64-linux-gnu/psi4/metadata.py
/usr/lib/x86_64-linux-gnu/psi4/driver/__init__.py
/usr/lib/x86_64-linux-gnu/psi4/driver/aliases.py
/usr/lib/x86_64-linux-gnu/psi4/driver/dependency_check.py
/usr/lib/x86_64-linux-gnu/psi4/driver/diatomic.py
/usr/lib/x86_64-linux-gnu/psi4/driver/driver.py
/usr/lib/x86_64-linux-gnu/psi4/driver/driver_cbs.py
/usr/lib/x86_64-linux-gnu/psi4/driver/driver_nbody.py
/usr/lib/x86_64-linux-gnu/psi4/driver/driver_util.py
/usr/lib/x86_64-linux-gnu/psi4/driver/endorsed_plugins.py
/usr/lib/x86_64-linux-gnu/psi4/driver/frac.py
/usr/lib/x86_64-linux-gnu/psi4/driver/gaussian_n.py
/usr/lib/x86_64-linux-gnu/psi4/driver/inputparser.py
/usr/lib/x86_64-linux-gnu/psi4/driver/json_wrapper.py
/usr/lib/x86_64-linux-gnu/psi4/driver/molutil.py
/usr/lib/x86_64-linux-gnu/psi4/driver/plugin.py
/usr/lib/x86_64-linux-gnu/psi4/driver/qmmm.py
/usr/lib/x86_64-linux-gnu/psi4/driver/wrapper_autofrag.py
/usr/lib/x86_64-linux-gnu/psi4/driver/wrapper_database.py
/usr/lib/x86_64-linux-gnu/psi4/driver/constants/__init__.py
/usr/lib/x86_64-linux-gnu/psi4/driver/constants/physconst.py
/usr/lib/x86_64-linux-gnu/psi4/driver/constants/psifiles.py
/usr/lib/x86_64-linux-gnu/psi4/driver/p4util/__init__.py
/usr/lib/x86_64-linux-gnu/psi4/driver/p4util/exceptions.py
/usr/lib/x86_64-linux-gnu/psi4/driver/p4util/fcidump.py
/usr/lib/x86_64-linux-gnu/psi4/driver/p4util/inpsight.py
/usr/lib/x86_64-linux-gnu/psi4/driver/p4util/numpy_helper.py
/usr/lib/x86_64-linux-gnu/psi4/driver/p4util/optproc.py
/usr/lib/x86_64-linux-gnu/psi4/driver/p4util/p4regex.py
/usr/lib/x86_64-linux-gnu/psi4/driver/p4util/procutil.py
/usr/lib/x86_64-linux-gnu/psi4/driver/p4util/python_helpers.py
/usr/lib/x86_64-linux-gnu/psi4/driver/p4util/solvers.py
/usr/lib/x86_64-linux-gnu/psi4/driver/p4util/text.py
/usr/lib/x86_64-linux-gnu/psi4/driver/p4util/util.py
/usr/lib/x86_64-linux-gnu/psi4/driver/procrouting/__init__.py
/usr/lib/x86_64-linux-gnu/psi4/driver/procrouting/empirical_dispersion.py
/usr/lib/x86_64-linux-gnu/psi4/driver/procrouting/interface_cfour.py
/usr/lib/x86_64-linux-gnu/psi4/driver/procrouting/proc.py
/usr/lib/x86_64-linux-gnu/psi4/driver/procrouting/proc_table.py
/usr/lib/x86_64-linux-gnu/psi4/driver/procrouting/proc_util.py
/usr/lib/x86_64-linux-gnu/psi4/driver/procrouting/roa.py
/usr/lib/x86_64-linux-gnu/psi4/driver/procrouting/wrappers_cfour.py
/usr/lib/x86_64-linux-gnu/psi4/driver/procrouting/dft_funcs/__init__.py
/usr/lib/x86_64-linux-gnu/psi4/driver/procrouting/dft_funcs/dict_builder.py
/usr/lib/x86_64-linux-gnu/psi4/driver/procrouting/dft_funcs/dict_dh_funcs.py
/usr/lib/x86_64-linux-gnu/psi4/driver/procrouting/dft_funcs/dict_gga_funcs.py
/usr/lib/x86_64-linux-gnu/psi4/driver/procrouting/dft_funcs/dict_hyb_funcs.py
/usr/lib/x86_64-linux-gnu/psi4/driver/procrouting/dft_funcs/dict_lda_funcs.py
/usr/lib/x86_64-linux-gnu/psi4/driver/procrouting/dft_funcs/dict_mgga_funcs.py
/usr/lib/x86_64-linux-gnu/psi4/driver/procrouting/dft_funcs/dict_xc_funcs.py
/usr/lib/x86_64-linux-gnu/psi4/driver/procrouting/dft_funcs/superfuncs.py
/usr/lib/x86_64-linux-gnu/psi4/driver/procrouting/findif_response_utils/__init__.py
/usr/lib/x86_64-linux-gnu/psi4/driver/procrouting/findif_response_utils/data_collection_helper.py
/usr/lib/x86_64-linux-gnu/psi4/driver/procrouting/findif_response_utils/db_helper.py
/usr/lib/x86_64-linux-gnu/psi4/driver/procrouting/mcscf/__init__.py
/usr/lib/x86_64-linux-gnu/psi4/driver/procrouting/mcscf/augmented_hessian.py
/usr/lib/x86_64-linux-gnu/psi4/driver/procrouting/mcscf/mcscf_solver.py
/usr/lib/x86_64-linux-gnu/psi4/driver/procrouting/response/__init__.py
/usr/lib/x86_64-linux-gnu/psi4/driver/procrouting/response/scf_response.py
/usr/lib/x86_64-linux-gnu/psi4/driver/procrouting/sapt/__init__.py
/usr/lib/x86_64-linux-gnu/psi4/driver/procrouting/sapt/sapt_jk_terms.py
/usr/lib/x86_64-linux-gnu/psi4/driver/procrouting/sapt/sapt_mp2_terms.py
/usr/lib/x86_64-linux-gnu/psi4/driver/procrouting/sapt/sapt_proc.py
/usr/lib/x86_64-linux-gnu/psi4/driver/procrouting/sapt/sapt_sf_terms.py
/usr/lib/x86_64-linux-gnu/psi4/driver/procrouting/sapt/sapt_util.py
/usr/lib/x86_64-linux-gnu/psi4/driver/qcdb/__init__.py
/usr/lib/x86_64-linux-gnu/psi4/driver/qcdb/align.py
/usr/lib/x86_64-linux-gnu/psi4/driver/qcdb/basislist.py
/usr/lib/x86_64-linux-gnu/psi4/driver/qcdb/basislistdunning.py
/usr/lib/x86_64-linux-gnu/psi4/driver/qcdb/basislistother.py
/usr/lib/x86_64-linux-gnu/psi4/driver/qcdb/bfs.py
/usr/lib/x86_64-linux-gnu/psi4/driver/qcdb/cfour.py
/usr/lib/x86_64-linux-gnu/psi4/driver/qcdb/cov_radii.py
/usr/lib/x86_64-linux-gnu/psi4/driver/qcdb/dashparam.py
/usr/lib/x86_64-linux-gnu/psi4/driver/qcdb/datastructures.py
/usr/lib/x86_64-linux-gnu/psi4/driver/qcdb/dbproc.py
/usr/lib/x86_64-linux-gnu/psi4/driver/qcdb/dbwrap.py
/usr/lib/x86_64-linux-gnu/psi4/driver/qcdb/exceptions.py
/usr/lib/x86_64-linux-gnu/psi4/driver/qcdb/hessparse.py
/usr/lib/x86_64-linux-gnu/psi4/driver/qcdb/interface_dftd3.py
/usr/lib/x86_64-linux-gnu/psi4/driver/qcdb/interface_gcp.py
/usr/lib/x86_64-linux-gnu/psi4/driver/qcdb/jajo.py
/usr/lib/x86_64-linux-gnu/psi4/driver/qcdb/libmintsbasisset.py
/usr/lib/x86_64-linux-gnu/psi4/driver/qcdb/libmintsbasissetparser.py
/usr/lib/x86_64-linux-gnu/psi4/driver/qcdb/libmintscoordentry.py
/usr/lib/x86_64-linux-gnu/psi4/driver/qcdb/libmintsgshell.py
/usr/lib/x86_64-linux-gnu/psi4/driver/qcdb/libmintsmolecule.py
/usr/lib/x86_64-linux-gnu/psi4/driver/qcdb/libmintspointgrp.py
/usr/lib/x86_64-linux-gnu/psi4/driver/qcdb/modelchems.py
/usr/lib/x86_64-linux-gnu/psi4/driver/qcdb/molecule.py
/usr/lib/x86_64-linux-gnu/psi4/driver/qcdb/molpro.py
/usr/lib/x86_64-linux-gnu/psi4/driver/qcdb/molpro2.py
/usr/lib/x86_64-linux-gnu/psi4/driver/qcdb/molpro_basissets.py
/usr/lib/x86_64-linux-gnu/psi4/driver/qcdb/mpl.py
/usr/lib/x86_64-linux-gnu/psi4/driver/qcdb/options.py
/usr/lib/x86_64-linux-gnu/psi4/driver/qcdb/orca.py
/usr/lib/x86_64-linux-gnu/psi4/driver/qcdb/orient.py
/usr/lib/x86_64-linux-gnu/psi4/driver/qcdb/p4regex.py
/usr/lib/x86_64-linux-gnu/psi4/driver/qcdb/parker.py
/usr/lib/x86_64-linux-gnu/psi4/driver/qcdb/pdict.py
/usr/lib/x86_64-linux-gnu/psi4/driver/qcdb/periodictable.py
/usr/lib/x86_64-linux-gnu/psi4/driver/qcdb/physconst.py
/usr/lib/x86_64-linux-gnu/psi4/driver/qcdb/psiutil.py
/usr/lib/x86_64-linux-gnu/psi4/driver/qcdb/psivardefs.py
/usr/lib/x86_64-linux-gnu/psi4/driver/qcdb/psivarrosetta.py
/usr/lib/x86_64-linux-gnu/psi4/driver/qcdb/qcformat.py
/usr/lib/x86_64-linux-gnu/psi4/driver/qcdb/qchem.py
/usr/lib/x86_64-linux-gnu/psi4/driver/qcdb/qcprog_psi4.py
/usr/lib/x86_64-linux-gnu/psi4/driver/qcdb/subsetgenerator.py
/usr/lib/x86_64-linux-gnu/psi4/driver/qcdb/textables.py
/usr/lib/x86_64-linux-gnu/psi4/driver/qcdb/vecutil.py
/usr/lib/x86_64-linux-gnu/psi4/driver/qcdb/vib.py
/usr/lib/x86_64-linux-gnu/psi4/driver/qcdb/molparse/__init__.py
/usr/lib/x86_64-linux-gnu/psi4/driver/qcdb/molparse/chgmult.py
/usr/lib/x86_64-linux-gnu/psi4/driver/qcdb/molparse/from_arrays.py
/usr/lib/x86_64-linux-gnu/psi4/driver/qcdb/molparse/from_string.py
/usr/lib/x86_64-linux-gnu/psi4/driver/qcdb/molparse/nucleus.py
/usr/lib/x86_64-linux-gnu/psi4/driver/qcdb/molparse/pubchem.py
/usr/lib/x86_64-linux-gnu/psi4/driver/qcdb/molparse/regex.py
/usr/lib/x86_64-linux-gnu/psi4/driver/qcdb/molparse/to_schema.py
/usr/lib/x86_64-linux-gnu/psi4/driver/qcdb/molparse/to_string.py
/usr/lib/x86_64-linux-gnu/psi4/driver/qcdb/pytest/addons.py
/usr/lib/x86_64-linux-gnu/psi4/driver/qcdb/pytest/test_bfs.py
/usr/lib/x86_64-linux-gnu/psi4/driver/qcdb/pytest/test_from_string.py
/usr/lib/x86_64-linux-gnu/psi4/driver/qcdb/pytest/test_mints4.py
/usr/lib/x86_64-linux-gnu/psi4/driver/qcdb/pytest/test_mints5_molecule_symmetry.py
/usr/lib/x86_64-linux-gnu/psi4/driver/qcdb/pytest/test_mints9_basisset.py
/usr/lib/x86_64-linux-gnu/psi4/driver/qcdb/pytest/test_parse_nucleus_label.py
/usr/lib/x86_64-linux-gnu/psi4/driver/qcdb/pytest/test_reconcile_nucleus.py
/usr/lib/x86_64-linux-gnu/psi4/driver/qcdb/pytest/test_schema.py
/usr/lib/x86_64-linux-gnu/psi4/driver/qcdb/pytest/test_to_string.py
/usr/lib/x86_64-linux-gnu/psi4/driver/qcdb/pytest/test_validate_and_fill_chgmult.py
/usr/lib/x86_64-linux-gnu/psi4/driver/qcdb/pytest/utils.py
/usr/lib/x86_64-linux-gnu/psi4/driver/qcdb/tests/litdb1/mard_data.py
/usr/lib/x86_64-linux-gnu/psi4/driver/qcdb/util/__init__.py
/usr/lib/x86_64-linux-gnu/psi4/driver/qcdb/util/gph_uno_bipartite.py
/usr/lib/x86_64-linux-gnu/psi4/driver/qcdb/util/misc.py
/usr/lib/x86_64-linux-gnu/psi4/driver/qcdb/util/mpl.py
/usr/lib/x86_64-linux-gnu/psi4/driver/qcdb/util/np_blockwise.py
/usr/lib/x86_64-linux-gnu/psi4/driver/qcdb/util/np_rand3drot.py
/usr/lib/x86_64-linux-gnu/psi4/driver/qcdb/util/scipy_hungarian.py
/usr/lib/x86_64-linux-gnu/psi4/driver/util/__init__.py
/usr/lib/x86_64-linux-gnu/psi4/driver/util/filesystem.py
/usr/lib/x86_64-linux-gnu/psi4/driver/util/tty/__init__.py
/usr/lib/x86_64-linux-gnu/psi4/driver/util/tty/color.py
/usr/lib/x86_64-linux-gnu/psi4/tests/addons.py
/usr/lib/x86_64-linux-gnu/psi4/tests/conftest.py
/usr/lib/x86_64-linux-gnu/psi4/tests/test_addons.py
/usr/lib/x86_64-linux-gnu/psi4/tests/test_psi4.py
/usr/share/doc/psi4/TODO.Debian
/usr/share/doc/psi4/changelog.Debian.gz
/usr/share/doc/psi4/copyright
/usr/share/doc/psi4/psi4rc.example

Changelog

2019-01-05 - Michael Banck <mbanck@debian.org>
psi4 (1:1.2.1-2) unstable; urgency=medium
* debian/control (Standards-Version): Bumped to 4.3.0.
* debian/control (Build-Depends): Added python3-networkx.
* debian/control (psi4/Depends): Added python3 runtime modules
python3-deepdiff, python3-numpy, python3-networkx and python3-pybind11.
* debian/control (Build-Depends): Removed Boost libraries, no longer needed.
* debian/patches/libxc_external.patch: Remove WPBE functional from dft-smoke
test, as it is not available.
* debian/rules (override_dh_auto_configure) Removed MAX_AM_ERI from CMake
definitions.
* debian/patches/dfhelper_crash_fix.patch: New patch, fixes segfaults in
DFHelper::transform, taken from upstream commit e286fcebf.
* debian/patches/testsuite_32bit_memory.patch: New patch, avoids memory
allocations above 2GB for 32bit architectures.
* debian/tests: Added autopkgtests based on upstream's `smoketest' target.
2019-01-04 - Michael Banck <mbanck@debian.org>
psi4 (1:1.2.1-1) unstable; urgency=medium
* New upstream release.  New features include:
+ Density-Fitted (DF) CCSD(T) Gradients
+ Spin-Network-Scaled MP2 (SNS-MP2)
+ VV10 non-local dispersion
+ Hundreds of new DFT Functionals via LibXC
+ Dispersion Corrected Spin-Component Scaled Double Hybrid (DSD) Functionals
+ Second-Order SCF Convergence of Density Functional Theory
+ Coupled Perturbed Self-Consistent Field (HF and DFT)
+ Second-Order Electron Propagator Theory (EP2)
+ SAPT0 with S^Infinity Induction and Induction Exchange
+ Density-fitted Gradients for range-separated and CAM Functionals
* debian/patches/relax_dmrg_caspt2_test.patch: Removed, no longer needed.
* debian/patches/fix_manual_build.patch: Likewise.
* debian/patches/support-pybind11-2.2.patch: Likewise.
* debian/control (Build-Depends): Bump libchemps2-dev version to 1.8.5-1.
* debian/control (Build-Depends): Added libgg-dev and libxc-dev.
* debian/control (Description): Update capabilities.
* debian/patches/verbose_makefile.patch: Updated.
* debian/rules (override_dh_auto_configure): Set PYTHON_EXECUTABLE to
python3.
* debian/control (Build-Depends): Added python3-deepdiff.
* debian/patches/relax_external_cmake_requirements.patch: New patch, relaxes
the pybind11 cmake requirements.
* debian/patches/libxc_external.patch: New patch, allows building with
external LibXC.
* debian/rules (override_dh_auto_test): No longer run chemps2 tests
explicitly, there are some included in quicktests now.
2018-12-09 - Michael Banck <mbanck@debian.org>
psi4 (1:1.1-6) unstable; urgency=medium
* debian/patches/support-pybind11-2.2.patch: New patch, fixes build failure
with pybin11-2.2, by Gilles Filippini (Closes: #897492).
* debian/control (Build-Depends): Added dh-python.
* debian/control (psi4/Depends): Added ${python3:Depends}.
* debian/rules: Added --with python3, thanks to Adrian Bunk (Closes:
#906094).
* debian/patches/support-pybind11-2.2.patch: Include upstream commit
5c0b2ffd and parts of upstream commit 34fec146.
* debian/psi4.install: Update lib directory.
* debian/rules (override_dh_auto_configure): Define ENABLE_CheMPS2.
* debian/control (Build-Depends): Added chemps2.
* debian/patches/runtests_python3.patch: New patch, sets python3 as
interpreter for python tests.
2018-01-14 - Michael Banck <mbanck@debian.org>
psi4 (1:1.1-5) unstable; urgency=medium
* debian/control (Build-Depends): Added python3-pytest.
* debian/patches/verbose_makefile.patch: New patch, turns on verbose CMake
output.
* debian/rules (override_dh_auto_configure): Define ENABLE_XHOST to off and
MAX_AM_ERI to 4 in line with libint-dev package, remove no longer used
definitions.
* debian/rules (override_dh_auto_test): Adjust test directory following
upstream's renaming.
* debian/rules (override_dh_auto_install): No longer install the HTML manual
(Closes: #887068).  
* debian/psi4-data.install: Likewise.

See Also

Package Description
psi_1.3-5_amd64.deb Jabber client using Qt
psignifit_2.5.6-5_amd64.deb Fitting and testing hypotheses about psychometric functions
psk31lx_2.2-1_amd64.deb PSK31 terminal application with text-based user interface
psl-make-dafsa_0.20.2-2_all.deb Create a binary DAFSA from a Public Suffix List
psl_0.20.2-2_amd64.deb Explore the Public Suffix List
pslib-dev_0.4.5-3.1build1_amd64.deb development files for pslib
pslib1_0.4.5-3.1build1_amd64.deb library to create PostScript files
pslist_1.4.0-2_all.deb utility that controls a process and its descendants
psortb_3.0.6+dfsg-1_amd64.deb bacterial localization prediction tool
pspg_1.6.3-1build1_amd64.deb PostgreSQL pager
pspp_1.2.0-2ubuntu1_amd64.deb Statistical analysis tool
pspresent_1.3-4build1_amd64.deb fullscreen PostScript presentation tool
psrip_1.3-8_all.deb Extract images from PostScript files
pssh_2.3.1-1_all.deb Parallel versions of SSH-based tools
psst_0.1-7_amd64.deb power stress and shaping tool
Advertisement
Advertisement