prelude-manager_4.1.1-2_amd64.deb


Advertisement

Description

prelude-manager - Security Information and Events Management System [ Manager ]

Property Value
Distribution Ubuntu 19.04 (Disco Dingo)
Repository Ubuntu Universe amd64
Package filename prelude-manager_4.1.1-2_amd64.deb
Package name prelude-manager
Package version 4.1.1
Package release 2
Package architecture amd64
Package type deb
Category universe/admin
Homepage https://www.prelude-siem.org/
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 98.20 KB
Installed size 450.00 KB
Prelude Manager is the main program of the Prelude SIEM suite. It is a
multithreaded server which handles connections from the Prelude sensors. It
is able to register local or remote sensors, let the operator configure them
remotely, receive alerts, and store alerts in a database or any format
supported by reporting plugins, thus providing centralized logging and
analysis. The IDMEF standard is used for alert representation. Support for
filtering plugins allows you to hook in different places in the Manager to
define custom criteria for alert relaying and logging.
This package provides the Prelude Manager, which is a high availability
server that accepts secured connections from distributed sensors or
other managers and saves received events to a media specified by the
user (database, log files, mail, etc).

Alternatives

Package Version Architecture Repository
prelude-manager_4.1.1-2_i386.deb 4.1.1 i386 Ubuntu Universe
prelude-manager - - -

Requires

Name Value
adduser -
dbconfig-common -
debconf >= 0.5
debconf-2.0 -
libc6 >= 2.17
libgnutls30 >= 3.5.6
libmaxminddb0 >= 1.0.2
libprelude23 >= 4.1
libpreludedb7 >= 4.1
libwrap0 >= 7.6-4~
libxml2 >= 2.7.4
ucf -

Download

Type URL
Mirror archive.ubuntu.com
Binary Package prelude-manager_4.1.1-2_amd64.deb
Source Package prelude-manager

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install prelude-manager deb package:
    # sudo apt-get install prelude-manager

Files

Path
/etc/logrotate.d/prelude-manager
/lib/systemd/system/prelude-manager.service
/usr/bin/prelude-manager
/usr/include/prelude-manager/prelude-manager.h
/usr/lib/tmpfiles.d/prelude-manager.conf
/usr/lib/x86_64-linux-gnu/prelude-manager/decodes/normalize.so
/usr/lib/x86_64-linux-gnu/prelude-manager/filters/idmef-criteria.so
/usr/lib/x86_64-linux-gnu/prelude-manager/filters/thresholding.so
/usr/lib/x86_64-linux-gnu/prelude-manager/reports/db.so
/usr/lib/x86_64-linux-gnu/prelude-manager/reports/debug.so
/usr/lib/x86_64-linux-gnu/prelude-manager/reports/smtp.so
/usr/lib/x86_64-linux-gnu/prelude-manager/reports/textmod.so
/usr/lib/x86_64-linux-gnu/prelude-manager/reports/xmlmod.so
/usr/share/dbconfig-common/data/prelude-manager/install/mysql
/usr/share/dbconfig-common/data/prelude-manager/install/pgsql
/usr/share/dbconfig-common/data/prelude-manager/upgrade/mysql/0.9.10-2
/usr/share/dbconfig-common/data/prelude-manager/upgrade/mysql/0.9.9.1-1
/usr/share/dbconfig-common/data/prelude-manager/upgrade/pgsql/0.9.10-2
/usr/share/dbconfig-common/data/prelude-manager/upgrade/pgsql/0.9.9.1-1
/usr/share/doc/prelude-manager/README.Debian
/usr/share/doc/prelude-manager/TODO.Debian
/usr/share/doc/prelude-manager/changelog.Debian.gz
/usr/share/doc/prelude-manager/copyright
/usr/share/doc/prelude-manager/smtp/template.example
/usr/share/man/man1/prelude-manager.1.gz
/usr/share/prelude-manager/prelude-manager.conf
/usr/share/prelude-manager/xmlmod/idmef-message.dtd

Changelog

2018-03-16 - Thomas Andrejak <thomas.andrejak@gmail.com>
prelude-manager (4.1.1-2) unstable; urgency=medium
* d/prelude-manager.postinst: fix chown calls on non existing files
2018-03-12 - Thomas Andrejak <thomas.andrejak@gmail.com>
prelude-manager (4.1.1-1) unstable; urgency=medium
* Bump version 4.1.1 (Closes: #892789)
- Update dependencies:
libprelude and libpreludedb 4.1 is required
Add prelude-utils
- Update patch 003-fix-libpreludedb-pkgconfig.patch
* d/control:
- Update description
- Update Vcs-* fields to salsa
* d/prelude-manager.postinst, do no use chown -R
* Update copyrights dates
2018-01-06 - Thomas Andrejak <thomas.andrejak@gmail.com>
prelude-manager (3.1.0-4) unstable; urgency=medium
* prelude-correlator.postinst: revert fix of #742116 because there
was no issues
* Bump Standards-Version to 4.1.3, nothing to update
* Bump debhelper compat level to 11
- Bump in d/control and d/compat
- Update d/postinst to use new features around systemd
2017-12-18 - Thomas Andrejak <thomas.andrejak@gmail.com>
prelude-manager (3.1.0-3) unstable; urgency=medium
* prelude-correlator.postinst: use single quotes instead of double
quotes in the sed statement (Closes: #742116)
* Bump Standards-Version to 4.1.2, nothing to update
2017-11-20 - Thomas Andrejak <thomas.andrejak@gmail.com>
prelude-manager (3.1.0-2) unstable; urgency=medium
* Push to unstable
2017-11-03 - Thomas Andrejak <thomas.andrejak@gmail.com>
prelude-manager (3.1.0-1) experimental; urgency=medium
* Remove init.d conffile
* On previous version (3.1.0-0.1) the bump Standard-Version
was to 4.1.1 and not to 4.1.0
* Remove some trailing whitespace in d/changelog
* Add Thomas Andrejak as uploader in d/control
2017-10-04 - Thomas Andrejak <thomas.andrejak@gmail.com>
prelude-manager (3.1.0-0.1) experimental; urgency=medium
* Non-maintainer upload.
* Rewriting of rules file using the dh sequencer
* Addition of the upstream signing key
* Update of watch file: update URL since upstream website moved
* Migrate from init.d to systemd
- Remove init script and its configuration
- Add service and tmpfile
- Update prelude-manager.postinst to add creation of tmpfile
* Update README.debian: remove TODO part
* Update prelude-manager.postinst: add --home in adduser command
* Update prelude-manager.config: remove unnecessary check
* Remove unnecessary prelude-manager.{dirs,docs}
* Bump version 3.1.0 (Closes: #875533)
* Patches:
- Remove unnecessary patches now that upstream included them
- 001-conf_db.patch: For dbconfig
- 002-text-spelling.patch: Spelling
- 003-fix-libpreludedb-pkgconfig.patch: Move from libpreludedb-config
to pkg-config to get compile flags
* Control:
- Change Priority from extra to optional
- Add Vcs fields
- Bump Standards-Version to 4.1.0
- Bump debhelper compat level to 10
- Set Homepage field
- Update dependencies: add libwrap and libmaxminddb
- Update MySQL dependencies (Closes:#848449)
* Update SQL dir content to made rules file simpler
* Rewriting of copyright file to fit the machine-readable format
* Add missing copyright information
2016-09-27 - Mattia Rizzolo <mattia@debian.org>
prelude-manager (1.0.1-5.2) unstable; urgency=medium
* Non-maintainer upload.
* Call dh_update_autotools_config to update config.{sub,guess} for new archs.
* Remove Mickael Profeta <profeta@debian.org> from the uploaders.
Closes: #838926
* Stop using hardening-wrapper, make use of dpkg-buildflags with
DEB_BUILD_MAINT_OPTIONS=hardening=+all
instead.  Closes: #836648
2014-08-15 - Andreas Metzler <ametzler@debian.org>
prelude-manager (1.0.1-5.1) unstable; urgency=medium
* Non-maintainer upload.
* Rebuild against GnuTLS 3. Drop build-dependency on libgnutls-dev, instead
rely on libprelude-dev pulling in GnuTLS and gcrypt development packages.

See Also

Package Description
prelude-notify_0.9.1-1.1_all.deb Security Information Management System [ Desktop Notifier ]
prelude-utils_4.1.0-4.2_amd64.deb Security Information and Events Management system [ Utils ]
preludedb-utils_4.1.0-2ubuntu3_amd64.deb Security Information and Events Management System [ Library utils ]
premake4_4.3+repack1-2build1_amd64.deb cross-platform build script generator
prepair-data_0.7.1-3build1_all.deb polygon repair tool -- example data
prepair_0.7.1-3build1_amd64.deb polygon repair tool
preprocess_1.1.0+ds-1build1_all.deb portable multi-language file preprocessor
prerex_6.5.4-1_amd64.deb course prerequisite chart editor for LaTeX/TikZ
presage-dbus_0.9.1-2.1ubuntu5_all.deb intelligent predictive text entry platform (D-Bus service)
presage_0.9.1-2.1ubuntu5_amd64.deb intelligent predictive text entry platform (tools and demos)
presentty_0.2.0-1_amd64.deb Console-based presentation software
preview.app_0.8.5-11build1_amd64.deb General purpose image viewer for GNUstep
previsat_3.5.1.7+dfsg1-3_amd64.deb satellite tracking software for observing purposes
prewikka_4.1.5-3_all.deb Security Information and Events Management System [ Web Interface ]
prey_0.6.2-1.1_all.deb utility for tracking stolen computers
Advertisement
Advertisement