pluginlib-dev_1.12.1-2_amd64.deb


Advertisement

Description

pluginlib-dev - ROS library for plugins

Property Value
Distribution Ubuntu 19.04 (Disco Dingo)
Repository Ubuntu Universe amd64
Package filename pluginlib-dev_1.12.1-2_amd64.deb
Package name pluginlib-dev
Package version 1.12.1
Package release 2
Package architecture amd64
Package type deb
Category universe/libdevel
Homepage https://wiki.ros.org/pluginlib
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 16.43 KB
Installed size 108.00 KB
This package is part of Robot OS (ROS). This is the high-level ROS
plugin interface. It provides tools for writing and dynamically
loading plugins using the ROS build infrastructure. To work, these
tools require plugin providers to register their plugins in their
package.xml file.

Alternatives

Package Version Architecture Repository
pluginlib-dev_1.12.1-2_i386.deb 1.12.1 i386 Ubuntu Universe
pluginlib-dev - - -

Requires

Name Value
libboost-dev -
libboost-filesystem-dev -
libboost-system-dev -
libclass-loader-dev -
librosconsole-dev -
libroslib-dev -
libtinyxml2-dev -
python -
ros-cmake-modules -

Download

Type URL
Mirror archive.ubuntu.com
Binary Package pluginlib-dev_1.12.1-2_amd64.deb
Source Package ros-pluginlib

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install pluginlib-dev deb package:
    # sudo apt-get install pluginlib-dev

Files

Path
/usr/include/pluginlib/class_desc.h
/usr/include/pluginlib/class_desc.hpp
/usr/include/pluginlib/class_list_macros.h
/usr/include/pluginlib/class_list_macros.hpp
/usr/include/pluginlib/class_loader.h
/usr/include/pluginlib/class_loader.hpp
/usr/include/pluginlib/class_loader_base.h
/usr/include/pluginlib/class_loader_base.hpp
/usr/include/pluginlib/class_loader_imp.h
/usr/include/pluginlib/class_loader_imp.hpp
/usr/include/pluginlib/exceptions.hpp
/usr/include/pluginlib/pluginlib_exceptions.h
/usr/lib/pluginlib/pluginlib_headers_migration.py
/usr/lib/x86_64-linux-gnu/pkgconfig/pluginlib.pc
/usr/share/doc/pluginlib-dev/changelog.Debian.gz
/usr/share/doc/pluginlib-dev/copyright
/usr/share/pluginlib/package.xml
/usr/share/pluginlib/cmake/pluginlibConfig-version.cmake
/usr/share/pluginlib/cmake/pluginlibConfig.cmake

Changelog

2018-10-11 - Jochen Sprickerhof <jspricke@debian.org>
ros-pluginlib (1.12.1-2) unstable; urgency=medium
* Simplify installation (needs new catkin)
* Bump policy version (no changes)
* simplify d/rules
2018-06-21 - Jochen Sprickerhof <jspricke@debian.org>
ros-pluginlib (1.12.1-1) unstable; urgency=medium
* Fix build-depends-on-1-revision
* New upstream version 1.10.5
* Update policy and debhelper versions
* Update watch file
* Remove old versioned dependency
* Limit watch to ROS1 versions
* New upstream version 1.11.2
* Update Vcs URLs to salsa.d.o
* Add R³
* http -> https
* New upstream version 1.12.1
* Update to new upstream version
* Bump policy and debhelper versions
* Rebase patches
* Add sourcedirectory to dh
2016-09-28 - Jochen Sprickerhof <jspricke@debian.org>
ros-pluginlib (1.10.4-2) unstable; urgency=medium
* add versioned dependency on libclass-loader-dev for UniquePtr
2016-09-23 - Jochen Sprickerhof <jspricke@debian.org>
ros-pluginlib (1.10.4-1) unstable; urgency=medium
* Bumped Standards-Version to 3.9.8, no changes needed.
* Update Vcs URLs
* Update my email address
* New upstream version 1.10.4
2016-07-10 - Jochen Sprickerhof <debian@jochen.sprickerhof.de>
ros-pluginlib (1.10.3-1) unstable; urgency=medium
* Make rules reproducible.
Thanks to Daniel Shahaf (Closes: #823174)
* Imported Upstream version 1.10.3
2016-02-24 - Jochen Sprickerhof <debian@jochen.sprickerhof.de>
ros-pluginlib (1.10.1-3) unstable; urgency=medium
* Adopt to new libexec location in catkin
2016-01-10 - Jochen Sprickerhof <debian@jochen.sprickerhof.de>
ros-pluginlib (1.10.1-2) unstable; urgency=medium
* Fix compilation on non x86_64 arch (Closes: #810662)
* Add dependencies
2015-12-25 - Jochen Sprickerhof <debian@jochen.sprickerhof.de>
ros-pluginlib (1.10.1-1) unstable; urgency=medium
* Initial release (Closes: #805335)

See Also

Package Description
plum_2.33.1-11_all.deb IRC proxy, stationing, logging, and bot program (pirc)
pluma-common_1.20.4-1_all.deb official text editor of the MATE desktop environment (common files)
pluma-dev_1.20.4-1_amd64.deb official text editor of the MATE desktop environment (development files)
pluma-doc_1.20.4-1_all.deb official text editor of the MATE desktop environment (documentation files)
pluma_1.20.4-1_amd64.deb official text editor of the MATE desktop environment
pluto-jpl-eph_0.0~git20180228-1.1_amd64.deb command line handling of JPL ephemeres data
pluto-lunar_0.0~git20180825.e34c1d1-1_amd64.deb routines for predictions of positions in solar system
pluxml_5.6-1_all.deb light blog/CMS engine powered by XML
plymouth-disabler_0.1_all.deb disable plymouth by installing .override files
plymouth-theme-breeze_5.15.4-0ubuntu1_amd64.deb Breeze theme for Plymouth
plymouth-theme-edubuntu_15.12.1_all.deb Plymouth is an application that runs very early
plymouth-theme-hamara_1.0_all.deb boot animation, logger and I/O multiplexer - Hamara theme
plymouth-theme-kubuntu-logo_19.04ubuntu4_all.deb graphical boot animation and logger - kubuntu-logo theme
plymouth-theme-kubuntu-text_19.04ubuntu4_all.deb graphical boot animation and logger - kubuntu-text theme
plymouth-theme-lubuntu-logo_19.04.2_all.deb plymouth theme for Lubuntu
Advertisement
Advertisement