php-smbclient_0.9.0-3_amd64.deb


Advertisement

Description

php-smbclient - PHP wrapper for libsmbclient

Property Value
Distribution Ubuntu 19.04 (Disco Dingo)
Repository Ubuntu Universe amd64
Package filename php-smbclient_0.9.0-3_amd64.deb
Package name php-smbclient
Package version 0.9.0
Package release 3
Package architecture amd64
Package type deb
Category universe/php
Homepage http://pecl.php.net/smbclient
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 21.34 KB
Installed size 95.00 KB
smbclient is a PHP extension that uses Samba's libsmbclient library
to provide Samba related functions and 'smb' streams to PHP programs.

Alternatives

Package Version Architecture Repository
php-smbclient_0.9.0-3_i386.deb 0.9.0 i386 Ubuntu Universe
php-smbclient - - -

Requires

Name Value
libc6 >= 2.14
libsmbclient >= 2:4.1.1
php-common >= 1:7.0+33~
phpapi-20170718 -
ucf -

Provides

Name Value
php-libsmbclient -
php7.2-smbclient -

Download

Type URL
Mirror archive.ubuntu.com
Binary Package php-smbclient_0.9.0-3_amd64.deb
Source Package php-smbclient

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install php-smbclient deb package:
    # sudo apt-get install php-smbclient

Files

Path
/etc/php/7.2/mods-available/smbclient.ini
/usr/lib/php/20170718/smbclient.so
/usr/share/doc/php-smbclient/changelog.Debian.gz
/usr/share/doc/php-smbclient/copyright

Changelog

2018-10-03 - Ondřej Surý <ondrej@debian.org>
php-smbclient (0.9.0-3) unstable; urgency=medium
* Add patch for PHP 7.3 (Courtesy of Remi Collet)
2018-08-19 - Ondřej Surý <ondrej@debian.org>
php-smbclient (0.9.0-2) unstable; urgency=medium
* Update maintainer email to team+php-pecl@tracker.debian.org
(Closes: #899812)
2018-03-23 - Ondřej Surý <ondrej@debian.org>
php-smbclient (0.9.0-1) unstable; urgency=medium
* New upstream version 0.9.0 (Closes: #892925)
* Update Vcs-* to samba.d.o.
2016-04-29 - Ondřej Surý <ondrej@debian.org>
php-smbclient (0.8.0-3) unstable; urgency=medium
* Move the default makefile snippet to dh-php and use a simple d/rules
with dh-php >= 0.12~
2016-04-28 - Ondřej Surý <ondrej@debian.org>
php-smbclient (0.8.0-2) unstable; urgency=medium
* Add Vcs-* links
* Improve d/rules so it can be used with both single or multiple PECL
upstream versions, controlled by looking for package-MAJOR.MINOR.xml,
package-MAJOR.xml and package.xml in this order
2016-03-07 - Ondřej Surý <ondrej@debian.org>
php-smbclient (0.8.0-1) unstable; urgency=medium
* Imported Upstream version 0.8.0
2016-02-29 - Ondřej Surý <ondrej@debian.org>
php-smbclient (0.8.0~rc1-3) unstable; urgency=medium
* Force rebuild with dh_php >= 0.7
2016-02-15 - Ondřej Surý <ondrej@debian.org>
php-smbclient (0.8.0~rc1-2) unstable; urgency=medium
* Enable smbclient extension by default (Closes: #814383)
2016-01-28 - Ondřej Surý <ondrej@debian.org>
php-smbclient (0.8.0~rc1-1) unstable; urgency=medium
* Initial release

See Also

Package Description
php-soap_7.2+69ubuntu1_all.deb SOAP module for PHP [default]
php-solr_2.4.0-7_amd64.deb PHP extension for communicating with Apache Solr server
php-sql-formatter_1.2.17-3_all.deb a PHP SQL highlighting library
php-ssh2_1.1.2+0.13-4_amd64.deb Bindings for the libssh2 library
php-stomp_2.0.2+1.0.9-2_amd64.deb Streaming Text Oriented Messaging Protocol (STOMP) client module for PHP
php-swiftmailer_5.4.2-1.1_all.deb Swiftmailer, free feature-rich PHP mailer
php-sybase_7.2+69ubuntu1_all.deb Sybase module for PHP [default]
php-symfony-asset_3.4.22+dfsg-1ubuntu1_all.deb manage asset URLs
php-symfony-browser-kit_3.4.22+dfsg-1ubuntu1_all.deb simulate the behavior of a web browser
php-symfony-cache_3.4.22+dfsg-1ubuntu1_all.deb Symfony Cache component with PSR-6, PSR-16, and tags
php-symfony-class-loader_3.4.22+dfsg-1ubuntu1_all.deb load PHP classes automatically
php-symfony-config_3.4.22+dfsg-1ubuntu1_all.deb load configurations from different data sources
php-symfony-console_3.4.22+dfsg-1ubuntu1_all.deb run tasks from the command line
php-symfony-contracts_1.0.2-1_all.deb A set of abstractions extracted out of the Symfony components
php-symfony-css-selector_3.4.22+dfsg-1ubuntu1_all.deb convert CSS selectors to XPath expressions
Advertisement
Advertisement