php-random-compat_2.0.18-1_all.deb


Advertisement

Description

php-random-compat - PHP 5.x polyfill for random_bytes() and random_int() from PHP 7

Property Value
Distribution Ubuntu 19.04 (Disco Dingo)
Repository Ubuntu Universe amd64
Package filename php-random-compat_2.0.18-1_all.deb
Package name php-random-compat
Package version 2.0.18
Package release 1
Package architecture all
Package type deb
Category universe/php
Homepage https://github.com/paragonie/random_compat
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 9.93 KB
Installed size 63.00 KB
The random_compat polyfill provides simple interfaces for cryptographically
secure random number generators added in PHP 7.0.0:
* random_bytes(int) generates an arbitrary number of random bytes
* random_int(int, int) returns a random integer between two given values
(inclusive)

Alternatives

Package Version Architecture Repository
php-random-compat_2.0.18-1_all.deb 2.0.18 all Ubuntu Universe
php-random-compat - - -

Requires

Name Value
php-common -

Download

Type URL
Mirror archive.ubuntu.com
Binary Package php-random-compat_2.0.18-1_all.deb
Source Package php-random-compat

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install php-random-compat deb package:
    # sudo apt-get install php-random-compat

Files

Path
/usr/share/doc/php-random-compat/changelog.Debian.gz
/usr/share/doc/php-random-compat/copyright
/usr/share/php/random_compat/byte_safe_strings.php
/usr/share/php/random_compat/cast_to_int.php
/usr/share/php/random_compat/error_polyfill.php
/usr/share/php/random_compat/random.php
/usr/share/php/random_compat/random_bytes_com_dotnet.php
/usr/share/php/random_compat/random_bytes_dev_urandom.php
/usr/share/php/random_compat/random_bytes_libsodium.php
/usr/share/php/random_compat/random_bytes_libsodium_legacy.php
/usr/share/php/random_compat/random_bytes_mcrypt.php
/usr/share/php/random_compat/random_int.php

Changelog

2019-01-08 - David Prévot <taffit@debian.org>
php-random-compat (2.0.18-1) unstable; urgency=medium
[ Paragon Initiative Enterprises ]
* Update for v2.0.18
[ David Prévot ]
* Use debhelper-compat 12
* Drop get-orig-source target
* Update Standards-Version to 4.3.0
2018-07-07 - David Prévot <taffit@debian.org>
php-random-compat (2.0.17-1) unstable; urgency=medium
[ Paragon Initiative Enterprises ]
* Version 2.0.17
[ David Prévot ]
* Update Standards-Version to 4.1.5
2018-06-08 - David Prévot <taffit@debian.org>
php-random-compat (2.0.15-1) unstable; urgency=medium
[ Paragon Initiative Enterprises ]
* Release notes for v2.0.15, update copyright year
[ David Prévot ]
* Update copyright (years)
* Track version 2
2018-04-24 - David Prévot <taffit@debian.org>
php-random-compat (2.0.12-1) unstable; urgency=medium
[ Paragon Initiative Enterprises ]
* Update CHANGELOG for v2.0.12
[ David Prévot ]
* Move project repository to salsa.d.o
* Update Standards-Version to 4.1.4
2017-10-05 - David Prévot <taffit@debian.org>
php-random-compat (2.0.11-1) unstable; urgency=medium
[ Scott ]
* Update .gitattributes
[ David Prévot ]
* Drop upstream doc not distributed anymore
* Restore upstream changelog
* Update copyright (years)
* Update Standards-Version to 4.1.1
2016-05-19 - David Prévot <taffit@debian.org>
php-random-compat (2.0.2-2) unstable; urgency=medium
* Ûpload to unstable since php-symfony-polyfill (from 1.2.0) allows
php-random-compat 2 as well
* Update Standards-Version to 3.9.8
2016-04-04 - David Prévot <taffit@debian.org>
php-random-compat (2.0.2-1) experimental; urgency=medium
[ Scott ]
* Add consistency check
* Update version comment for v2.0.2
2016-03-21 - David Prévot <taffit@debian.org>
php-random-compat (2.0.1-1) experimental; urgency=medium
* Upload to experimental since php-symfony-polyfill-php70 (as of 1.1.1-1)
depends on php-random-compat (<< 2~~)
[ Scott ]
* Version 2.0.1 (update comment)
[ David Prévot ]
* Revert "Track version 1"
2016-03-20 - David Prévot <taffit@debian.org>
php-random-compat (1.4.1-1) unstable; urgency=medium
[ Scott ]
* Add even more possible values for open_basedir
* Version 1.4.1 (update comment)
[ David Prévot ]
* Track version 1
2016-03-11 - David Prévot <taffit@debian.org>
php-random-compat (1.2.2-1) unstable; urgency=medium
[ Scott ]
* Prepare v1.2.2 release
[ David Prévot ]
* Build with recent pkg-php-tools for the PHP 7.0 transition

See Also

Package Description
php-raphf-dev_2.0.0+1.1.2-4_all.deb raphf module for PHP development headers [dummy]
php-raphf_2.0.0+1.1.2-4_amd64.deb raphf module for PHP
php-ratchet-pawl_0.3.4-1_all.deb Asynchronous WebSocket client for RatchetPHP
php-ratchet-rfc6455_0.2.4-2build1_all.deb Implementation of the WebSocket protocol for PHP
php-react-cache_0.5.0-1_all.deb Async, promise-based cache component for ReactPHP
php-react-child-process_0.5.2-2_all.deb Event-driven library for executing child processes with ReactPHP
php-react-dns_0.4.16-1_all.deb Asynchronous DNS resolver for ReactPHP
php-react-event-loop_1.0.0-1_all.deb ReactPHP's core reactor event loop for evented I/O
php-react-http_0.8.3-3_all.deb Event-driven, streaming HTTP/HTTPS server for ReactPHP
php-react-promise-stream_1.1.1-3_all.deb Link between promises and streams in ReactPHP
php-react-promise-timer_1.5.0-2_all.deb Trivial implementation of timeouts for promises on top of ReactPHP
php-react-promise_2.7.0-1_all.deb lightweight implementation of CommonJS Promises/A for PHP
php-react-socket_1.1.0-1_all.deb Asynchronous client and server socket connections for ReactPHP
php-react-stream_1.0.0-2_all.deb Event-driven streams for non-blocking I/O in ReactPHP
php-readline_7.2+69ubuntu1_all.deb readline module for PHP [default]
Advertisement
Advertisement