php-luasandbox_3.0.3-1_amd64.deb


Advertisement

Description

php-luasandbox - PHP extension that provides a sandboxed Lua environment

Property Value
Distribution Ubuntu 19.04 (Disco Dingo)
Repository Ubuntu Universe amd64
Package filename php-luasandbox_3.0.3-1_amd64.deb
Package name php-luasandbox
Package version 3.0.3
Package release 1
Package architecture amd64
Package type deb
Category universe/php
Homepage https://www.mediawiki.org/wiki/LuaSandbox
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 31.36 KB
Installed size 114.00 KB
LuaSandbox is a PHP extension that provides a Lua environment which can be used
to run untrusted code. It provides a performance benefit compared to using a
standalone Lua binary.
LuaSandbox was designed for the MediaWiki Scribunto extension, which allows
users to write Lua code on the wiki, and then have it executed. But it has
no dependency upon MediaWiki and can be used standalone.

Alternatives

Package Version Architecture Repository
php-luasandbox_3.0.3-1_i386.deb 3.0.3 i386 Ubuntu Universe
php-luasandbox - - -

Requires

Name Value
libc6 >= 2.14
liblua5.1-0 -
php -
php-cli -
php-common >= 1:7.0+33~
phpapi-20170718 -

Download

Type URL
Mirror archive.ubuntu.com
Binary Package php-luasandbox_3.0.3-1_amd64.deb
Source Package php-luasandbox

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install php-luasandbox deb package:
    # sudo apt-get install php-luasandbox

Files

Path
/etc/php/7.2/mods-available/luasandbox.ini
/usr/lib/php/20170718/luasandbox.so
/usr/share/doc/php-luasandbox/changelog.Debian.gz
/usr/share/doc/php-luasandbox/copyright

Changelog

2018-10-10 - Kunal Mehta <legoktm@debian.org>
php-luasandbox (3.0.3-1) unstable; urgency=medium
* New upstream version 3.0.3
* d/watch: Enable pgpmode=gittag
* Standards-Version: 4.2.1, no changes needed
2018-05-06 - Kunal Mehta <legoktm@member.fsf.org>
php-luasandbox (3.0.1-2) unstable; urgency=medium
* Switch Maintainer to "MediaWiki packaging team"
* Standards-Version: 4.1.4
2018-02-28 - Kunal Mehta <legoktm@member.fsf.org>
php-luasandbox (3.0.1-1) unstable; urgency=medium
* New upstream version 3.0.1
* Fixes tests on 32-bit systems
* Have dh_auto_test fail when tests fail
2018-02-13 - Kunal Mehta <legoktm@member.fsf.org>
php-luasandbox (3.0.0-1) unstable; urgency=medium
* Update Vcs-* control fields for move to salsa.debian.org
* New upstream release.
* Update Homepage to new wiki page
* Standards-Version: 4.1.3, no changes needed
* Update copyright for new release and new year
* Make sure CI fails if a test fails
2017-12-04 - Kunal Mehta <legoktm@member.fsf.org>
php-luasandbox (2.0.14-4) unstable; urgency=medium
* Set Rules-Requires-Root: no
* Use dh_php for installing luasandbox.ini
* Update to debhelper compat 10
2017-11-25 - Kunal Mehta <legoktm@member.fsf.org>
php-luasandbox (2.0.14-3) unstable; urgency=medium
* Run tests via autopkgtest
* Standards-Version: 4.1.1
2017-09-25 - Kunal Mehta <legoktm@member.fsf.org>
php-luasandbox (2.0.14-2) unstable; urgency=medium
* Change section to php
2017-09-04 - Kunal Mehta <legoktm@member.fsf.org>
php-luasandbox (2.0.14-1) unstable; urgency=medium
* New upstream release.
* Add debian/watch
* Add gbp.conf
* Update to Standards-Version 4.1.0
* Add Vcs-Git and Vcs-Browser control fields
2017-06-23 - Kunal Mehta <legoktm@member.fsf.org>
php-luasandbox (2.0.13-1) unstable; urgency=medium
* Initial release. (Closes: #865724)

See Also

Package Description
php-mail-mime_1.10.2-0.1_all.deb PHP PEAR module for creating MIME messages
php-mail_1.3.0-1_all.deb Class that provides multiple interfaces for sending emails
php-mailparse_3.0.3~dev20181093+2.1.7~dev20160128-1_amd64.deb Email message manipulation for PHP
php-mapi_8.7.0-2ubuntu2_amd64.deb Complete and feature rich groupware solution - PHP MAPI bindings
php-markdown_1.8.0-1_all.deb PHP library for rendering Markdown data
php-mbstring_7.2+69ubuntu1_all.deb MBSTRING module for PHP [default]
php-mdb2-driver-mysql_1.5.0b4-2_all.deb mysql MDB2 driver
php-mdb2-driver-pgsql_1.5.0b4-2_all.deb pgsql MDB2 driver
php-mdb2_2.5.0b5-2_all.deb database abstraction layer
php-memcache_3.0.9~20170802.e702b5f-2_amd64.deb memcache extension module for PHP
php-memcached_3.1.3+2.2.0-1_amd64.deb memcached extension module for PHP, uses libmemcached
php-mf2_0.3.0-0.1_all.deb Microformats2 is the simplest way to markup structured information in HTML
php-mime-type_1.3.1-1build1_all.deb Utility class for dealing with MIME types
php-mongodb_1.5.3-2_amd64.deb MongoDB driver for PHP
php-monolog_1.24.0-1_all.deb send logs to various destination and web services
Advertisement
Advertisement