pev_0.80-4build1_amd64.deb


Advertisement

Description

pev - text-based tool to analyze PE files

Property Value
Distribution Ubuntu 19.04 (Disco Dingo)
Repository Ubuntu Universe amd64
Package filename pev_0.80-4build1_amd64.deb
Package name pev
Package version 0.80
Package release 4build1
Package architecture amd64
Package type deb
Category universe/utils
Homepage http://pev.sourceforge.net
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 152.21 KB
Installed size 1.29 MB
pev is a tool to get information of PE32/PE32+
executables (EXE, DLL, OCX etc) like  headers,
sections, resources and more.

Alternatives

Package Version Architecture Repository
pev_0.80-4build1_i386.deb 0.80 i386 Ubuntu Universe
pev - - -

Requires

Name Value
libc6 >= 2.14
libssl1.1 >= 1.1.0

Download

Type URL
Mirror archive.ubuntu.com
Binary Package pev_0.80-4build1_amd64.deb
Source Package pev

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install pev deb package:
    # sudo apt-get install pev

Files

Path
/usr/bin/ofs2rva
/usr/bin/pedis
/usr/bin/pehash
/usr/bin/pepack
/usr/bin/peres
/usr/bin/pescan
/usr/bin/pesec
/usr/bin/pestr
/usr/bin/readpe
/usr/bin/rva2ofs
/usr/lib/libpe.so
/usr/lib/libpe.so.1
/usr/lib/libpe.so.1.0
/usr/lib/pev/plugins/csv_plugin.so
/usr/lib/pev/plugins/html_plugin.so
/usr/lib/pev/plugins/json_plugin.so
/usr/lib/pev/plugins/text_plugin.so
/usr/lib/pev/plugins/xml_plugin.so
/usr/share/doc/pev/changelog.Debian.gz
/usr/share/doc/pev/copyright
/usr/share/man/man1/ofs2rva.1.gz
/usr/share/man/man1/pedis.1.gz
/usr/share/man/man1/pehash.1.gz
/usr/share/man/man1/pepack.1.gz
/usr/share/man/man1/peres.1.gz
/usr/share/man/man1/pescan.1.gz
/usr/share/man/man1/pesec.1.gz
/usr/share/man/man1/pestr.1.gz
/usr/share/man/man1/readpe.1.gz
/usr/share/man/man1/rva2ofs.1.gz
/usr/share/pev/userdb.txt

Changelog

2018-02-05 - Dimitri John Ledkov <xnox@ubuntu.com>
pev (0.80-4build1) bionic; urgency=high
* No change rebuild against openssl1.1.
2017-12-18 - Adam Borowski <kilobyte@angband.pl>
pev (0.80-4) unstable; urgency=medium
* QA upload.
* Migrate to openssl 1.1. (Closes: #870779)
* Priority optional.
* R³.
2017-07-16 - Petter Reinholdtsen <pere@debian.org>
pev (0.80-3) unstable; urgency=medium
* QA upload.
* Fix segfault due to modification of const value. (Closes: #868554)
* Extend autopkgtest check to run pehash too.
2017-07-15 - Petter Reinholdtsen <pere@debian.org>
pev (0.80-2) unstable; urgency=medium
* QA upload.
* Reorder build dependency for ssl, list libssl1.0-dev first to make
life easier for the autobuilders.
2017-07-15 - Petter Reinholdtsen <pere@debian.org>
pev (0.80-1) unstable; urgency=medium
* QA upload.
* New upstream version 0.80 (Closes: #772837).
- Dropped install-target.patch now applied upstream.
- Adjusted build rules for new upstream version.
- Added libssl1.0-dev as build dependency.
- Added 01-plugins-path.patch to adjust plugin path.
* Added simple autopkgtest check.
2016-09-02 - Petter Reinholdtsen <pere@debian.org>
pev (0.50-1) unstable; urgency=medium
* QA upload.
* Imported Debian packaging to collab-maint git.
* Change maintainer to Debian QA Group  as package is orphaned (bug #836368).
* Changed Standards-Version from 3.9.2 to 3.9.8.
* Changed debhelper compat level from 7 to 9.
* Updated to upstream version 0.50.
- Adjust build rules for version 0.50.  Added install-target.patch.
- Not updating to version 0.60 and newer because this is a GPL
program linking to OpenSSL without the OpenSSL exception.
2011-08-17 - Fernando Mercês <fernando@mentebinaria.com.br>
pev (0.40-1) unstable; urgency=low
* New upstreamer version.
* Added PE32+ support, TLS, ASLR and DEP checks.
2011-05-19 - Fernando Mercês <fernando@mentebinaria.com.br>
pev (0.31-2) unstable; urgency=low
* Fixed description.
* Compliance with Standards-Version 3.9.2
2011-05-19 - Fernando Mercês <fernando@mentebinaria.com.br>
pev (0.31-1) unstable; urgency=low
* New upstream release.
* Updated description (Closes: #618693)
* Display PE headers and sections.
2010-12-28 - Fernando Mercês <fernando@mentebinaria.com.br>
pev (0.22-1) unstable; urgency=low
* Initial release. (Closes: #608460)

See Also

Package Description
pex_1.1.14-2ubuntu2_all.deb library for generating Python executable zip files
pexec_1.0~rc8-4_amd64.deb Executing commands in parallel
pfb2t1c2pfb_0.3-11_amd64.deb convert pfb into more compressible format and back
pff-tools_20180714-1_amd64.deb utilities for MS Outlook PAB, PST and OST files
pflogsumm_1.1.5-5_all.deb Postfix log entry summarizer
pfm_2.0.8-3_all.deb PostgreSQL graphical client using Tcl/Tk
pfqueue_0.5.6-9build3_amd64.deb interactive console-based tool to control MTA queues
pfsglview_2.1.0-3build4_amd64.deb command line HDR manipulation programs (OpenGL/GLUT viewer)
pfstmo_2.1.0-3build4_amd64.deb set of tone mapping operators
pfstools_2.1.0-3build4_amd64.deb command line HDR manipulation programs
pfsview_2.1.0-3build4_amd64.deb command line HDR manipulation programs (Qt viewer)
pftools_3+dfsg-3_amd64.deb build and search protein and DNA generalized profiles
pg-activity_1.4.0-1_all.deb Realtime PostgreSQL database server monitoring tool
pg-backup-ctl_0.8_all.deb backup and recover PostgreSQL using log archiving
pg-cloudconfig_0.10_all.deb Set optimized defaults for PostgreSQL in virtual environments
Advertisement
Advertisement