pdfsam_4.0.1-1_all.deb


Advertisement

Description

pdfsam - PDF Split and Merge

Property Value
Distribution Ubuntu 19.04 (Disco Dingo)
Repository Ubuntu Universe amd64
Package filename pdfsam_4.0.1-1_all.deb
Package name pdfsam
Package version 4.0.1
Package release 1
Package architecture all
Package type deb
Category universe/text
Homepage http://www.pdfsam.org
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 1.03 MB
Installed size 1.20 MB
PDF Split and Merge is a very simple, easy to use, free, open source utility
to split and merge pdf files. It has a simple graphical interface to let the
user choose pdf files, split or merge them.

Alternatives

Package Version Architecture Repository
pdfsam_4.0.1-1_all.deb 4.0.1 all Ubuntu Universe
pdfsam - - -

Requires

Name Value
default-jre >= 2:1.9
java9-runtime -
libatinject-jsr330-api-java -
libbcmail-java >= 1.58
libbcprov-java >= 1.58
libcommons-io-java >= 2.6
libcommons-lang3-java >= 3.8
libfontawesomefx-java >= 9.1.2
libgettext-commons-java -
libhibernate-validator-java >= 4.3.3-2
libjackson2-jr-java -
liblogback-java -
libopenjfx-java -
libsambox-java >= 1.1.41
libsejda-eventstudio-java >= 1.0.6
libsejda-injector-java >= 1.0.2
libsejda-java >= 3.2.56
libslf4j-java >= 1.7.25
openjfx >= 11

Download

Type URL
Mirror archive.ubuntu.com
Binary Package pdfsam_4.0.1-1_all.deb
Source Package pdfsam

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install pdfsam deb package:
    # sudo apt-get install pdfsam

Files

Path
/usr/bin/pdfsam
/usr/share/applications/pdfsam.desktop
/usr/share/doc/pdfsam/changelog.Debian.gz
/usr/share/doc/pdfsam/copyright
/usr/share/icons/hicolor/scalable/apps/pdfsam.svg
/usr/share/man/man1/pdfsam.1.gz
/usr/share/pdfsam/bin/pdfsam.sh
/usr/share/pdfsam/lib/atinject-jsr330-api.jar
/usr/share/pdfsam/lib/bcmail.jar
/usr/share/pdfsam/lib/bcprov.jar
/usr/share/pdfsam/lib/commons-io.jar
/usr/share/pdfsam/lib/commons-lang3.jar
/usr/share/pdfsam/lib/eventstudio.jar
/usr/share/pdfsam/lib/fontawesomefx-commons.jar
/usr/share/pdfsam/lib/fontawesomefx-fontawesome.jar
/usr/share/pdfsam/lib/fontawesomefx-materialdesignfont.jar
/usr/share/pdfsam/lib/fontawesomefx-materialicons.jar
/usr/share/pdfsam/lib/fontbox2.jar
/usr/share/pdfsam/lib/geronimo-validation-1.0-spec.jar
/usr/share/pdfsam/lib/gettext-commons.jar
/usr/share/pdfsam/lib/hibernate-validator.jar
/usr/share/pdfsam/lib/jackson-core.jar
/usr/share/pdfsam/lib/jackson-jr-objects.jar
/usr/share/pdfsam/lib/javafx-base.jar
/usr/share/pdfsam/lib/javafx-controls.jar
/usr/share/pdfsam/lib/javafx-graphics.jar
/usr/share/pdfsam/lib/javafx-media.jar
/usr/share/pdfsam/lib/jboss-logging.jar
/usr/share/pdfsam/lib/jcl-over-slf4j.jar
/usr/share/pdfsam/lib/logback-classic.jar
/usr/share/pdfsam/lib/logback-core.jar
/usr/share/pdfsam/lib/pdfsam-alternate-mix-4.0.1.jar
/usr/share/pdfsam/lib/pdfsam-basic-4.0.1.jar
/usr/share/pdfsam/lib/pdfsam-core-4.0.1.jar
/usr/share/pdfsam/lib/pdfsam-extract-4.0.1.jar
/usr/share/pdfsam/lib/pdfsam-fx-4.0.1.jar
/usr/share/pdfsam/lib/pdfsam-gui-4.0.1.jar
/usr/share/pdfsam/lib/pdfsam-i18n-4.0.1.jar
/usr/share/pdfsam/lib/pdfsam-merge-4.0.1.jar
/usr/share/pdfsam/lib/pdfsam-rotate-4.0.1.jar
/usr/share/pdfsam/lib/pdfsam-service-4.0.1.jar
/usr/share/pdfsam/lib/pdfsam-simple-split-4.0.1.jar
/usr/share/pdfsam/lib/pdfsam-split-by-bookmarks-4.0.1.jar
/usr/share/pdfsam/lib/pdfsam-split-by-size-4.0.1.jar
/usr/share/pdfsam/lib/sambox.jar
/usr/share/pdfsam/lib/sejda-conversion.jar
/usr/share/pdfsam/lib/sejda-core.jar
/usr/share/pdfsam/lib/sejda-fonts.jar
/usr/share/pdfsam/lib/sejda-injector.jar
/usr/share/pdfsam/lib/sejda-io.jar
/usr/share/pdfsam/lib/sejda-model.jar
/usr/share/pdfsam/lib/sejda-sambox.jar
/usr/share/pdfsam/lib/slf4j-api.jar
/usr/share/pdfsam/resources/splash.gif

Changelog

2019-01-12 - Markus Koschany <apo@debian.org>
pdfsam (4.0.1-1) unstable; urgency=medium
* New upstream version 4.0.1
* Declare compliance with Debian Policy 4.3.0.
* Use canonical VCS URI.
2018-12-22 - Markus Koschany <apo@debian.org>
pdfsam (4.0.0-1) unstable; urgency=medium
* New upstream version 4.0.0.
* Drop fontawesomefx.patch and javafx.patch. Fixed upstream.
* Rebase pdfsam-bin.patch.
* Don't install logback.xml separately because it is included in pdfsam-basic
now.
2018-10-24 - Markus Koschany <apo@debian.org>
pdfsam (3.3.7-1) unstable; urgency=medium
* New upstream version 3.3.7.
* Switch to compat level 11.
* Add javafx.patch and port PDFsam to use OpenJFX 11. (Closes: #886394)
* Add fontawesomefx.patch and make PDFsam compatible with version 9.1.2 of
fontawesomefx.
* Add libcommons-csv-java to B-D.
* Declare compliance with Debian Policy 4.2.1.
* Update pdfsam-bin.patch and work around Debian bug #910764. Use
-Djdk.gtk.version=2.
2017-11-26 - Markus Koschany <apo@debian.org>
pdfsam (3.3.5-1) unstable; urgency=medium
* New upstream version 3.3.5.
* d/rules: Symlink the unversioned jar for javax.inject api.
2017-10-26 - Markus Koschany <apo@debian.org>
pdfsam (3.3.4-1) unstable; urgency=medium
* New upstream version 3.3.4.
2017-10-13 - Markus Koschany <apo@debian.org>
pdfsam (3.3.3-1) unstable; urgency=medium
* New upstream version 3.3.3.
* d/control: Change section back to text again.
* Declare compliance with Debian Policy 4.1.1.
* Tighten B-D on libsejda-java.
* Provide a simple manpage for pdfsam.
2017-09-19 - Markus Koschany <apo@debian.org>
pdfsam (3.3.2-2) unstable; urgency=medium
* Upload to unstable.
* Tighten dependency on libhibernate-validator-java to >= 4.3.3-2.
2017-09-15 - Markus Koschany <apo@debian.org>
pdfsam (3.3.2-1) experimental; urgency=medium
* New upstream version 3.3.2.
* Depend on libsambox-java and liblogback-java.
Thanks to Michael Weghorn for the report. (Closes: #874372)
* Tighten build-dependency on libsejda-java and libsambox-java.
* pdfsam.poms: Remove --has-package-version flag.
* get-orig-source: Use xz compression and repack the tarball.
2017-08-31 - Markus Koschany <apo@debian.org>
pdfsam (3.2.5-1) experimental; urgency=medium
* New upstream version. (Closes: #635964)
- Null pointer exception was fixed. (Closes: #779058)
- pdfsam-console does no longer exist. (Closes: #792467)
- i18n localization works as expected now. (Closes: #714394)
- The update manager is disabled by default now. (Closes: #796805)
- jgoodies-common is no longer a required dependency. (Closes: #714304)
* New build system Maven.
* Add myself to Uploaders and remove Thorsten Werner because he is not active
anymore.
2017-05-20 - Markus Koschany <apo@debian.org>
pdfsam (1.1.4-4) unstable; urgency=medium
* Team upload.
* Add a NEWS file and inform users, who upgrade from Jessie to Stretch,
to modify the LAF theme value in ~/.pdfsam/config.xml. (Closes: #855324)

See Also

Package Description
pdfsandwich_0.1.7-1_amd64.deb Tool to generate "sandwich" OCR pdf files
pdfshuffler_1.1.1-1_all.deb merge, split and re-arrange PDF documents - transitional package
pdftk-java_3.0.2-2_all.deb pdftk port to java - a tool for manipulating PDF documents
pdftk_2.02-5_amd64.deb transitional package for pdftk, a tool for manipulating PDF documents
pdftoipe_7.2.7.2-1ubuntu1_amd64.deb converts arbitrary PDF file to XML file readable by Ipe
pdi2iso_0.1-0ubuntu3_amd64.deb Instant Copy image to ISO image file converter
pdl_2.019-5build1_amd64.deb perl data language: Perl extensions for numerics
pdlzip_1.10-3_amd64.deb data compressor based on the LZMA algorithm (simple version)
pdmenu_1.3.4build1_amd64.deb simple console menu program
pdns-backend-bind_4.1.6-1build1_amd64.deb BIND backend for PowerDNS
pdns-backend-geoip_4.1.6-1build1_amd64.deb geoip backend for PowerDNS
pdns-backend-ldap_4.1.6-1build1_amd64.deb LDAP backend for PowerDNS
pdns-backend-lua_4.1.6-1build1_amd64.deb Lua backend for PowerDNS
pdns-backend-mydns_4.1.6-1build1_amd64.deb MyDNS compatibility backend for PowerDNS
pdns-backend-mysql_4.1.6-1build1_amd64.deb generic MySQL backend for PowerDNS
Advertisement
Advertisement