pcb-gtk_4.2.0-2_amd64.deb


Advertisement

Description

pcb-gtk - printed circuit board (pcb) design program - GTK+ interface

Property Value
Distribution Ubuntu 19.04 (Disco Dingo)
Repository Ubuntu Universe amd64
Package filename pcb-gtk_4.2.0-2_amd64.deb
Package name pcb-gtk
Package version 4.2.0
Package release 2
Package architecture amd64
Package type deb
Category universe/electronics
Homepage http://pcb.geda-project.org/
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 617.04 KB
Installed size 1.65 MB
PCB is an interactive printed circuit board editor for the X11 window
system. PCB includes a rats nest feature, design rule checking, and can
provide industry standard RS-274-X (Gerber), NC drill, and centroid data
(X-Y data) output for use in the board fabrication and assembly process.
PCB offers high end features such as an autorouter and trace optimizer
which can tremendously reduce layout time.
This package contains the GTK+ user-interface for pcb.

Alternatives

Package Version Architecture Repository
pcb-gtk_4.2.0-2_i386.deb 4.2.0 i386 Ubuntu Universe
pcb-gtk - - -

Requires

Name Value
libc6 >= 2.14
libcairo2 >= 1.2.4
libdbus-1-3 >= 1.9.14
libgd3 >= 2.1.0~alpha~
libgdk-pixbuf2.0-0 >= 2.22.0
libgl1 -
libglib2.0-0 >= 2.35.9
libglu1 -
libglu1-mesa -
libgtk2.0-0 >= 2.18.0
libgtkglext1 -
pcb-common -

Download

Type URL
Mirror archive.ubuntu.com
Binary Package pcb-gtk_4.2.0-2_amd64.deb
Source Package pcb

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install pcb-gtk deb package:
    # sudo apt-get install pcb-gtk

Files

Path
/usr/bin/pcb-gtk
/usr/share/doc/pcb-gtk
/usr/share/man/man1/pcb-gtk.1.gz
/usr/share/menu/pcb-gtk

Changelog

2019-02-03 - Bdale Garbee <bdale@gag.com>
pcb (1:4.2.0-2) unstable; urgency=medium
* disable test suite on i386 due to known upstream issue in test harness
2019-02-02 - Bdale Garbee <bdale@gag.com>
pcb (1:4.2.0-1) unstable; urgency=medium
* New upstream version 4.2.0
2018-10-04 - Bdale Garbee <bdale@gag.com>
pcb (1:4.1.3-1) unstable; urgency=medium
* New upstream version 4.1.3
2018-06-10 - Bdale Garbee <bdale@gag.com>
pcb (1:4.1.2-1) unstable; urgency=medium
[ Dima Kogan ]
* Moved Vcs-... tags to point to salsa
[ Bdale Garbee ]
* New upstream version 4.1.2
2017-10-11 - أحمد المحمودي (Ahmed El-Mahmoudy) <aelmahmoudy@users.sourceforge.net>
pcb (1:4.0.2-4) unstable; urgency=medium
* debian/watch:
+ Remove non-working URL
+ debian/watch: limit search pattern to upstream new versioning scheme
2017-10-03 - أحمد المحمودي (Ahmed El-Mahmoudy) <aelmahmoudy@users.sourceforge.net>
pcb (1:4.0.2-3) unstable; urgency=medium
* Add -ffloat-store to CFLAGS for *-i386 builds
* fix_typos.diff: fix  further spelling errors
* Fix spelling error in an old changelog entry
2017-10-01 - أحمد المحمودي (Ahmed El-Mahmoudy) <aelmahmoudy@users.sourceforge.net>
pcb (1:4.0.2-2) unstable; urgency=medium
* Add rm_mimelnk.diff patch to remove deprecated
* mimelnk files (Closes: #875526)
* Add -ffloat-store to CFLAGS for i386 builds.
Thanks to Adrian Bunk <bunk@debian.org>
(Closes: #876641)
* Update Standards-Version to 4.1.1
* Re-add myself to uploaders
* Change Vcs-* fields to secure URLs
* Update my email address
* Update copyright years
* Fix spelling errors
* Add fix_typos.diff patch to fix upstream
spelling errors
* Removed unused lintian overrides
* Bump to compat level 10
+ Remove autotools-dev sequence
+ Disable autoreconf as it fails the build
+ Link package documentation using pcb*.links,
since dh_installdocs --linkdoc between
different arch. packages is not supported in
compat level 10
2017-09-06 - Bdale Garbee <bdale@gag.com>
pcb (1:4.0.2-1) unstable; urgency=medium
* new upstream release, using epoch to handle return to simple version
numbers, closes: #874414
* clean out Uploaders, closes: #759991, #831485, #859281 
2016-12-25 - Dima Kogan <dkogan@debian.org>
pcb (20140316-3.1) unstable; urgency=medium
* Non-maintainer upload
* debian/rules update to be able to make arch-indep-only builds and
arch-dependent-only builds. Closes: #806092
2014-08-27 - أحمد المحمودي (Ahmed El-Mahmoudy) <aelmahmoudy@sabily.org>
pcb (20140316-3) unstable; urgency=medium
* (Build-)Depend on unversioned tcl/tk

See Also

Package Description
pcb-lesstif_4.2.0-2_amd64.deb printed circuit board (pcb) design program - LessTif interface
pcb-rnd_2.1.1-1_amd64.deb Modular Printed Circuit Board layout tool
pcb2gcode_1.1.4-git20120902-1.1build3_amd64.deb command-line tool for engraving PCBs using CNCs
pcb_4.2.0-2_all.deb printed circuit board (pcb) design program - metapackage
pcc_1.2.0~DEVEL+20181202-1_amd64.deb Portable C Compiler
pccts_1.33MR33-6build1_amd64.deb The Purdue Compiler Construction Tool Set (PCCTS)
pcf2bdf_1.05-1build1_amd64.deb convert X11 font from PCF to BDF format
pchar_1.5-4_amd64.deb Characterize the bandwidth, latency and loss on network links
pcl-tools_1.9.1+dfsg1-3ubuntu1_amd64.deb Point Cloud Library - point cloud processing tools
pcmanfm-qt-l10n_0.14.1-0ubuntu1_all.deb Language package for pcmanfm-qt
pcmanfm-qt_0.14.1-0ubuntu1_amd64.deb extremely fast and lightweight file and desktop icon manager
pcmanfm_1.3.1-1_amd64.deb extremely fast and lightweight file manager
pcmanx-gtk2_1.3-2_amd64.deb user-friendly telnet client mainly targets BBS users
pconsole_1.0-14_amd64.deb parallel interactive shell console
pcp-conf_4.3.1-1_amd64.deb Performance Co-Pilot runtime configuration
Advertisement
Advertisement