patchelf_0.9+52.20180509-1_amd64.deb


Advertisement

Description

patchelf - modify properties of ELF executables

Property Value
Distribution Ubuntu 19.04 (Disco Dingo)
Repository Ubuntu Universe amd64
Package filename patchelf_0.9+52.20180509-1_amd64.deb
Package name patchelf
Package version 0.9+52.20180509
Package release 1
Package architecture amd64
Package type deb
Category universe/utils
Homepage http://nixos.org/patchelf.html
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 50.21 KB
Installed size 140.00 KB
PatchELF is a simple utility for modifying existing ELF executables and
libraries.  In particular, it can do the following:
* Change the dynamic loader ("ELF interpreter") of executables
* Change the RPATH of executables and libraries
* Remove declared dependencies on dynamic libraries
(DT_NEEDED entries)

Alternatives

Package Version Architecture Repository
patchelf_0.9+52.20180509-1_i386.deb 0.9+52.20180509 i386 Ubuntu Universe
patchelf - - -

Requires

Name Value
libc6 >= 2.14
libgcc1 >= 1:3.0
libstdc++6 >= 5.2

Download

Type URL
Mirror archive.ubuntu.com
Binary Package patchelf_0.9+52.20180509-1_amd64.deb
Source Package patchelf

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install patchelf deb package:
    # sudo apt-get install patchelf

Files

Path
/usr/bin/patchelf
/usr/share/doc/patchelf/README.gz
/usr/share/doc/patchelf/changelog.Debian.gz
/usr/share/doc/patchelf/copyright
/usr/share/man/man1/patchelf.1.gz

Changelog

2018-09-28 - Felipe Sateler <fsateler@debian.org>
patchelf (0.9+52.20180509-1) unstable; urgency=medium
[ Felipe Sateler ]
* Package an upstream git snapshot
- Makes some binaries strippable after patching (Closes: #903396)
* no-rpath-prebuild: force pagesize to 4096 on prebuilt binaries.
They all have that page size, and the host-detected one might be
different.
* Update watchfile
- Use format version 4
- Use github as source page
* Migrate to salsa for hosting
* Bump debhelper compat to 11.
Also switch to the debhelper-compat virtual package
* Bump Standards-Version
* Enable hardening flags
[ Drew Parsons ]
* add new patch adjust_startPage_issue127_commit1cc234fea.patch from
upstream Issue #127. Fixes build-time tests.
2016-02-29 - Felipe Sateler <fsateler@debian.org>
patchelf (0.9-1) unstable; urgency=medium
* New upstream release
- Drop all patches, applied upstream
- No longer breaks hardlinks (Closes: #759497)
* Force pagesize for no-rpath-prebuild test: We know the page size,
and it may be different from system one
2015-11-15 - Felipe Sateler <fsateler@debian.org>
patchelf (0.8-4) unstable; urgency=medium
* Disable no-rpath.sh test, as it may fail when the binary is of foreign
architecture. Really Closes: #799880
2015-11-12 - Felipe Sateler <fsateler@debian.org>
patchelf (0.8-3) unstable; urgency=medium
* Pick upstream commit to use a dynamic page size. Fixes FTBFS on ppc64el.
Closes: #799880
2014-03-28 - Felipe Sateler <fsateler@debian.org>
patchelf (0.8-2) unstable; urgency=medium
* Document --remove-needed in manpage
* Fix typo in manpage. Closes: #742468
Thanks Gianluigi Tiesi
2014-03-18 - Felipe Sateler <fsateler@debian.org>
patchelf (0.8-1) unstable; urgency=low
* Initial release (Closes: #742049)

See Also

Package Description
pathogen_1.1.1-5_amd64.deb Puzzle game about matching 3D model structures
pathological_1.1.3-15_all.deb puzzle game involving paths and marbles
pathspider_2.0.1-2_amd64.deb Internet path transparency measurement tool
patman_1.2.2+dfsg-5_amd64.deb rapid alignment of short sequences to large databases
patool_1.12-3_all.deb command line archive file manager
patroni-doc_1.5.5-1_all.deb PostgreSQL High Availability (documentation)
patroni_1.5.5-1_all.deb PostgreSQL High Availability with ZooKeeper, etcd, Consul, or Kubernetes
paulstretch_2.2-2-4_amd64.deb Extreme sound time-stretch
pavucontrol-qt-l10n_0.14.1-1ubuntu1_all.deb Language package for pavucontrol-qt
pavucontrol-qt_0.14.1-1ubuntu1_amd64.deb Qt port of volume control pavucontrol
pavucontrol_3.0-4_amd64.deb PulseAudio Volume Control
pavumeter_0.9.3-4build2_amd64.deb PulseAudio Volume Meter
paw++_2.14.04.dfsg.2-9.1build3_amd64.deb Physics Analysis Workstation (Lesstif-enhanced version)
paw-common_2.14.04.dfsg.2-9.1build3_all.deb Physics Analysis Workstation (common files)
paw-demos_2.14.04.dfsg.2-9.1build3_all.deb Physics Analysis Workstation examples and tests
Advertisement
Advertisement