osspd_1.3.2-11_amd64.deb


Advertisement

Description

osspd - OSS Proxy Daemon: Userland OSS emulation

Property Value
Distribution Ubuntu 19.04 (Disco Dingo)
Repository Ubuntu Universe amd64
Package filename osspd_1.3.2-11_amd64.deb
Package name osspd
Package version 1.3.2
Package release 11
Package architecture amd64
Package type deb
Category universe/sound
Homepage https://sourceforge.net/projects/osspd/
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 24.21 KB
Installed size 90.00 KB
OSS Proxy Daemon is a Linux userland OSS sound device (/dev/[a]dsp and
/dev/mixer) implementation using CUSE. Currently it supports
forwarding OSS sound streams to PulseAudio and ALSA.
Actually emulating the OSS devices makes for a more robust emulation compared
to OSS wrappers using LD_PRELOAD, like aoss and padsp. It also works better
when running foreign-architecture applications or using old libc versions for
compatibility reasons.

Alternatives

Package Version Architecture Repository
osspd_1.3.2-11_i386.deb 1.3.2 i386 Ubuntu Universe
osspd - - -

Requires

Name Value
libc6 >= 2.28
libfuse2 >= 2.8
lsb-base >= 3.2-14
osspd-backend -
osspd-pulseaudio -

Provides

Name Value
oss-compat -

Conflicts

Name Value
oss-compat -

Download

Type URL
Mirror archive.ubuntu.com
Binary Package osspd_1.3.2-11_amd64.deb
Source Package osspd

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install osspd deb package:
    # sudo apt-get install osspd

Files

Path
/etc/init.d/osspd
/etc/modprobe.d/osspd.conf
/lib/modules-load.d/osspd.conf
/lib/systemd/system/osspd.service
/lib/udev/rules.d/98-osscuse.rules
/usr/sbin/osspd
/usr/share/doc/osspd/README.gz
/usr/share/doc/osspd/changelog.Debian.gz
/usr/share/doc/osspd/copyright
/usr/share/man/man8/osspd.8.gz

Changelog

2019-01-25 - Ralf Jung <post@ralfj.de>
osspd (1.3.2-11) unstable; urgency=medium
* Update Standards-Version to 4.3.0.  No changes needed.
* Fix cross-build with a patch by Helmut Grohne
<helmut@subdivi.de> (again).  (Closes: #917827).
2018-12-26 - Ralf Jung <post@ralfj.de>
osspd (1.3.2-10) unstable; urgency=medium
* Fix build on MIPS.  (Closes: #916231)
2017-12-08 - Ralf Jung <post@ralfj.de>
osspd (1.3.2-9) unstable; urgency=medium
* Fix using target-architecture pkg-config. Patch by
Helmut Grohne <helmut@subdivi.de>.  (Closes: #882365)
* No longer depend on obsolete dh-systemd.  Instead, depend
on sufficiently new debhelper.
* Update Standards-Version to 4.1.2.  Changed some URLs to
https.
2017-05-17 - Ralf Jung <post@ralfj.de>
osspd (1.3.2-8) unstable; urgency=medium
* Mark osspd as Multi-Arch: foreign (Closes: #861577).
* Update Standards-Version to 3.9.8. No changes needed.
* Use https URL for Vcs-Browser.
* Add Documentation to systemd service file.
* Fix a typo in the manpage.
2015-12-28 - Ralf Jung <post@ralfj.de>
osspd (1.3.2-7) unstable; urgency=medium
* Migrate debug symbols to ddeb.
* Update Standards-Version to 3.9.6. No changes needed.
2014-03-31 - Ralf Jung <post@ralfj.de>
osspd (1.3.2-6) unstable; urgency=medium
* Load cuse module via module-load.d.
* Update Standards-Version to 3.9.5. No changes needed.
2013-10-10 - Ralf Jung <post@ralfj.de>
osspd (1.3.2-5) unstable; urgency=low
* Fix systemd service file.
2013-09-26 - Ralf Jung <post@ralfj.de>
osspd (1.3.2-4) unstable; urgency=low
* Move backends into their own packages.
* Manage the ossp slave via update-alternatives.
* Add a systemd service file (taken from Arch).
* Add modprobe file to blacklist OSS modules - thanks, Stephen
(Closes: #712705).
2013-05-18 - Ralf Jung <post@ralfj.de>
osspd (1.3.2-3) unstable; urgency=low
* Provide oss-compat, as we provide OSS, and conflict with it
since it takes the OSS major/minor numbers.
* Update Standards-Version to 3.9.4. No changes needed.
* Add "-pthreads" compiler and linker flag. Patch based on Ubuntu
patch by Logan Rosen <logan@ubuntu.com>.
* Add links to git repository.
2012-10-02 - Ralf Jung <post@ralfj.de>
osspd (1.3.2-2) unstable; urgency=low
* 0004-Allow-to-set-slave-installation-path-during-compilat.patch:
Removed unused variables.
* Change architecture to linux-any as Hurd and FreeBSD lack epoll.
* Extend package description.

See Also

Package Description
ostinato_0.9-2build1_amd64.deb Packet/Traffic Generator and Analyzer
ostree-tests_2019.1-1ubuntu1_amd64.deb content-addressed filesystem for operating system binaries - tests
ostree_2019.1-1ubuntu1_amd64.deb content-addressed filesystem for operating system binaries
otags_4.05.1-1_amd64.deb tags file generator for OCaml
otb-bin-qt_6.6.1+dfsg-1build1_amd64.deb ORFEO Toolbox graphical user interface applications
otb-bin_6.6.1+dfsg-1build1_amd64.deb ORFEO Toolbox command line applications
otb-i18n_6.6.1+dfsg-1build1_all.deb ORFEO Toolbox translations
otb-qgis_6.6.1+dfsg-1build1_amd64.deb ORFEO Toolbox library - otbQgisDescriptor
otb-testdriver_6.6.1+dfsg-1build1_amd64.deb ORFEO Toolbox library - OTBTestDriver
otcl-shells_1.14+dfsg-4_amd64.deb OTcl shells
otf-trace_1.12.5+dfsg-4_amd64.deb Open Trace Format support library - development files
otf2bdf_3.1-4.1_amd64.deb generate BDF bitmap fonts from OpenType outline fonts
otp_1.2.2-1build1_amd64.deb Generator for One Time Pads or Passwords
otpw-bin_1.5-2_amd64.deb OTPW programs for generating OTPW lists
otrs2_6.0.16-1_all.deb Open Ticket Request System
Advertisement
Advertisement