osmium-tool_1.10.0-1_amd64.deb


Advertisement

Description

osmium-tool - Command line tool for working with OpenStreetMap data

Property Value
Distribution Ubuntu 19.04 (Disco Dingo)
Repository Ubuntu Universe amd64
Package filename osmium-tool_1.10.0-1_amd64.deb
Package name osmium-tool
Package version 1.10.0
Package release 1
Package architecture amd64
Package type deb
Category universe/utils
Homepage https://osmcode.org/osmium-tool/
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 663.32 KB
Installed size 2.19 MB
Osmium Tool is a multipurpose command line tool based on the Osmium library.
With the Osmium Tool you currently can:
* Get information about an OSM file
* Convert OSM files from one format into another (supports all XML and PBF
formats)
* Merge and apply change files to an OSM file (with or without history)
* Extract data from OSM history files for a given point in time or a time
range
The Osmium library has extensive support for all types of OSM entities: nodes,
ways, relations, and changesets. It allows reading from and writing to OSM
files in XML and PBF formats, including change files and full history files.
Osmium can store OSM data in memory and on disk in various formats and using
various indexes. Its easy to use handler interface allows you to quickly write
data filtering and conversion functions. Osmium can create WKT, WKB, OGR, GEOS
and GeoJSON geometries for easy conversion into many GIS formats and it can
assemble multipolygons from ways and relations.

Alternatives

Package Version Architecture Repository
osmium-tool_1.10.0-1_i386.deb 1.10.0 i386 Ubuntu Universe
osmium-tool - - -

Requires

Name Value
libboost-program-options1.67.0 -
libbz2-1.0 -
libc6 >= 2.14
libexpat1 >= 2.0.1
libgcc1 >= 1:3.0
libstdc++6 >= 7
zlib1g >= 1:1.2.6

Download

Type URL
Mirror archive.ubuntu.com
Binary Package osmium-tool_1.10.0-1_amd64.deb
Source Package osmium-tool

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install osmium-tool deb package:
    # sudo apt-get install osmium-tool

Files

Path
/usr/bin/osmium
/usr/share/doc/osmium-tool/CHANGELOG.md.gz
/usr/share/doc/osmium-tool/CONTRIBUTING.md
/usr/share/doc/osmium-tool/README.md.gz
/usr/share/doc/osmium-tool/changelog.Debian.gz
/usr/share/doc/osmium-tool/copyright
/usr/share/doc/osmium-tool/examples/extract-example-config/README.md
/usr/share/doc/osmium-tool/examples/extract-example-config/berlin-feature-collection.geojson
/usr/share/doc/osmium-tool/examples/extract-example-config/berlin.geojson
/usr/share/doc/osmium-tool/examples/extract-example-config/berlin.poly
/usr/share/doc/osmium-tool/examples/extract-example-config/brandenburg.poly.gz
/usr/share/doc/osmium-tool/examples/extract-example-config/extracts.json.gz
/usr/share/doc/osmium-tool/examples/extract-example-config/hamburg.poly
/usr/share/doc/osmium-tool/examples/extract-example-config/karlsruhe.osm.bz2
/usr/share/man/man1/osmium-add-locations-to-ways.1.gz
/usr/share/man/man1/osmium-apply-changes.1.gz
/usr/share/man/man1/osmium-cat.1.gz
/usr/share/man/man1/osmium-changeset-filter.1.gz
/usr/share/man/man1/osmium-check-refs.1.gz
/usr/share/man/man1/osmium-derive-changes.1.gz
/usr/share/man/man1/osmium-diff.1.gz
/usr/share/man/man1/osmium-export.1.gz
/usr/share/man/man1/osmium-extract.1.gz
/usr/share/man/man1/osmium-fileinfo.1.gz
/usr/share/man/man1/osmium-getid.1.gz
/usr/share/man/man1/osmium-getparents.1.gz
/usr/share/man/man1/osmium-merge-changes.1.gz
/usr/share/man/man1/osmium-merge.1.gz
/usr/share/man/man1/osmium-renumber.1.gz
/usr/share/man/man1/osmium-show.1.gz
/usr/share/man/man1/osmium-sort.1.gz
/usr/share/man/man1/osmium-tags-filter.1.gz
/usr/share/man/man1/osmium-time-filter.1.gz
/usr/share/man/man1/osmium.1.gz
/usr/share/man/man5/osmium-file-formats.5.gz
/usr/share/man/man5/osmium-index-types.5.gz
/usr/share/zsh/vendor-completions/_osmium

Changelog

2018-12-10 - Bas Couwenberg <sebastic@debian.org>
osmium-tool (1.10.0-1) unstable; urgency=medium
* New upstream release.
* Drop patches, included upstream.
2018-12-10 - Bas Couwenberg <sebastic@debian.org>
osmium-tool (1.9.1-2) unstable; urgency=medium
* Bump Standards-Version to 4.2.1, no changes.
* Add upstream patches to fix FTBFS with libosmium 2.15.0.
(closes: #916109)
* Bump minimum required libosmium2-dev to 2.15.0.
2018-08-18 - Bas Couwenberg <sebastic@debian.org>
osmium-tool (1.9.1-1) unstable; urgency=medium
* New upstream release.
* Drop spelling-errors.patch, applied upstream.
2018-08-12 - Bas Couwenberg <sebastic@debian.org>
osmium-tool (1.9.0-1) unstable; urgency=medium
* New upstream release.
* Bump Standards-Version to 4.2.0, no changes.
* Bump minimum required libosmium2-dev to 2.14.2.
* Update spelling-errors.patch to fix 'described' typo.
* Update watch file to limit matches to archive path.
2018-08-01 - Bas Couwenberg <sebastic@debian.org>
osmium-tool (1.8.0-2) unstable; urgency=medium
* Bump Standards-Version to 4.1.5, no changes.
* Strip trailing whitespace from control & rules files.
* Use filter instead of findstring to prevent partial matches.
* Update osmcode.org URLs to use HTTPS.
* Drop autopkgtest to test installability.
* Add lintian override for testsuite-autopkgtest-missing.
* Add patch to fix spelling errors.
2018-03-31 - Bas Couwenberg <sebastic@debian.org>
osmium-tool (1.8.0-1) unstable; urgency=medium
* New upstream release.
* Update copyright-format URL to use HTTPS.
* Update Vcs-* URLs for Salsa.
* Bump Standards-Version to 4.1.3, no changes.
* Bump minimum required libosmium2-dev to 2.14.0.
* Drop manpages-install.patch, applied upstream.
* Update copyright years for Jochen Topf.
2017-08-26 - Bas Couwenberg <sebastic@debian.org>
osmium-tool (1.7.1-1) unstable; urgency=medium
* New upstream release.
* Bump minimum required libosmium2-dev to 2.13.1.
* Add patch to fix manpage installation.
2017-08-16 - Bas Couwenberg <sebastic@debian.org>
osmium-tool (1.7.0-2) unstable; urgency=medium
* Ignore test failures on mips64el.
2017-08-15 - Bas Couwenberg <sebastic@debian.org>
osmium-tool (1.7.0-1) unstable; urgency=medium
* New upstream release.
* Bump minimum required libosmium2-dev to 2.13.0.
2017-06-25 - Bas Couwenberg <sebastic@debian.org>
osmium-tool (1.6.1-2) unstable; urgency=medium
* Bump Standards-Version to 4.0.0, no changes.
* Add autopkgtest to test installability.

See Also

Package Description
osmo-bsc-bs11-utils_1.3.0-2_amd64.deb Command line utilities for Siemens BS-11 BTS
osmo-bsc-ipaccess-utils_1.3.0-2_amd64.deb Command line utilities for ip.access nanoBTS
osmo-bsc-meas-utils_1.3.0-2_amd64.deb Command line utilities to manage measurement reports
osmo-bsc-mgcp_1.4.0-1_amd64.deb Osmocom's Legacy Media Gateway
osmo-bsc_1.3.0-2_amd64.deb GSM Base Station Controller
osmo-bts_0.8.1-2_amd64.deb Base Transceiver Station for GSM
osmo-fl2k_0.1.0+20180423git9e79bde-2_amd64.deb use a VGA USB adapter as DAC and SDR transmitter
osmo-gbproxy_1.3.0-2_amd64.deb GPRS Gb Interface Proxy
osmo-ggsn_1.2.2-4_amd64.deb Osmocom Gateway GPRS Support Node (GGSN)
osmo-gtphub_1.3.0-2_amd64.deb Proxy for GTP traffic between multiple SGSNs and GGSNs
osmo-hlr_0.2.1-3_amd64.deb Osmocom Home Location Register
osmo-hnbgw_0.3.0-5_amd64.deb osmocom Home Node B Gateway
osmo-libasn1c-dev_0.9.31-2_amd64.deb asn1c runtime code as shared library - development files
osmo-libasn1c0_0.9.31-2_amd64.deb asn1c runtime code as shared library
osmo-mgw_1.4.0-1_amd64.deb Osmocom's Media Gateway for 2G and 3G circuit-switched mobile networks
Advertisement
Advertisement