openwsman_2.6.5-0ubuntu3_amd64.deb


Advertisement

Description

openwsman - Open Web Services Manager

Property Value
Distribution Ubuntu 19.04 (Disco Dingo)
Repository Ubuntu Universe amd64
Package filename openwsman_2.6.5-0ubuntu3_amd64.deb
Package name openwsman
Package version 2.6.5
Package release 0ubuntu3
Package architecture amd64
Package type deb
Category universe/admin
Homepage http://openwsman.github.io/
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 70.11 KB
Installed size 268.00 KB
Openwsman is a project intended to provide an open-source implementation of
the Web Services Management specification (WS-Management) and to expose
system management information on the Linux operating system using the
WS-Management protocol. WS-Management is based on a suite of web services
specifications and usage requirements that exposes a set of operations
focused on and covers all system management aspects.
This package provides a basic WS Manager daemon.

Alternatives

Package Version Architecture Repository
openwsman_2.6.5-0ubuntu3_i386.deb 2.6.5 i386 Ubuntu Universe
openwsman - - -

Requires

Name Value
libc6 >= 2.15
libcimcclient0 -
libpam0g >= 0.99.7.1
libssl1.1 >= 1.1.0
libwsman-server1 -
libwsman1 -

Download

Type URL
Mirror archive.ubuntu.com
Binary Package openwsman_2.6.5-0ubuntu3_amd64.deb
Source Package openwsman

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install openwsman deb package:
    # sudo apt-get install openwsman

Files

Path
/etc/openwsman/openwsman.conf
/etc/openwsman/ssleay.cnf
/etc/pam.d/openwsman
/usr/lib/x86_64-linux-gnu/openwsman/authenticators/libwsman_file_auth.so
/usr/lib/x86_64-linux-gnu/openwsman/authenticators/libwsman_file_auth.so.1
/usr/lib/x86_64-linux-gnu/openwsman/authenticators/libwsman_file_auth.so.1.0.0
/usr/lib/x86_64-linux-gnu/openwsman/authenticators/libwsman_pam_auth.so
/usr/lib/x86_64-linux-gnu/openwsman/authenticators/libwsman_pam_auth.so.1
/usr/lib/x86_64-linux-gnu/openwsman/authenticators/libwsman_pam_auth.so.1.0.0
/usr/lib/x86_64-linux-gnu/openwsman/plugins/libredirect.so
/usr/lib/x86_64-linux-gnu/openwsman/plugins/libredirect.so.1
/usr/lib/x86_64-linux-gnu/openwsman/plugins/libredirect.so.1.0.0
/usr/lib/x86_64-linux-gnu/openwsman/plugins/libwsman_cim_plugin.so
/usr/lib/x86_64-linux-gnu/openwsman/plugins/libwsman_cim_plugin.so.1
/usr/lib/x86_64-linux-gnu/openwsman/plugins/libwsman_cim_plugin.so.1.0.0
/usr/lib/x86_64-linux-gnu/openwsman/plugins/libwsman_identify_plugin.so
/usr/lib/x86_64-linux-gnu/openwsman/plugins/libwsman_identify_plugin.so.1
/usr/lib/x86_64-linux-gnu/openwsman/plugins/libwsman_identify_plugin.so.1.0.0
/usr/lib/x86_64-linux-gnu/openwsman/plugins/libwsman_test.so
/usr/lib/x86_64-linux-gnu/openwsman/plugins/libwsman_test.so.1
/usr/lib/x86_64-linux-gnu/openwsman/plugins/libwsman_test.so.1.0.0
/usr/sbin/openwsmand
/usr/sbin/owsmangencert
/usr/share/doc/openwsman/changelog.Debian.gz
/usr/share/doc/openwsman/copyright
/usr/share/lintian/overrides/openwsman

Changelog

2018-03-10 - Andres Rodriguez <andreserl@ubuntu.com>
openwsman (2.6.5-0ubuntu3) bionic; urgency=medium
* debian/control: breaks/replaces for libwsman-client2.
2018-03-09 - Andres Rodriguez <andreserl@ubuntu.com>
openwsman (2.6.5-0ubuntu2) bionic; urgency=medium
* Fix binary package to reflect the bumped soname from libwsman-client2
to libwsman-client4.
2018-03-08 - Andres Rodriguez <andreserl@ubuntu.com>
openwsman (2.6.5-0ubuntu1) bionic; urgency=medium
* New upstream release
* d/p/fix_with_openssl1.11: Allow build with openssl 1.11 (LP: #1754012)
2014-07-10 - Kent Baxley <kent.baxley@canonical.com>
openwsman (2.4.7-0ubuntu2) utopic; urgency=medium
* Fix typo in control file.  
2014-06-27 - Kent Baxley <kent.baxley@canonical.com>
openwsman (2.4.7-0ubuntu1) utopic; urgency=low
* New upstream release (LP: #1334832) 
2014-06-06 - Kent Baxley <kent.baxley@canonical.com>
openwsman (2.4.3-0ubuntu4.1) trusty-security; urgency=low
* SECURITY UPDATE: Add security fixes from upstream openwsman (LP: #1319089)
- debian/patches/ws-xml-make-default-prefix-buff-overflow-fix.patch:
ws_xml_make_default_prefix() can overflow buf parameter via sprintf()
- debian/patches/wsmc-create-request-fix-buff-overflow.patch:
wsmc_create_request() potential buf[20] overflow via WSMAN_ACTION_RENEW
- debian/patches/LocalSubscriptionOpUpdate-fix-fopen.patch:
address LocalSubscriptionOpUpdate() unchecked fopen()
- debian/patches/wsman-get-fault-status-sanity-guard-fix.patch:
Fix incorrect order of sanity guards in wsman_get_fault_status_from_doc()
- debian/patches/mem-allocation-wsman-init-plugins-fix.patch:
Fix unchecked memory allocation in wsman_init_plugins(), p->ifc
- debian/patches/mem-allocation-mem-double-newptr-fix.patch:
Fix unchecked memory allocation in mem_double(), newptr
- debian/patches/mem-allocation-dictionary-new-fix.patch:
Fix unchecked memory allocation in dictionary_new(), d, d->val, d->key,
d->hash
- debian/patches/mem-allocation-u-error-new-fix.patch:
Fix unchecked memory allocation in u_error_new(), *error
- debian/patches/remove-unsafe-debug-call-from-sighup-handler.patch:
sighup_handler() in wsmand.c use of unsafe functions in a signal handler
- debian/patches/SHA512-password-fixes.patch:
Support SHA512 password encoding, use safe_cmp to prevent brute-force
attacks
- debian/patches/increase-password-upper-limit.patch:
increase password upper limit to 128 characters (from 64)
2014-01-24 - Kent Baxley <kent.baxley@canonical.com>
openwsman (2.4.3-0ubuntu4) trusty; urgency=low
* debian/control: fix the breaks and replaces version numbers 
for libopenwsman1.
2014-01-24 - Kent Baxley <kent.baxley@canonical.com>
openwsman (2.4.3-0ubuntu3) trusty; urgency=low
* debian/control: Added 'Breaks' to each of the new libwsman packages.
* debian/control: Added a libopenwsman1 transitional package.
* clean up control and .install files to remove extra newlines.  
2014-01-23 - Kent Baxley <kent.baxley@canonical.com>
openwsman (2.4.3-0ubuntu2) trusty; urgency=low
* debian/control: convert libopenwsman package into libwsman1,  
libwsman-client2, libwsman-curl-client-transport1. 
* debain/control: break libwsman-server1 into its own package. 
* Fixes ABI breakage for wsmancli (LP: #1272059). 
2014-01-13 - Kent Baxley <kent.baxley@canonical.com>
openwsman (2.4.3-0ubuntu1) trusty; urgency=low
* Sync with upstream 2.4.3 (LP: #1268707)
* debian/control: bump standards version to 3.9.5
* debian/patches: removed cmake-findruby.patch. FTBFS no longer occurs due to
overhauled ruby cmake file upstream.

See Also

Package Description
openyahtzee_1.9.3-2_amd64.deb classic dice game of Yahtzee
opgpcard_0.1.4-1_all.deb tool to create printable business cards including OpenPGP
ophcrack-cli_3.8.0-2_amd64.deb Microsoft Windows password cracker using rainbow tables (cmdline)
ophcrack_3.8.0-2_amd64.deb Microsoft Windows password cracker using rainbow tables (gui)
oping_1.10.0-2.1ubuntu1_amd64.deb sends ICMP_ECHO requests to network hosts
opl3-soundfont_1.0-3_all.deb OPL3 SoundFont that simulates the sound of an OPL3 chip
oprofile_1.2.0-0ubuntu6_amd64.deb system-wide profiler for Linux systems
opt_3.19-1.3build1_amd64.deb Options Parsing Tool library
optcomp_1.6-2build1_amd64.deb syntax extension for optional compilation with cpp-like directives (tools)
optgeo_2.25-1_amd64.deb simulator for geometrical optics
opticalraytracer_3.2-1.1ubuntu1_all.deb Virtual lens design workshop
opus-tools_0.1.10-1_amd64.deb Opus codec command line tools
orage-data_4.12.1-6_all.deb Calendar for Xfce Desktop Environment (data files)
orage_4.12.1-6_amd64.deb Calendar for Xfce Desktop Environment
orbit2-nameserver_2.14.19-4_amd64.deb high-performance CORBA implementation - name server
Advertisement
Advertisement