opendict_0.6.8-1_all.deb


Advertisement

Description

opendict - computer dictionary for several dictionary formats

Property Value
Distribution Ubuntu 19.04 (Disco Dingo)
Repository Ubuntu Universe amd64
Package filename opendict_0.6.8-1_all.deb
Package name opendict
Package version 0.6.8
Package release 1
Package architecture all
Package type deb
Category universe/text
Homepage http://opendict.sourceforge.net/
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 102.26 KB
Installed size 532.00 KB
OpenDict is free cross-platform dictionary program. It works with
DICT, Slowo and Mova dictionaries. It also supports plug-in
dictionaries that may be created for almost any data source.
OpenDict is a client for DICT servers.

Alternatives

Package Version Architecture Repository
opendict_0.6.8-1_all.deb 0.6.8 all Ubuntu Universe
opendict - - -

Requires

Name Value
python-wxgtk3.0 -
python:any >= 2.7.5-5~

Download

Type URL
Mirror archive.ubuntu.com
Binary Package opendict_0.6.8-1_all.deb
Source Package opendict

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install opendict deb package:
    # sudo apt-get install opendict

Files

Path
/usr/bin/opendict
/usr/share/applications/opendict.desktop
/usr/share/doc-base/opendict
/usr/share/doc/opendict/Plugin-HOWTO.html
/usr/share/doc/opendict/changelog.Debian.gz
/usr/share/doc/opendict/copyright
/usr/share/icons/hicolor/24x24/apps/opendict.png
/usr/share/icons/hicolor/32x32/apps/opendict.png
/usr/share/icons/hicolor/48x48/apps/opendict.png
/usr/share/icons/hicolor/96x96/apps/opendict.png
/usr/share/icons/hicolor/scalable/apps/opendict.svg
/usr/share/locale/fr/LC_MESSAGES/opendict.mo
/usr/share/locale/lt/LC_MESSAGES/opendict.mo
/usr/share/locale/ru/LC_MESSAGES/opendict.mo
/usr/share/man/man1/opendict.1.gz
/usr/share/opendict/copying.html
/usr/share/opendict/opendict.py
/usr/share/opendict/lib/__init__.py
/usr/share/opendict/lib/config.py
/usr/share/opendict/lib/dicteditor.py
/usr/share/opendict/lib/dicttype.py
/usr/share/opendict/lib/enc.py
/usr/share/opendict/lib/errortype.py
/usr/share/opendict/lib/history.py
/usr/share/opendict/lib/info.py
/usr/share/opendict/lib/installer.py
/usr/share/opendict/lib/logger.py
/usr/share/opendict/lib/meta.py
/usr/share/opendict/lib/misc.py
/usr/share/opendict/lib/newplugin.py
/usr/share/opendict/lib/parser.py
/usr/share/opendict/lib/plaindict.py
/usr/share/opendict/lib/threads.py
/usr/share/opendict/lib/util.py
/usr/share/opendict/lib/xmltools.py
/usr/share/opendict/lib/extra/__init__.py
/usr/share/opendict/lib/extra/dictclient.py
/usr/share/opendict/lib/extra/dictdlib.py
/usr/share/opendict/lib/extra/html2text.py
/usr/share/opendict/lib/gui/__init__.py
/usr/share/opendict/lib/gui/dictaddwin.py
/usr/share/opendict/lib/gui/dictconnwin.py
/usr/share/opendict/lib/gui/dicteditorwin.py
/usr/share/opendict/lib/gui/errorwin.py
/usr/share/opendict/lib/gui/helpwin.py
/usr/share/opendict/lib/gui/mainwin.py
/usr/share/opendict/lib/gui/miscwin.py
/usr/share/opendict/lib/gui/pluginwin.py
/usr/share/opendict/lib/gui/prefswin.py
/usr/share/opendict/lib/gui/registerwin.py
/usr/share/opendict/pixmaps/hide.png
/usr/share/opendict/pixmaps/icon-24x24.png
/usr/share/opendict/pixmaps/icon-32x32.png
/usr/share/opendict/pixmaps/icon-32x32.xpm
/usr/share/opendict/pixmaps/icon-48x48.png
/usr/share/opendict/pixmaps/icon-96x96.png
/usr/share/opendict/pixmaps/left.png
/usr/share/opendict/pixmaps/opendict-logo.png
/usr/share/opendict/pixmaps/right.png
/usr/share/opendict/pixmaps/stop.png
/usr/share/opendict/pixmaps/unhide.png
/usr/share/python/runtime.d/opendict.rtupdate

Changelog

2017-11-28 - Daniel Echeverry <epsilon77@gmail.com>
opendict (0.6.8-1) unstable; urgency=medium
* QA Upload.
* New upstream release.
* debian/control
+ Bump standard versions 4.1.1
+ Use HTTPS in Link to copyright format.
+ Remove version depends from python.
+ Change debhelper to 10 in B-D.
+ Remove X-Python-Version field.
* debian/compat
+ Switch compat level 9 to 10.
* debian/changelog
+ Remove trailing whitespaces.
* debian/watch
+ Use HTTPS in url.
2016-04-30 - Daniel Echeverry <epsilon77@gmail.com>
opendict (0.6.7-1) unstable; urgency=medium
* QA Upload
* New upstream release
* debian/control
+ Bump standard versions 3.9.8 (no changes)
+ Change debhelper to 9 in B-D
+ Add dh-python in B-D
* debian/compat
+ Switch compat level 7 to 9
* debian/patches
+ Remove fix-desktop-file.patch
+ Merge with upstream
* Remove menu file
* debian/dirs
+ Remove some directories because aren't necessary
* Add opendict.manpages file
* debian/rules
+ Migrate to dh tiny rules
2015-07-15 - Julián Moreno Patiño <julian@debian.org>
opendict (0.6.6-1) unstable; urgency=medium
* QA upload.
* New upstream release.
* Remove wxpy3.0-compat.patch patch,
merge with upstream.
* Add fix-desktop-file.patch to fix
desktop file issues.
* Add doc-base documentation.
* Update copyright to copyright-format 1.0.
2014-10-21 - Olly Betts <olly@survex.com>
opendict (0.6.5-3) unstable; urgency=low
* QA upload.
* "Standards-Version: 3.9.6" - no changes required.
* debian/patches/wxpy3.0-compat.patch:
- Fix deprecation warning.
- Fix assertion upon opening preferences dialog.
- Hard require wxPython 3.0 for simplicity (jessie no longer has 2.8).
2014-08-07 - Olly Betts <olly@survex.com>
opendict (0.6.5-2) unstable; urgency=medium
* QA upload.
* "Standards-Version: 3.9.5" - no changes required.
* debian/control,debian/copyright: Update upstream homepage URL.
* debian/copyright: Refer to /usr/share/common-licenses/GPL-2 rather than
/usr/share/common-licenses/GPL.
2014-08-07 - Olly Betts <olly@survex.com>
opendict (0.6.5-1) unstable; urgency=medium
* QA upload.
* New upstream release:
+ All our patches were applied upstream, so drop them.
* Update to depend on python-wxgtk3.0 rather than python-wxgtk2.8.
* New patch for wxpython 3.0 compatibility: wxpy3.0-compat.patch
2013-05-09 - Sebastian Ramacher <sramacher@debian.org>
opendict (0.6.3-4) unstable; urgency=low
* QA upload.
[ Kęstutis Biliūnas ]
* Switched to 3.0 (quilt) source format. As a consequence, no longer
build-depend on quilt.
* debian/control:
- switched to debhelper v7;
- add ${misc:Depends} to dependencies to properly cope with
debhelper-triggerred dependencies;
- bumped Standards-Version to 3.8.4. No changes required.
* debian/rules: replaced deprecated calls to 'dh_clean -k' by dh_prep.
* debian/patches:
- the missing ChangeLog file converted to the patch 006_ChangeLog.diff;
- added the patch 007_replace_string_exceptions.diff for not using string
exceptions, not supported by Python 2.6 (closes: #585264);
- added the temporary patch 999_changes_in_po_files.diff.
[ Stéphane Graber ]
* Convert from pycentral to dh_python2
- debian/pycompat: Removed (no longer needed)
- debian/rules: Replace dh_pycenral by dh_python2
- debian/control
+ Drop XS-Python-Version
+ Drop python-central from build-depends
+ Replace build-depends on python-all-dev to python >= 2.6.6-3~
+ Drop XB-Python-Version from binary package
[ Sebastian Ramacher ]
* Orphan package (see #704970).
* Acknowledge NMU from Olly Betts.
* debian/rules:
- Add build-arch and build-indep targets.
* debian/control:
- Bump Standards-Version to 3.9.4.

See Also

Package Description
opendkim-tools_2.11.0~alpha-12_amd64.deb Set of command line tools for OpenDKIM
opendkim_2.11.0~alpha-12_amd64.deb Milter implementation of DomainKeys Identified Mail
opendmarc_1.3.2-6_amd64.deb Milter implementation of DMARC
opendnssec-common_2.1.3-3_all.deb common configuration files for OpenDNSSEC suite
opendnssec-doc_2.1.3-3_all.deb documentation for OpenDNSSEC suite
opendnssec-enforcer-mysql_2.1.3-3_amd64.deb tool to prepare DNSSEC keys (MySQL backend)
opendnssec-enforcer-sqlite3_2.1.3-3_amd64.deb tool to prepare DNSSEC keys (sqlite3 backend)
opendnssec-enforcer_2.1.3-3_all.deb tool to prepare DNSSEC keys (common package)
opendnssec-signer_2.1.3-3_amd64.deb daemon to sign DNS zone files periodically
opendnssec_2.1.3-3_all.deb dependency package to install full OpenDNSSEC suite
opendrim-lmp-baseserver_1.1.2-0ubuntu2_amd64.deb OpenDRIM Base Server provider
opendrim-lmp-battery_1.0.0-0ubuntu2_amd64.deb OpenDRIM Battery provider
opendrim-lmp-boot_0.1.0-0ubuntu2_amd64.deb OpenDRIM Boot provider
opendrim-lmp-cpu_1.1.0-0ubuntu2_amd64.deb OpenDRIM CPU provider
opendrim-lmp-dhcp_1.0.0-0ubuntu2_amd64.deb OpenDRIM DHCP provider
Advertisement
Advertisement