opendbx-utils_1.4.6-13build1_amd64.deb


Advertisement

Description

opendbx-utils - Utility applications using libopendbx

Property Value
Distribution Ubuntu 19.04 (Disco Dingo)
Repository Ubuntu Universe amd64
Package filename opendbx-utils_1.4.6-13build1_amd64.deb
Package name opendbx-utils
Package version 1.4.6
Package release 13build1
Package architecture amd64
Package type deb
Category universe/libs
Homepage http://www.linuxnetworks.de/doc/index.php/OpenDBX
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 55.59 KB
Installed size 240.00 KB
OpenDBX provides a simple and lightweight API for interfacing native
relational database APIs in a consistent way. By using the OpenDBX API you
don't have to adapt your program to the different database APIs by yourself.
This package provides the odbx-sql utility application for accessing database
content directly via libopendbx and the opendbx test suite for verifying that
various backends are working

Alternatives

Package Version Architecture Repository
opendbx-utils_1.4.6-13build1_i386.deb 1.4.6 i386 Ubuntu Universe
opendbx-utils - - -

Requires

Name Value
libc6 >= 2.14
libgcc1 >= 1:3.0
libopendbx1 >= 1.4.6-13build1
libreadline8 >= 6.0
libstdc++6 >= 5.2

Provides

Name Value
opendbx-utils -

Download

Type URL
Mirror archive.ubuntu.com
Binary Package opendbx-utils_1.4.6-13build1_amd64.deb
Source Package libopendbx

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install opendbx-utils deb package:
    # sudo apt-get install opendbx-utils

Files

Path
/usr/bin/odbx-sql
/usr/bin/odbxplustest
/usr/bin/odbxtest
/usr/bin/odbxtest.master
/usr/share/doc/opendbx-utils
/usr/share/doc/opendbx/odbxtest.site
/usr/share/locale/de/LC_MESSAGES/opendbx-utils.mo
/usr/share/locale/en@quot/LC_MESSAGES/opendbx-utils.mo
/usr/share/man/man1/odbx-sql.1.gz
/usr/share/opendbx/keywords

Changelog

2019-01-14 - Matthias Klose <doko@ubuntu.com>
libopendbx (1.4.6-13build1) disco; urgency=medium
* No-change rebuild for readline soname change.
2018-12-13 - Scott Kitterman <scott@kitterman.com>
libopendbx (1.4.6-13) unstable; urgency=medium
[ Scott Kitterman ]
* Orphan the package, see #916331
- Set maintainer to Debian QA Group
- Remove Marc Haber and myself from uploaders
* Update symbols from build logs 
[ Ondřej Nový ]
* d/rules: Remove trailing whitespaces
2018-06-04 - Scott Kitterman <scott@kitterman.com>
libopendbx (1.4.6-12) unstable; urgency=medium
* Update maintainer address due to demise of alioth (Closes: #899584)
* Update Vcs-* for move to salsa
* Bump standards-version to 4.1.4 without further change
* Delete incorrect built-using field for libopendbx-doc
* Mark libopendbx-doc Multi-Arch: foreign
* Install pkg-config file in cross-compilation friendly location
2016-10-20 - Scott Kitterman <scott@kitterman.com>
libopendbx (1.4.6-11) unstable; urgency=medium
* Wrap and sort
* Build depend on firebird-dev instead of firebird2.5-dev (Closes: #841469)
* Build depend on default-libmysqlclient-dev insted of libmysqlclient-dev
2016-07-15 - Scott Kitterman <scott@kitterman.com>
libopendbx (1.4.6-10) unstable; urgency=medium
* Update debian/rules to allow for arch and indep only builds to succeed
(Closes: #806060)
* Bump standards version to 3.9.8 without further change
2015-08-03 - Scott Kitterman <scott@kitterman.com>
libopendbx (1.4.6-9) unstable; urgency=medium
* Update libopendbx1.symbols for g++5 transition (Closes: #777962)
- Symbols are lost/gained for the C++ portion of the library, but nothing
in Debian uses them, so not bumping library name
* Add rm of additional build artifacts (doc/doxygen_sqlite3.db and
utils/doc/odbx-sql.1) to clean rule so package builds twice in a row
* Update mechanism in debian/rules for adding dpkg-gensymbols from pkg-kde-
tools to the path
* Bump standards version to 3.9.6 without further change
2014-09-05 - Scott Kitterman <scott@kitterman.com>
libopendbx (1.4.6-8) unstable; urgency=medium
* Switch to source format 3.0 (quilt) since patches stopped being applied on
the buildds for some reason
- Update debian/rules
- Remove quilt portions of debian/README.Source
- Update build-depends
2014-09-05 - Scott Kitterman <scott@kitterman.com>
libopendbx (1.4.6-7) unstable; urgency=medium
* Fix FTBFS due to incompatible change in doxygen 1.8.8 (Closes: #759951)
- Add symlink from lib/opendbx/api to lib/opendbx/api.dox in debian/rules
so the correct FileParser is used without having to rewrite the opendbx
makefiles to work with a new filename.
- Remove the symlink in clean
- Add debian/patches/inputname.diff to change the INPUT file name in doc/
Doxyfile.in to use api.dox and upgrade using doxygen -u
2014-06-14 - Scott Kitterman <scott@kitterman.com>
libopendbx (1.4.6-6) unstable; urgency=medium
[ Xilin Sun ]
* Update libopenbx1.symbols to fix ftbfs with GCC-4.9 (Closes: #746868)
[ Scott Kitterman ]
* Add mips64 mips64el specific symbols changes (Closes: #746267)
2014-03-19 - Scott Kitterman <scott@kitterman.com>
libopendbx (1.4.6-5) unstable; urgency=medium
* Confirm symbols on all archs
* Capture unforwarded change from Ubuntu to use dh-autoreconf
* Update for symbols on Debian and Ubuntu ports (alpha, arm64, ppc64,
ppc64el, and sparc64)
* Update standards version to 3.9.5 without further change

See Also

Package Description
opendict_0.6.8-1_all.deb computer dictionary for several dictionary formats
opendkim-tools_2.11.0~alpha-12_amd64.deb Set of command line tools for OpenDKIM
opendkim_2.11.0~alpha-12_amd64.deb Milter implementation of DomainKeys Identified Mail
opendmarc_1.3.2-6_amd64.deb Milter implementation of DMARC
opendnssec-common_2.1.3-3_all.deb common configuration files for OpenDNSSEC suite
opendnssec-doc_2.1.3-3_all.deb documentation for OpenDNSSEC suite
opendnssec-enforcer-mysql_2.1.3-3_amd64.deb tool to prepare DNSSEC keys (MySQL backend)
opendnssec-enforcer-sqlite3_2.1.3-3_amd64.deb tool to prepare DNSSEC keys (sqlite3 backend)
opendnssec-enforcer_2.1.3-3_all.deb tool to prepare DNSSEC keys (common package)
opendnssec-signer_2.1.3-3_amd64.deb daemon to sign DNS zone files periodically
opendnssec_2.1.3-3_all.deb dependency package to install full OpenDNSSEC suite
opendrim-lmp-baseserver_1.1.2-0ubuntu2_amd64.deb OpenDRIM Base Server provider
opendrim-lmp-battery_1.0.0-0ubuntu2_amd64.deb OpenDRIM Battery provider
opendrim-lmp-boot_0.1.0-0ubuntu2_amd64.deb OpenDRIM Boot provider
opendrim-lmp-cpu_1.1.0-0ubuntu2_amd64.deb OpenDRIM CPU provider
Advertisement
Advertisement