opari2_2.0.4-1_amd64.deb


Advertisement

Description

opari2 - OpenMP Pragma And Region Instrumentor - translation tool

Property Value
Distribution Ubuntu 19.04 (Disco Dingo)
Repository Ubuntu Universe amd64
Package filename opari2_2.0.4-1_amd64.deb
Package name opari2
Package version 2.0.4
Package release 1
Package architecture amd64
Package type deb
Category universe/devel
Homepage http://www.vi-hps.org/Tools/OPARI2.html
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 90.93 KB
Installed size 263.00 KB
OPARI2 is a source-to-source translation tool which automatically adds all
necessary calls to the pomp runtime measurement library which allows one to
collect runtime performance data of Fortran, C, or C++ OpenMP applications.
This is the successor of opari (1), with a completely reworked API
This package contains the translation tool.

Alternatives

Package Version Architecture Repository
opari2_2.0.4-1_i386.deb 2.0.4 i386 Ubuntu Universe
opari2 - - -

Requires

Name Value
libc6 >= 2.14
libgcc1 >= 1:3.0
libpomp2-dev -
libstdc++6 >= 5.2

Download

Type URL
Mirror archive.ubuntu.com
Binary Package opari2_2.0.4-1_amd64.deb
Source Package opari2

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install opari2 deb package:
    # sudo apt-get install opari2

Files

Path
/usr/bin/opari2
/usr/share/doc/opari2/changelog.Debian.gz
/usr/share/doc/opari2/copyright
/usr/share/man/man1/opari2.1.gz

Changelog

2018-10-20 - Samuel Thibault <sthibault@debian.org>
opari2 (2.0.4-1) unstable; urgency=medium
[ Samuel Thibault ]
* New upstream release.
* control: Bump Standards-Version to 4.2.0 (no changes).
* tests: Add autopkgtest.
* control: Mark libpomp2-doc Multi-Arch: foreign.
[ Chris Lamb ]
* rules: Make the build reproducible.
[ Ondřej Nový ]
* d/control: Set Vcs-* to salsa.debian.org
2018-06-17 - Samuel Thibault <sthibault@debian.org>
opari2 (2.0.3-1) unstable; urgency=medium
* New upstream release.
- patches/POMP2_Section_end_MALLOC_PERTURB_.diff: Remove, fixed upstream.
- patches/reproducible: Remove, fixed upstream.
2018-04-29 - Samuel Thibault <sthibault@debian.org>
opari2 (2.0.2-4) unstable; urgency=medium
[ Chris Lamb]
* Make build reproducible (Closes: Bug#891412).
[ Samuel Thibault ]
* Bump Standards-Version to 4.1.4 (no changes).
2017-11-05 - Samuel Thibault <sthibault@debian.org>
opari2 (2.0.2-3) unstable; urgency=medium
* Restore building on non-Linux ports (Closes: #880672)
2017-11-03 - Samuel Thibault <sthibault@debian.org>
opari2 (2.0.2-2) unstable; urgency=medium
* patches/POMP2_Section_end_MALLOC_PERTURB_.diff: Update fix.
2017-11-02 - Samuel Thibault <sthibault@debian.org>
opari2 (2.0.2-1) unstable; urgency=medium
[ Andreas Beckman ]
* New upstream release.
* Use canonical https:// URLs.
* Switch to debhelper compat level 10.
[ Samuel Thibault ]
* New upstream release.
* Use canonical anonscm vcs URL.
* control: Migrate priority to optional.
* control: Bump Standards-Version to 4.1.1.
* patches/POMP2_Section_end_MALLOC_PERTURB_.diff: Fix allocation liveness
issue.
* rules, control: Use libjs-jquery.
2016-09-04 - Samuel Thibault <sthibault@debian.org>
opari2 (1.0.7+dfsg-6) unstable; urgency=medium
* Bump Standards-Version to 3.9.8 (no changes).
* compat: Bump to 9.
* rules: Clear.
* control: Drop hardening-wrapper dependency (Closes: Bug#836641).
2014-08-22 - Samuel Thibault <sthibault@debian.org>
opari2 (1.0.7+dfsg-5) unstable; urgency=medium
* Fix watch file.
* Use autoreconf.
2014-05-21 - Samuel Thibault <sthibault@debian.org>
opari2 (1.0.7+dfsg-4) unstable; urgency=medium
* Really use autotools-dev (Closes: #748820)
2014-05-19 - Samuel Thibault <sthibault@debian.org>
opari2 (1.0.7+dfsg-3) unstable; urgency=low
* Bump Standards-Version to 3.9.5 (no changes).
* Use autotools-dev (Closes: #748511)

See Also

Package Description
opari_1.1+dfsg-7_amd64.deb OpenMP Pragma And Region Instrumentor - translation tool
open-adventure_1.4+git20170917.0.d512384-2_amd64.deb colossal cave adventure, the 1995 430-point version
open-cobol_2.2-5_all.deb transitional dummy package for gnucobol
open-font-design-toolkit_1.7_all.deb metapackage for open font design
open-infrastructure-apache-icons_20190301-lts1-1_all.deb Additional utilities for Apache (transitional package)
open-infrastructure-apache-tools_20190301-lts1-1_all.deb Additional utilities for Apache
open-infrastructure-ceph-tools_20190301-lts1-1_all.deb Additional utilities to manage Ceph
open-infrastructure-container-tools_20190301-lts1-2_all.deb manage systemd-nspawn containers
open-infrastructure-storage-tools_20190301-lts1-1_all.deb Additional utilities to manage Ceph (transitional package)
open-infrastructure-system-boot_20190301-lts1-1_all.deb Boot Debian-based system images
open-infrastructure-system-build_20190301-lts1-1_all.deb Build Debian-based system images
open-infrastructure-system-config_20190301-lts1-1_all.deb Configure Debian-based system images
open-infrastructure-system-images_20190301-lts1-1_all.deb Debian-based system images
open-invaders-data_0.3-4.3_all.deb Space Invaders clone (data package)
open-invaders_0.3-4.3_amd64.deb Space Invaders clone
Advertisement
Advertisement