omniidl-python_4.2.2-0.2build2_all.deb


Advertisement

Description

omniidl-python - omniidl backend to compile Python stubs from IDL files

Property Value
Distribution Ubuntu 19.04 (Disco Dingo)
Repository Ubuntu Universe amd64
Package filename omniidl-python_4.2.2-0.2build2_all.deb
Package name omniidl-python
Package version 4.2.2
Package release 0.2build2
Package architecture all
Package type deb
Category universe/python
Homepage http://omniorb.sourceforge.net
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 17.01 KB
Installed size 105.00 KB
omniORB4 is a freely available Common Object Request Broker
Architecture (CORBA) 2.6 compliant object request broker (ORB)
implementation. It is based on the IIOP communications
protocol and should be interoperable with any other
CORBA 2.6 compliant ORB.
This includes the Python backend for omniidl to compile IDL to
Python stubs.

Alternatives

Package Version Architecture Repository
omniidl-python_4.2.2-0.2build2_all.deb 4.2.2 all Ubuntu Universe
omniidl-python - - -

Requires

Name Value
omniidl -

Download

Type URL
Mirror archive.ubuntu.com
Binary Package omniidl-python_4.2.2-0.2build2_all.deb
Source Package python-omniorb

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install omniidl-python deb package:
    # sudo apt-get install omniidl-python

Files

Path
/usr/lib/omniidl/omniidl_be/python.py
/usr/share/doc/omniidl-python/changelog.Debian.gz
/usr/share/doc/omniidl-python/copyright

Changelog

2018-10-30 - Matthias Klose <doko@ubuntu.com>
python-omniorb (4.2.2-0.2build2) disco; urgency=medium
* No-change rebuild to build for python3.7 as the default.
2018-06-28 - Matthias Klose <doko@ubuntu.com>
python-omniorb (4.2.2-0.2build1) cosmic; urgency=medium
* No-change rebuild to build for python3.7.
2018-06-04 - Emilio Pozuelo Monfort <pochu@debian.org>
python-omniorb (4.2.2-0.2) unstable; urgency=medium
* Non-maintainer upload.
* Upload to unstable.
2018-02-07 - Matthias Klose <doko@debian.org>
python-omniorb (4.2.2-0.1) experimental; urgency=medium
* Non-maintainer upload.
* New upstream version.
* Bump standards and debhelper versions.
2011-11-28 - Thomas Girard <thomas.g.girard@free.fr>
python-omniorb (3.6-1) unstable; urgency=low
[ Floris Bruynooghe ]
* New upstream release
* debian/patches/pythonpath: modified, mostly obsolte by new release.
* debian/patches/dist-packages__init__: removed, applied upstream.
* debian/control:
- add ${python:Depends} to python-omniorb-omg's Depends' line,
thanks Jakub Wilk (Closes: #642465).
- add ${shlibs:Depends} to python-omniorb-dbg
* debian/rules: add build-arch and build-indep targets.
[ Thomas Girard ]
* debian/control: Add DM-Upload-Allowed: yes.
2011-06-14 - Thomas Girard <thomas.g.girard@free.fr>
python-omniorb (3.5-3) unstable; urgency=low
[ Floris Bruynooghe ]
* debian/patches/dist-packages__init__: patch to stop shipping __init__.py
into dist-packages (Closes: #629352).
[ Thomas Girard ]
* debian/control: update with new Alioth URLs.
2011-05-01 - Floris Bruynooghe <flub@devork.be>
python-omniorb (3.5-2) unstable; urgency=low
* debian/omniidl-python.install: fix bug exposed by python2.5
removal (thanks Jakub Wilk for patch) (closes: #624740)
* debian/control: bump standards version to 3.9.2, no changes needed.
2011-04-08 - Thomas Girard <thomas.g.girard@free.fr>
python-omniorb (3.5-1) unstable; urgency=low
[ Floris Bruynooghe ]
* New upstream release
* debian/python-omniorb-doc.docs, debian/python-omniorb-doc.doc-base:
remove .ps documentation, dropped by upstream.
* Change to dpkg-source format 3.0 (quilt).
* Add XB-Python-Version to python-omniorb-dbg.
* Bump Standars-Version to 3.9.1: no changes needed.
* debian/control: make python-omniorb-dbg recommend python-dbg.
* Bump debhelper compat level to 7 due to auto debian/tmp prefix usage.
* Convert to use dh_python2 (closes: #617015):
- install omniidl python backed to /usr/lib/omniidl/omniidl_be.
* Use dh_prep instead of dh_clean -k.
* Remove conflicts and provides of old packages now that those packages are
no longer in stable.
* Change Recommends of omniidl-python to python-omniorb instead of
libomniorb4-dev.
* Remove usused python:Provides as per python policy.
* Correct examples of modifying PYTHONPATH (closes: #605188)
[ Thomas Girard ]
* Remove obsolete Build-Conflicts: in debian/control.
2010-01-10 - Floris Bruynooghe <floris.bruynooghe@gmail.com>
python-omniorb (3.3-1) unstable; urgency=low
* New upstream release
* Bump Standards-Version to 3.8.3, no changes needed.
* Drop transitional packages, they've made it into a stable release.
* Let python-omniorb-omg conflict with python-pyorbit-omg (Closes: #550629).
* Add ${misc:Depends} to all packages.
* Add -dbg package for the extension modules.
2008-05-12 - Floris Bruynooghe <floris.bruynooghe@gmail.com>
python-omniorb (3.2-2) unstable; urgency=low
* Rename omniidl4-python to omniidl-python in line with the omniorb4
binary packages, provide transitional package.
* Depend on python-central >= 0.6.0 and remove #452227 workaround.
* Depend on omniorb-idl and omniidl >= 4.1.2-2.
* Add python-omniorb-doc to include HTML, PDF and PS documentation,
move examples into this package.
* Bump debhelper compat level to 6, no changes.

See Also

Package Description
omniidl_4.2.2-0.9build1_amd64.deb omniORB IDL to C++ and Python compiler
omniorb-doc_4.2.2-0.9build1_all.deb omniORB documentation
omniorb-idl_4.2.2-0.9build1_all.deb omniORB CORBA services idl files
omniorb-nameserver_4.2.2-0.9build1_amd64.deb omniORB naming service
omniorb_4.2.2-0.9build1_amd64.deb IOR and naming service utilities for omniORB
ompl-demos_1.4.2+ds1-1_all.deb Open Motion Planning Library (OMPL) demos
ompl-plannerarena_1.4.2+ds1-1_all.deb Open Motion Planning Library (OMPL) plannerarena
onak_0.5.0-1_amd64.deb OpenPGP Key Server
onboard-common_1.4.1-2ubuntu4_all.deb Simple On-screen Keyboard (common files)
onboard-data_1.4.1-2ubuntu4_all.deb Language model files for the word suggestion feature of Onboard
onboard_1.4.1-2ubuntu4_amd64.deb Simple On-screen Keyboard
ondir_0.2.3+git0.55279f03-1_amd64.deb Automate tasks specific to certain directories in the shell
onedrive_2.2.5-1build1_amd64.deb folder synchronization with OneDrive
oneisenough_0.40-4_all.deb 2D platform game about the epic struggle of balls
oneko_1.2.sakura.6-14_amd64.deb cat chases the cursor (now a mouse) around the screen
Advertisement
Advertisement