olsrd-plugins_0.6.6.2-1ubuntu1_amd64.deb


Advertisement

Description

olsrd-plugins - various plugins to enhance olsrd

Property Value
Distribution Ubuntu 19.04 (Disco Dingo)
Repository Ubuntu Universe amd64
Package filename olsrd-plugins_0.6.6.2-1ubuntu1_amd64.deb
Package name olsrd-plugins
Package version 0.6.6.2
Package release 1ubuntu1
Package architecture amd64
Package type deb
Category universe/net
Homepage http://olsr.org/
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 170.29 KB
Installed size 644.00 KB
olsrd is an implementation of the Optimized Link State Routing protocol
for Mobile Ad-Hoc networks(MANET)
The following plugins are available:
* httpinfo      - tiny webserver for information purposes
* dyn_gw        - dynamically announce uplinks
* dot_draw      - generates output (over a TCP socket) in the dot format
* secure        - secure OLSR routing with a shared key
* nameservice   - announce hostnames and dns servers
* bmf           - basic multicast forwarding
* quagga        - import external routes from quagga
* txtinfo       - display information about the OSLR node
The following plugins are also included, even though experimental and demo
plugins:
* pgraph        - performance graph
* watchdog      - detection of olsrd freeze
* tas           - tiny application server
* mini          - minimal example plugin (demo)
* dyn_gw_plain  - dyn_gw without ping/libthread
* arprefresh    - optimize kernel arp cache from olsr UDP sniffing
* mdnsp         - multicast DNS via OLSR mesh network
* p2pd          - distribute P2P Discovery messages

Alternatives

Package Version Architecture Repository
olsrd-plugins_0.6.6.2-1ubuntu1_i386.deb 0.6.6.2 i386 Ubuntu Universe
olsrd-plugins - - -

Requires

Name Value
libc6 >= 2.15
olsrd = 0.6.6.2-1ubuntu1

Download

Type URL
Mirror archive.ubuntu.com
Binary Package olsrd-plugins_0.6.6.2-1ubuntu1_amd64.deb
Source Package olsrd

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install olsrd-plugins deb package:
    # sudo apt-get install olsrd-plugins

Files

Path
/usr/lib/olsrd/libOlsrdPudWireFormat.so
/usr/lib/olsrd/libOlsrdPudWireFormat.so.1.1.0
/usr/lib/olsrd/libnmea.so
/usr/lib/olsrd/libnmea.so.1.0.4
/usr/lib/olsrd/olsrd_arprefresh.so.0.1
/usr/lib/olsrd/olsrd_bmf.so.1.7.0
/usr/lib/olsrd/olsrd_dot_draw.so.0.3
/usr/lib/olsrd/olsrd_dyn_gw.so.0.5
/usr/lib/olsrd/olsrd_dyn_gw_plain.so.0.4
/usr/lib/olsrd/olsrd_httpinfo.so.0.1
/usr/lib/olsrd/olsrd_jsoninfo.so.0.0
/usr/lib/olsrd/olsrd_mdns.so.1.0.1
/usr/lib/olsrd/olsrd_mini.so.0.1
/usr/lib/olsrd/olsrd_nameservice.so.0.3
/usr/lib/olsrd/olsrd_p2pd.so.0.1.0
/usr/lib/olsrd/olsrd_pgraph.so.1.1
/usr/lib/olsrd/olsrd_pud.so.1.1.0
/usr/lib/olsrd/olsrd_quagga.so.0.2.2
/usr/lib/olsrd/olsrd_secure.so.0.6
/usr/lib/olsrd/olsrd_sgwdynspeed.so.1.0.0
/usr/lib/olsrd/olsrd_txtinfo.so.0.1
/usr/lib/olsrd/olsrd_watchdog.so.0.1
/usr/share/doc/olsrd/olsrd.pud.position.conf
/usr/share/doc/olsrd/olsrd.sgw.speed.conf
/usr/share/doc/olsrd-plugins/README.gz
/usr/share/doc/olsrd-plugins/README_ARPREFRESH
/usr/share/doc/olsrd-plugins/README_BMF
/usr/share/doc/olsrd-plugins/README_DOT_DRAW
/usr/share/doc/olsrd-plugins/README_DYN_GW.gz
/usr/share/doc/olsrd-plugins/README_DYN_GW_PLAIN
/usr/share/doc/olsrd-plugins/README_HTTPINFO
/usr/share/doc/olsrd-plugins/README_MINI
/usr/share/doc/olsrd-plugins/README_NAMESERVICE
/usr/share/doc/olsrd-plugins/README_PGRAPH
/usr/share/doc/olsrd-plugins/README_QUAGGA
/usr/share/doc/olsrd-plugins/README_SECURE
/usr/share/doc/olsrd-plugins/README_TXTINFO
/usr/share/doc/olsrd-plugins/README_WATCHDOG
/usr/share/doc/olsrd-plugins/changelog.Debian.gz
/usr/share/doc/olsrd-plugins/copyright

Changelog

2014-09-11 - Matthias Klose <doko@ubuntu.com>
olsrd (0.6.6.2-1ubuntu1) utopic; urgency=medium
* Build using -fPIC everywhere except on ix86.
2014-06-08 - Roland Stigge <stigge@antcom.de>
olsrd (0.6.6.2-1) unstable; urgency=medium
* New upstream release
* debian/control: Standards-Version: 3.9.5
2013-10-25 - Roland Stigge <stigge@antcom.de>
olsrd (0.6.6.1-1) unstable; urgency=low
* New upstream release
2013-04-01 - Hans-Christoph Steiner <hans@eds.org>
olsrd (0.6.5.2-1~) experimental; urgency=low
* New upstream release
* remove patches that have been included or obsoleted upstream
* update build process based on upstream changes
2013-03-27 - Hans-Christoph Steiner <hans@eds.org>
olsrd (0.6.3-6) unstable; urgency=low
* include upstream fix for brokenness on amd64 (Closes: #704025)
2012-10-05 - Hans-Christoph Steiner <hans@eds.org>
olsrd (0.6.3-5) unstable; urgency=low
* fixed build system so all hardening flags are applied
* fixed some lintian warnings
* make tas plugin build against Debian's lua rather than the lua sources
that are included in the olsrd orig tarball
2012-07-06 - Roland Stigge <stigge@antcom.de>
olsrd (0.6.3-4) unstable; urgency=low
* debian/rules: Drop OS=linux from the make call, fixing FTBFS on !linux,
thanks to Evgeni Golov (Closes: #679761)
2012-06-30 - Hans-Christoph Steiner <hans@eds.org>
olsrd (0.6.3-3) unstable; urgency=low
* update broken jsoninfo plugin with patches from upstream git
* updated default config based on settings from funkfeuer and
commotionwireless.net
2012-06-24 - Roland Stigge <stigge@antcom.de>
olsrd (0.6.3-2) unstable; urgency=low
* Re-upload to unstable
2012-06-08 - Roland Stigge <stigge@antcom.de>
olsrd (0.6.3-1) experimental; urgency=low
* New upstream release
* debian/control: Standards-Version: 3.9.3

See Also

Package Description
olsrd_0.6.6.2-1ubuntu1_amd64.deb optimized link-state routing daemon (unik-olsrd)
omake-doc_0.9.8.5-3-9build4_all.deb documentation for OMake
omake_0.9.8.5-3-9build4_amd64.deb build system with automated dependency analysis
omega-rpg_0.90-pa9-16build1_amd64.deb text-based roguelike game
omegat_3.6.0.10+dfsg-1_all.deb Computer Assisted Translation (CAT) tool
omhacks_0.16-1_amd64.deb command line interface to OpenMoko hardware
omins_0.2.0-7.1ubuntu2_amd64.deb collection of LADSPA plugins aimed at modular synthesizers
omnievents-doc_2.6.2-5build1_all.deb omniORB event service documentation
omnievents_2.6.2-5build1_amd64.deb omniORB event service
omniidl-python_4.2.2-0.2build2_all.deb omniidl backend to compile Python stubs from IDL files
omniidl_4.2.2-0.9build1_amd64.deb omniORB IDL to C++ and Python compiler
omniorb-doc_4.2.2-0.9build1_all.deb omniORB documentation
omniorb-idl_4.2.2-0.9build1_all.deb omniORB CORBA services idl files
omniorb-nameserver_4.2.2-0.9build1_amd64.deb omniORB naming service
omniorb_4.2.2-0.9build1_amd64.deb IOR and naming service utilities for omniORB
Advertisement
Advertisement