ogre-1.9-tools_1.9.0+dfsg1-12_amd64.deb


Advertisement

Description

ogre-1.9-tools - 3D Object-Oriented Graphics Rendering Engine (tools)

Property Value
Distribution Ubuntu 19.04 (Disco Dingo)
Repository Ubuntu Universe amd64
Package filename ogre-1.9-tools_1.9.0+dfsg1-12_amd64.deb
Package name ogre-1.9-tools
Package version 1.9.0+dfsg1
Package release 12
Package architecture amd64
Package type deb
Category universe/devel
Homepage https://ogre3d.org/
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 93.46 KB
Installed size 378.00 KB
OGRE (Object-Oriented Graphics Rendering Engine) is a scene-oriented, flexible
3D engine written in C++ designed to make it easier and more intuitive for
developers to produce applications utilising hardware-accelerated 3D
graphics. The class library abstracts all the details of using the underlying
system libraries like Direct3D and OpenGL and provides an interface based on
world objects and other intuitive classes.
This package contains tools used to convert from and to OGRE's native mesh
format.

Alternatives

Package Version Architecture Repository
ogre-1.9-tools_1.9.0+dfsg1-12_i386.deb 1.9.0+dfsg1 i386 Ubuntu Universe
ogre-1.9-tools - - -

Requires

Name Value
libboost-system1.67.0 -
libc6 >= 2.14
libgcc1 >= 1:3.0
libogre-1.9.0v5 >= 1.9.0+dfsg1-9~
libstdc++6 >= 5.2
libtinyxml2.6.2v5 -

Conflicts

Name Value
ogre-1.8-tools << 1.9.0
ogre-tools << 1.9.0

Download

Type URL
Mirror archive.ubuntu.com
Binary Package ogre-1.9-tools_1.9.0+dfsg1-12_amd64.deb
Source Package ogre-1.9

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install ogre-1.9-tools deb package:
    # sudo apt-get install ogre-1.9-tools

Files

Path
/usr/bin/OgreMeshUpgrader
/usr/bin/OgreXMLConverter
/usr/share/doc/ogre-1.9-tools/CommandLineTools_Readme.txt.gz
/usr/share/doc/ogre-1.9-tools/changelog.Debian.gz
/usr/share/doc/ogre-1.9-tools/copyright
/usr/share/man/man1/OgreMeshUpgrader.1.gz
/usr/share/man/man1/OgreXMLConverter.1.gz

Changelog

2018-10-20 - Manuel A. Fernandez Montecelo <mafm@debian.org>
ogre-1.9 (1.9.0+dfsg1-12) unstable; urgency=medium
* Bump Standards-Version to 4.2.1 (no changes needed)
* d/control: Use https in Homepage URL
* d/copyright: Use https in Format and Source URLs
* d/watch:
- Switch to version=4
- Update URL to use the most recent repository location
2018-05-04 - Manuel A. Fernandez Montecelo <mafm@debian.org>
ogre-1.9 (1.9.0+dfsg1-11) unstable; urgency=medium
* Bump Standards-Version to 4.1.4 (no changes needed)
* Update Vcs-* URLs (salsa)
* d/patches:
- add riscv64-support.patch (Closes: #897663)
2018-01-20 - Manuel A. Fernandez Montecelo <mafm@debian.org>
ogre-1.9 (1.9.0+dfsg1-10) unstable; urgency=medium
* Bump Standards-Version to 4.1.3 (no changes needed)
* Switch to debhelper compat level 11
* Set "Rules-Requires-Root: no" in d/control
2017-08-11 - Manuel A. Fernandez Montecelo <mafm@debian.org>
ogre-1.9 (1.9.0+dfsg1-9) unstable; urgency=medium
* Bump shlibs version due to GCC v7 ABI change (Closes: #871296)
2017-08-01 - Manuel A. Fernandez Montecelo <mafm@debian.org>
ogre-1.9 (1.9.0+dfsg1-8) unstable; urgency=medium
* Bump Standards-Version to 4.0.0 (no changes needed)
* Switch to debhelper compat level v10
- dh flags --parallel are not needed
* Update Vcs-* URLs
* Use automatic dbgsym packages, drop -dbg
2015-11-01 - Manuel A. Fernandez Montecelo <mafm@debian.org>
ogre-1.9 (1.9.0+dfsg1-7) unstable; urgency=medium
* Change for reproducible builds: remove timestamp from documentation.
Thanks Chris Lamb.  (Closes: #795462)
- d/patches: reproducible-remove-documentation-timestamp.patch
2015-08-13 - Manuel A. Fernandez Montecelo <mafm@debian.org>
ogre-1.9 (1.9.0+dfsg1-6) unstable; urgency=medium
* Release to unstable
2015-08-12 - Manuel A. Fernandez Montecelo <mafm@debian.org>
ogre-1.9 (1.9.0+dfsg1-5) experimental; urgency=medium
* Bump Standards-Version to 3.9.6 (no changes needed)
* Transition for GCC-5 with ABI change:
- rename library package to *v5
- in d/control, add Conflicts and Replaces on previous name of the
library
* Update Vcs-Browser link
* In -dev package, add -dbg to Suggests
* Address new lintian warning "embedded-javascript-library": add Depends
on libjs-jquery in the -doc package, and create a symbolic link
instead of install the local copy of the file "jquery.js"
* Update the location of Docs/manual in copyright file and resolve minor
issues (e.g. "dep5-copyright-license-name-not-unique" by renaming
"License: other" to "License: otherN")
2014-09-20 - Manuel A. Fernandez Montecelo <mafm@debian.org>
ogre-1.9 (1.9.0+dfsg1-4) unstable; urgency=medium
* Fix problem building GLES2 in big endian architectures (patch:
fix-rendersystem-gles2-big-endian.patch)
2014-09-12 - Manuel A. Fernandez Montecelo <mafm@debian.org>
ogre-1.9 (1.9.0+dfsg1-3) unstable; urgency=medium
* Enable support for GLES, thanks Bret Curtis
* Create new patch support-arm64.patch to try to fix FTBFS on this port

See Also

Package Description
ohai_13.8.0-1_all.deb Detects data about your operating system and reports it in JSON
ohcount-doc_3.1.1-2_all.deb Source code line counter - Documentation
ohcount_3.1.1-2_amd64.deb Source code line counter
oidentd_2.3.2-1_amd64.deb replacement ident daemon
oidua_0.16.1-9_amd64.deb audio file metadata lister
oinkmaster_2.0-4_all.deb Snort rules manager
okteta-dev_0.25.5-1ubuntu1_amd64.deb Development files for Okteta
okteta_0.25.5-1ubuntu1_amd64.deb hexadecimal editor for binary files
okular-backend-odp_3.1.0+dfsg-5ubuntu3_amd64.deb Okular backend for ODP documents
okular-backend-odt_3.1.0+dfsg-5ubuntu3_amd64.deb Okular backend for ODT documents
okular-dev_18.12.3-0ubuntu1_amd64.deb development files for the Okular libraries
okular-extra-backends_18.12.3-0ubuntu1_amd64.deb additional document format support for Okular
okular-mobile_18.12.3-0ubuntu1_amd64.deb mobile support for Okular
okular_18.12.3-0ubuntu1_amd64.deb universal document viewer
ola-python_0.10.7.nojsmin-1ubuntu2_all.deb Open Lighting Architecture - Python Classes
Advertisement
Advertisement