octave-splines_1.3.2-6_all.deb


Advertisement

Description

octave-splines - cubic spline functions for Octave

Property Value
Distribution Ubuntu 19.04 (Disco Dingo)
Repository Ubuntu Universe amd64
Package filename octave-splines_1.3.2-6_all.deb
Package name octave-splines
Package version 1.3.2
Package release 6
Package architecture all
Package type deb
Category universe/math
Homepage https://octave.sourceforge.io/splines/
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 19.95 KB
Installed size 105.00 KB
This package provides functionality to work with additional cubic
spline functions in Octave.  It contains interpolation functions
using cubic splines with various end conditions as well as functions
for differentiating splines and plotting them.
This Octave add-on package is part of the Octave-Forge project.

Alternatives

Package Version Architecture Repository
octave-splines_1.3.2-6_all.deb 1.3.2 all Ubuntu Universe
octave-splines - - -

Requires

Name Value
octave >= 4.4.1

Download

Type URL
Mirror archive.ubuntu.com
Binary Package octave-splines_1.3.2-6_all.deb
Source Package octave-splines

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install octave-splines deb package:
    # sudo apt-get install octave-splines

Files

Path
/usr/share/doc/octave-splines/NEWS
/usr/share/doc/octave-splines/changelog.Debian.gz
/usr/share/doc/octave-splines/copyright
/usr/share/octave/packages/splines-1.3.2/bin_values.m
/usr/share/octave/packages/splines-1.3.2/catmullrom.m
/usr/share/octave/packages/splines-1.3.2/csape.m
/usr/share/octave/packages/splines-1.3.2/csapi.m
/usr/share/octave/packages/splines-1.3.2/csaps.m
/usr/share/octave/packages/splines-1.3.2/csaps_sel.m
/usr/share/octave/packages/splines-1.3.2/dedup.m
/usr/share/octave/packages/splines-1.3.2/doc-cache
/usr/share/octave/packages/splines-1.3.2/fnder.m
/usr/share/octave/packages/splines-1.3.2/fnplt.m
/usr/share/octave/packages/splines-1.3.2/fnval.m
/usr/share/octave/packages/splines-1.3.2/tpaps.m
/usr/share/octave/packages/splines-1.3.2/tps_val.m
/usr/share/octave/packages/splines-1.3.2/tps_val_der.m
/usr/share/octave/packages/splines-1.3.2/packinfo/CITATION
/usr/share/octave/packages/splines-1.3.2/packinfo/DESCRIPTION
/usr/share/octave/packages/splines-1.3.2/packinfo/INDEX
/usr/share/octave/packages/splines-1.3.2/packinfo/NEWS

Changelog

2019-01-13 - Rafael Laboissiere <rafael@debian.org>
octave-splines (1.3.2-6) unstable; urgency=medium
* d/p/xtest-random-unit-tests.patch: Fix indentation of assert commands
(really, closes: 918747)
2019-01-09 - Rafael Laboissiere <rafael@debian.org>
octave-splines (1.3.2-5) unstable; urgency=medium
* d/p/xtest-random-unit-tests.patch: New patch.
Transform the randomly failing unit tests into xtest (expected
failure test).
(Closes: #918747)
2019-01-02 - Rafael Laboissiere <rafael@debian.org>
octave-splines (1.3.2-4) unstable; urgency=medium
[ Mike Miller ]
* d/control, d/copyright: Use secure URL for upstream source.
[ Rafael Laboissiere ]
* d/control:
+ Add Rules-Requires-Root: no
+ Bump Standards-Version to 4.3.0
+ Bump to debhelper compat level 12
* Build-depend on debhelper-compat instead of using d/compat
2018-02-10 - Rafael Laboissiere <rafael@debian.org>
octave-splines (1.3.2-3) unstable; urgency=medium
* Use dh-octave for building the package
* d/control:
+ Use Debian's GitLab URLs in Vcs-* headers
+ Change Maintainer to team+pkg-octave-team@tracker.debian.org
2017-12-29 - Rafael Laboissiere <rafael@debian.org>
octave-splines (1.3.2-2) unstable; urgency=medium
[ Sébastien Villemot ]
* d/copyright: use secure URL for format.
* d/watch: bump to format version 4.
[ Rafael Laboissiere ]
* d/u/metadata: Add publication year
* Use the dh-based version of octave-pkg-dev
* Set debhelper compatibility level to >= 11
* d/control:
+ Bump Standards-Version to 4.1.3 (no changes needed)
+ Use cgit instead of gitweb in Vcs-Browser URL
+ Add Testsuite field
2016-12-16 - Sébastien Villemot <sebastien@debian.org>
octave-splines (1.3.2-1) unstable; urgency=medium
[ Sébastien Villemot ]
* New upstream version 1.3.2
* Drop obsolete workaround for fixing file permissions.
[ Rafael Laboissiere ]
* d/u/metadata: Add citation
* Bump debhelper compat level to 10
* d/control: Build-depends on octave-pkg-dev >= 1.4.4
2016-06-26 - Rafael Laboissiere <rafael@debian.org>
octave-splines (1.3.1-1) unstable; urgency=medium
* Imported Upstream version 1.3.1
* d/rules: Fix file permissions
* d/control: Reword package description and fix typos
2016-05-28 - Sébastien Villemot <sebastien@debian.org>
octave-splines (1.3.0-1) unstable; urgency=medium
[ Sébastien Villemot ]
* Imported Upstream version 1.3.0
* d/p/relax-tps-val-unit-test.patch: drop patch, applied upstream.
[ Rafael Laboissiere ]
* d/control:
+ Use secure URIs in the Vcs-* fields
+ Bump Standards-Version to 3.9.8 (no changes needed)
2015-12-10 - Rafael Laboissiere <rafael@laboissiere.net>
octave-splines (1.2.9-1) unstable; urgency=medium
* Imported Upstream version 1.2.9
* d/copyright: Reflect upstream changes
* d/p/fix-unit-test-bin_values.patch: Remove patch (applied upstream)
* d/p/relax-tps-val-unit-test.patch: New patch
2015-07-25 - Sébastien Villemot <sebastien@debian.org>
octave-splines (1.2.8-1) unstable; urgency=medium
[ Rafael Laboissiere ]
* Imported Upstream version 1.2.8
* d/p/autoload-yes.patch: Remove patch (deprecated upstream)
* d/p/fix-unit-test-bin_values.patch: New patch

See Also

Package Description
octave-statistics_1.4.0-5_all.deb additional statistical functions for Octave
octave-stk_2.5.1-2_amd64.deb (not so) Small Toolbox for Kriging
octave-strings_1.2.0-4_amd64.deb additional string manipulation functions for Octave
octave-struct_1.0.15-2_amd64.deb additional structure manipulation functions for Octave
octave-symbolic_2.7.1-2_all.deb symbolic package for Octave
octave-tsa_4.4.5-4_all.deb time series analysis in Octave
octave-vibes_0.2.0-3_amd64.deb VIBes API to easily display results in Octave
octave-vlfeat_0.9.21+dfsg0-3build1_amd64.deb Computer vision library focussing on visual features and clustering
octave-vrml_1.0.13-5_all.deb VRML functions for Octave
octave-zenity_0.5.7-9_all.deb simple graphical user interfaces using zenity in Octave
octave-zeromq_1.3.0-4_amd64.deb ZeroMQ binding for Octave
octave_4.4.1-5_amd64.deb GNU Octave language for numerical computations
octavia-api_4.0.0-0ubuntu1_all.deb OpenStack Load Balancer as a Service - API frontend
octavia-common_4.0.0-0ubuntu1_all.deb OpenStack Load Balancer as a Service - Common files
octavia-doc_4.0.0-0ubuntu1_all.deb OpenStack Load Balancer Service - documentation
Advertisement
Advertisement