octave-msh_1.0.10-7_amd64.deb


Advertisement

Description

octave-msh - create and manage meshes for FE or FV solvers in Octave

Property Value
Distribution Ubuntu 19.04 (Disco Dingo)
Repository Ubuntu Universe amd64
Package filename octave-msh_1.0.10-7_amd64.deb
Package name octave-msh
Package version 1.0.10
Package release 7
Package architecture amd64
Package type deb
Category universe/math
Homepage https://octave.sourceforge.io/msh/
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 30.05 KB
Installed size 231.00 KB
This package creates and manages triangular and tetrahedral meshes
for Finite Element or Finite Volume PDE solvers in Octave, a
scientific computation software. It uses a mesh data structure
compatible with pdetool.  It relies on gmsh for unstructured mesh
generation.
This Octave add-on package is part of the Octave-Forge project.

Alternatives

Package Version Architecture Repository
octave-msh_1.0.10-7_i386.deb 1.0.10 i386 Ubuntu Universe
octave-msh - - -

Requires

Name Value
gmsh >= 1.6.5
libc6 >= 2.14
libgcc1 >= 1:3.0
liboctave6 -
libstdc++6 >= 5.2
octave >= 4.4.1
octave-splines -

Download

Type URL
Mirror archive.ubuntu.com
Binary Package octave-msh_1.0.10-7_amd64.deb
Source Package octave-msh

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install octave-msh deb package:
    # sudo apt-get install octave-msh

Files

Path
/usr/lib/x86_64-linux-gnu/octave/packages/msh-1.0.10/x86_64-pc-linux-gnu-api-v52/mshm_dolfin_read.oct
/usr/lib/x86_64-linux-gnu/octave/packages/msh-1.0.10/x86_64-pc-linux-gnu-api-v52/mshm_dolfin_write.oct
/usr/lib/x86_64-linux-gnu/octave/packages/msh-1.0.10/x86_64-pc-linux-gnu-api-v52/mshm_refine.oct
/usr/share/doc/octave-msh/NEWS
/usr/share/doc/octave-msh/changelog.Debian.gz
/usr/share/doc/octave-msh/copyright
/usr/share/octave/packages/msh-1.0.10/doc-cache
/usr/share/octave/packages/msh-1.0.10/msh2m_displacement_smoothing.m
/usr/share/octave/packages/msh-1.0.10/msh2m_equalize_mesh.m
/usr/share/octave/packages/msh-1.0.10/msh2m_geometrical_properties.m
/usr/share/octave/packages/msh-1.0.10/msh2m_gmsh.m
/usr/share/octave/packages/msh-1.0.10/msh2m_gmsh_write.m
/usr/share/octave/packages/msh-1.0.10/msh2m_jiggle_mesh.m
/usr/share/octave/packages/msh-1.0.10/msh2m_join_structured_mesh.m
/usr/share/octave/packages/msh-1.0.10/msh2m_mesh_along_spline.m
/usr/share/octave/packages/msh-1.0.10/msh2m_nodes_on_sides.m
/usr/share/octave/packages/msh-1.0.10/msh2m_structured_mesh.m
/usr/share/octave/packages/msh-1.0.10/msh2m_submesh.m
/usr/share/octave/packages/msh-1.0.10/msh2m_topological_properties.m
/usr/share/octave/packages/msh-1.0.10/msh2p_mesh.m
/usr/share/octave/packages/msh-1.0.10/msh3e_surface_mesh.m
/usr/share/octave/packages/msh-1.0.10/msh3m_geometrical_properties.m
/usr/share/octave/packages/msh-1.0.10/msh3m_gmsh.m
/usr/share/octave/packages/msh-1.0.10/msh3m_gmsh_write.m
/usr/share/octave/packages/msh-1.0.10/msh3m_join_structured_mesh.m
/usr/share/octave/packages/msh-1.0.10/msh3m_nodes_on_faces.m
/usr/share/octave/packages/msh-1.0.10/msh3m_structured_mesh.m
/usr/share/octave/packages/msh-1.0.10/msh3m_submesh.m
/usr/share/octave/packages/msh-1.0.10/packinfo/DESCRIPTION
/usr/share/octave/packages/msh-1.0.10/packinfo/INDEX
/usr/share/octave/packages/msh-1.0.10/packinfo/NEWS

Changelog

2019-02-09 - Sébastien Villemot <sebastien@debian.org>
octave-msh (1.0.10-7) unstable; urgency=medium
[ Kurt Kremitzki ]
* Add gmsh 4 support patch
[ Sébastien Villemot ]
* Update Build-Conflicts on libdolfin-dev
2019-01-04 - Rafael Laboissiere <rafael@debian.org>
octave-msh (1.0.10-6) unstable; urgency=medium
[ Mike Miller ]
* d/control, d/copyright: Use secure URL for upstream source.
[ Rafael Laboissiere ]
* d/control:
+ Add Rules-Requires-Root: no
+ Bump Standards-Version to 4.3.0
+ Bump to debhelper compat level 12
* Build-depend on debhelper-compat instead of using d/compat
* d/checkvar: Set DH_OCTAVE_TEST_ENV here instead of d/rules
2018-02-10 - Rafael Laboissiere <rafael@debian.org>
octave-msh (1.0.10-5) unstable; urgency=medium
* Use dh-octave for building the package
* d/control:
+ Use Debian's GitLab URLs in Vcs-* headers
+ Change Maintainer to team+pkg-octave-team@tracker.debian.org
2017-12-29 - Rafael Laboissiere <rafael@debian.org>
octave-msh (1.0.10-4) unstable; urgency=medium
* Use the dh-based version of octave-pkg-dev
* Set debhelper compatibility level to >= 11
* d/control:
+ Bump Standards-Version to 4.1.3 (no changes needed)
+ Add Testsuite field
2017-09-09 - Rafael Laboissiere <rafael@debian.org>
octave-msh (1.0.10-3) unstable; urgency=medium
[ Sébastien Villemot ]
* d/copyright: use secure URL for format.
[ Rafael Laboissiere ]
* d/p/continuation-lines.patch: New patch
* d/p/skip-dolfin-tests.patch: New patch.
Skip the unit tests related to the dolfin library, avoiding the
package to FTBFS. (Closes: #874138)
* d/control:
+ Use cgit instead of gitweb in Vcs-Browser URL
+ Bump Standards-Version to 4.1.0 (no changes needed)
2017-01-24 - Sébastien Villemot <sebastien@debian.org>
octave-msh (1.0.10-2) unstable; urgency=medium
[ Rafael Laboissiere ]
* d/p/autoload-yes.diff: Remove patch (deprecated upstream)
* d/control: Use secure URIs in the Vcs-* fields
* Bump Standards-Version to 3.9.8 (no changes needed)
[ Sébastien Villemot ]
* Add Rafael Laboissiere and Mike Miller to Uploaders.
* d/rules: ensure that, in the testsuite, gmsh is not run in a fakeroot env.
(Closes: #850402)
* Bump to debhelper compat level 10.
* d/watch: bump to format version 4.
* d/clean: add files generated by src/configure script.
2014-02-27 - Sébastien Villemot <sebastien@debian.org>
octave-msh (1.0.10-1) unstable; urgency=medium
* Imported Upstream version 1.0.10
* debian/copyright: reflect upstream changes.
* Update Build-Conflicts against dolfin to version 1.3.
Hopefully dolfin will soon be fixed and we'll re-enable the dolfin support.
* configure-script-source.patch: new patch, adds source of configure script.
2013-12-22 - Sébastien Villemot <sebastien@debian.org>
octave-msh (1.0.9-1) unstable; urgency=medium
[ Sébastien Villemot ]
* Imported Upstream version 1.0.9
* debian/copyright: reflect upstream changes.
* Stop builing against dolfin.
That package is currently in bad shape and not in testing. Moreover, one
octave-msh test fails badly when compiled with dolfin.
[ Rafael Laboissiere ]
* Bump to Standards-Version 3.9.5, no changes needed
2013-10-27 - Sébastien Villemot <sebastien@debian.org>
octave-msh (1.0.8-1) unstable; urgency=low
[ Sébastien Villemot ]
* Imported Upstream version 1.0.8
* debian/copyright: reflect upstream changes
* Convert the package to arch:any
* Add libdolfin1.2-dev to Build-Depends.
The dependency is versioned to workaround a bug in dolfin 1.2.0+dfsg-2
* debian/clean: add msh.xml
[ Thomas Weber ]
* debian/control: Use canonical URLs in Vcs-* fields
[ Rafael Laboissiere ]
* debian/copyright: Use octave-maintainers mailing list as upstream contact
2012-10-29 - Sébastien Villemot <sebastien@debian.org>
octave-msh (1.0.6-1) unstable; urgency=low
[ Rafael Laboissiere ]
* Imported Upstream version 1.0.6

See Also

Package Description
octave-mvn_1.1.0-2_all.deb multivariate normal distribution clustering for Octave
octave-nan_3.1.4-5_amd64.deb handles data with and without missing values in Octave
octave-ncarray_1.0.4-2_all.deb access NetCDF files as a multi-dimensional array in Octave
octave-netcdf_1.0.12-2_amd64.deb Matlab compatible NetCDF interface for Octave
octave-nlopt_2.4.2+dfsg-8build1_amd64.deb nonlinear optimization library -- GNU Octave package
octave-nurbs_1.3.13-5_amd64.deb non-uniform rational B-splines for Octave
octave-octclip_1.0.8-5_amd64.deb boolean operations with polygons in Octave
octave-octproj_1.1.5-4_amd64.deb GNU Octave bindings to PROJ.4
octave-openems_0.0.35+dfsg.1-3build1_amd64.deb Octave interface for openems
octave-optics_0.1.3-2_all.deb optics functions for Octave
octave-optim_1.5.3-2_amd64.deb unconstrained non-linear optimization toolkit for Octave
octave-optiminterp_0.3.5-2_amd64.deb optimal interpolation package for Octave
octave-parallel_3.1.3-2_amd64.deb parallel execution of Octave in clusters of computers
octave-pfstools_2.1.0-3build4_amd64.deb octave bindings for pfstools
octave-plplot_5.14.0+dfsg-3_amd64.deb Octave support for PLplot, a plotting library
Advertisement
Advertisement